Roon ROCK UEFI Intel NUC not showing HDMI output

Roon Core Machine

Roon Optimized Core Kit
OS: RoonOS 1.0 (build 254) production
Intel NUC11TNB, i5, 16GB RAM

Networking Gear & Setup Details

via LAN

Connected Audio Devices

Smart TV Samsung Series 8 via HDMI

Number of Tracks in Library

30,000 tracks

Description of Issue

Good Day Community,

The installation Roon Rock with UEFI works fine with Intel NUC11TNB. But I`m facing the Issue that the HDMI output is not showing up in Roon, only the airplay Devices. If i install Ubuntu-OS on the NUC Machine and then install Roon Server, it works fine and the HDMI output shows up.

Question 1: Is there a driver Issue ?
Question 2. Does Roon Rock not supported NUC11TNB the HDMI Output ?
Question 3: Is there any Solution ? Because I checked the BIOS Settings as well and HDMI/Audio/USB-C Type is active → Advanced → Onboard Devices ->HDMI/Audio is checked

Or is something wrong with the last Roon Rock FW-Update ?

Many thanks for your support and help.


I have a NUC 12, for which UEFI boot is the only option. I have the same issue where no HDMI output is detected by ROCK. By comparison, I also have a NUC 8, which still allows legacy boot, and HDMI audio works just fine.

I have the exact same issue with a NUC8i5BEH. No HDMI output as an option, only airplay. @Jinwei_Hao gave me an idea with the post above. I’m going to try and reflash ROCK on the NUC with the legacy boot option and see how that goes.

Hi All,

Thanks for the reports here.

@audio_flow - I noticed that your Roon Core has not been online since your report. Can you please update to the latest Roon release and check to see if it has any impact in behavior?

@Jinwei_Hao - According to our diagnostics, it looks like your HDMI zones are working again. Can you please clarify if this is accurate and what you ended up doing to resolve the issue if so?

@MikeS54 - Yes, that would be an interesting test. I’ve also enabled logging for your account and I’m noticing a strange trace in your logs, I will check with the team on this.

I have got three Roon Rock devices, a older NUC 8i3BIH2 and a recent NUC11ATKC2 and an embedded device. On neither nor the HDMI output is showing. Although with Roon on Windows installed, the HDMI audio actually works on the two Intel NUCs at least. But I am unhappy about the Windows performance which is much better under ROCK. I installed the newest ROCK version and Server software. Will there be a solution?

Hello All,

I checked with the team regarding your reports, and I have some good news - we have just submitted a potential fix for this issue to the RoonOS earlyaccess testing branch.

If you wish to try the release on your end and check to see if it resolves the issue, you would need to follow the procedure outlined below.

Please note that this is a RoonOS (Operating System) earlyaccess release, and this differs from the regular Roon/RoonServer earlyaccess program.

If you are already enrolled in regular Roon/RoonServer earlyaccess testing, you will still need to use the below instructions to switch the OS branch over to test this update.

Please also ensure you have made a recent backup of your Roon database.

Instructions on how to switch to earlyaccess RoonOS branch:

  1. Download the RoonOS instruction file from the below link and save it on your computer - do not modify the name, extension, or content of this file.
  1. Navigate to the /Data/Reinstall directory on your ROCK.
  2. Copy the instruction file that you downloaded into the Reinstall directory.
  3. Visit the RoonOS Web Administration Page and click on the “Reinstall” button.
  4. Ensure that your Web Administration Page says that you are now using RoonOS build 255
  5. Let us know if this resolves the issue on your end

Further instructions on the Reinstall functionality can be found in this article:

Hope this helps and do let us know how it goes!

Just to pile on…

I hav a NUC6i3 running ROCK (but 1.8 since it is just for playback) and it will not output through HDMI either. I can confirm it played through the HDMI 8 months ago (I don’t play multichannel a lot).

can you try early access builds?

also, its worth noting that this fix is only on the EFI builds of ROCK (for now).

Thanks noris. It didn’t make a difference on the NUC. Still shows NUC as a PCH (I believe, don’t have a screenshot handy). No HDMI option for output.

I’ll try this early access build over the weekend and report back.

1 Like

Disregard my issue with the NUC6i3. It functions perfectly. The sample rate was reset (to 192khz, which my system cannot accept) during a number of power outages and I did not double check this setting until just now.


So after using the early access OS ,I see this now! Going to do some testing with it to verify.


Seems to be working! Nice!


Hi Noris,

the new release indeed fixed this bug, so fien for my core! Thanks.

But let me report a regression it introduced on my endpoint (another NUC with a Pro-Ject DAC Box S2 +).
After the update, the HDMI Ports were also showing here, but strangely the max loudness of the DAC was reduced by at lease 90% by switching to DSD DoP, so even at the highest loudness level, the sound was barely noticeable. This even was the case after changing back to PCM.
I changed nothing on the settings.

Converting back to the production build 254 solved the issue again. So this was introduced with the 255, I suppose.

HDMI DoP likely is the problem. HDMI devices do not support it, only PCM or DSD.


1 Like

@noris, yes, the HDMI zone is working again because I gave up on NUC 12 (for now), and switched back to my old 8th gen NUC.

1 Like

No, the problem occurred on the the Pro-Ject S2 Plus, which does not have HDMI, it is connected via USB to the NUC. This one was showing the loudness problem, strangely. But this happened due to the prerelease 255, maybe this is not connected to the HDMI problem at all…

1 Like

The reinstall of the earlyaccess worked for my issue I was having with my new NUC, NUC11PAHi7, I was only showing the 3.5mm as an option. After switching to OS Version 1.0 (build 255) earlyaccess I now have HDMI 0-11 and HDA Intel PCH ALC256 Analog. Thank you so much!!!

1 Like

So i noticed today that the ARC app on my phone is constantly hanging up and asking to close (Galaxy S22). It worked fine before on the old ROCK. Would this be an issue with tbr early release? Or would they not be tied together?

NICE! Good to hear @Brian_Scafaro