Roon ROCK unable to login to Roon account

Core Machine (Operating system/System info/Roon build number)

Intel Nuc7i7bnh, Samsung 970 Evo NvMeM.2 250gb for operating system, Kingston Ram x1 8gb, Seagate Firecuda 1tb for storage, Roon Rock operating system version 1.0 (build 227) server software version 1.7 (build 710)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router Newcom NF4V on fibre connection, internet switch D-Link DGS-1008A internet switch 8 port to run all AV, Hifi equipment (connected to internet switch Roon Rock Intel Nuc7i7bnh, Intel Nuc7i3bnh for remote & endpoint running Windows 10pro, Oppo UDP-205, Chromecast Ultra, LG 58UF830T Tv) Intel Nuc6i5syh running direct from router as remote / PC, all hardware above is hardwired. Remotes also used Samsung S20 Ultra 5G, Samsung S8, Samsung S7.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Oppo UDP-205 directly from Roon Rock via USB & sometimes via network, AudioQuest Dragonfly Red plugged directly to above phones.

Description Of Issue

Since last update slow at loading on Android app on Samsung S20 Ultra, missing artwork. Seamed to work fine on both windows 10 PCs. Have rebooted router several times, disconnected power supply for router, internet switches PCs overnight, bypassed internet switch & connected directly to router still had same issues. Rebooted Rock machine several times same issues, then wouldn’t log into Tidal tried several times, managed to log into Tidal but slow, then coming up with network error. Updated Bios on Rock machine seamed to be better for a few hours then same issues started to persist, rebooted Rock again wouldn’t even bring up anything on main screen just continuous loading symbol then network error. Have reinstalled Rock operating system, reset database & settings, done restore from a backup up, really slow at doing restore only have a small libary about 700 albums. Once restore was done entered email address and password, really slow at logging in, wouldn’t log in have tried several times just comes up with network error, tried to log into Roon and changed settings for Rock from hardwire to wifi still no difference. Internet working fine with all other devices have got Audirvana on another PC with Tidal integration and is working fine. Have also called my ISP everything fine at their end according to them. Just wondering if it is a problem with Roon account as not logging in.

I think your DNS server address is what is causing the problem. Can you find what the DNS server is for other devices on your network? You can also try resolving it by resetting your network gear, which should automatically assign the correct DNS server. If you want, you can try using Google DNS or Cloudflare DNS. Cloudflare is and Google is or You can try entering one of those and see if it helps

1 Like

Thanks for that I’ll give it a go and let you know.

Regards Luke

This is a good suggestion as test but do note that most residential routers do set themselves as caching DNS servers. They then perform pitifully and cause all kinds of problems. I don’t doubt the rest of the devices on the network will be set with the same address… but changing ROCK to use one of the addresses you proposed is a good test.

There is nothing wrong with DNS in that setup. it’s using the Router as local DNS server. it in turn will use ISP DNS servers unless they have been changed on the router side. This is standard for home network. You don’t need go changing DNS on individual devices as you then need to use fixed up especially on ROCK you can’t just change it without then moving of DHCP which likely cause more issues. Let your router manage it. It’s what its for after all.

Also in noone hould you have to change from your ISP DNS to get Roon to work, if they do there is something wrong with Roon it you need a better ISP. If you do change them do it on the router then this will apply to all devices on the network.

Personally I found Cloudflare and Google much slower than my ISP and caused more issues. I am sure Roon only recommend Cloudflare as they are hosted by them so assume it will resolve better, it doesn’t my ISP wipes the floor with them in consistent tests.

1 Like

Changed Dns on tried , , still made no difference. I could put my core onto my windows 10 Nuc7i3bnh just to get Roon running for now, seems to log into Roon using same dns as Rock.

Hi @Luke_Jericevich1,

Happy New Year! In this screenshot, I noticed that you are using two network interfaces for your ROCK, can you please confirm you only have one active at a time? I wonder if the secondary interface active may be causing an issue.

Hi Noris

Tried my Rock Nuc over at brother’s worked perfect straight away. Tried back on my network now working but slow, tried another port on router seems to be alot better but occasional drop outs. Have a new router on its way think that is the problem, thanks will keep you posted.

Regards Luke

1 Like

Thanks for the update @Luke_Jericevich1, do let us know how it goes!
I would check both of your network adapters on ROCK as well.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.