Roon-Rotel RA 1572 USB 2.0 not working

Hi, bought a new Rotel Amp and Roon is not working at all. I had a CA DacMagicPlus and Roon was working without problems,
Tidal is working ( Rotel PC-USB Audio 2.0 ) and qobuz is working as well ( Rotel PC-USB Audio 2.0 )
Rotel Driver installed, working without problems.
Setting in Windows Sound Options is 24/192
Dell Desktop i7 with Win 10pro, Wifi
Roon: No sound at all! If I click on an album, it just does not start with track No1, it “runs” through all of the titels and then it does not start playing a single song. If I click on a single song, nothing…
I deistalled Roon and installed it again, same problem…
If I click on a playlist, same, it runs through all the songs on that playlist and then…nothing…not a single song of the playlist can be played.
roon radio does not work either!!
Thank you, Lambert

Hello @Lambert_Brunner,

Can you please share a screenshot of your Roon Settings -> Audio tab? It should look something like this:

Have you made sure that the Rotel is powered on and you have selected the correct zone from the Zone Picker?

Hi Noris, thank you very much for the quick reply. Here the screenshotsgrafik

I am just listening with Audirvana Player. Works fine with Tidal and qobuz. USB 2.0

Thank you for your help
Best regards, Lambert

In the screenshot you seem to have system output selected instead of rotel?

And in the Audio Settings screenshot, there is an ASIO driver for the Rotel that has not been enabled. What happens if you use that instead of the WASAPI channel?

Hi, Ged
Does not matter what output I select, no one is working

have you rebooted the PC with the rotel still powered on and connected.
Also try rebooting the roon server.

1 Like

Hi Ged,
no, but I did just now.. It is working!!!
Rotel USB 2.0 Asio driver
Thank you so much and a nice day to the US of A
Best regards, Lambert

1 Like


Hi @Lambert_Brunner,

Glad to hear that a reboot sorted everything out!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.