Roon running in Docker on UnRaid 6.x

Looks like the ronch docker hasn’t been updated since 2016. I’ll be doing a VM and installing on an Ubuntu VM on unRaid instead of a Docker.

what updates would you like ? it pulls the latest Core binary from Roon’s servers on startup…

1 Like

I have an itch to try the docker way, currently running roon in a VM. I can get roon up and running, but for the life of me I cannot work out how to point roon to the music share on my unraid server.

I tried adding to the template a new path to the music folder, click save run it again but still in roon when adding a lirbary I cannot find my music any where.

Where in the roon adding library bit should I find my music share from unraid?

My folders are as follows, if it helps?

/var/roon > /mnt/user/data/docker/roon/library/
/music > /mnt/user/Music/
/opt -> /mnt/user/data/docker/roon/application/

Yes but how are you creating that?

I dont have a nice template just a blank one I have to create new entries from scratch.

In edit configuration I am putting:

Config Type: Path
Name: Music
Container Path ??? - I have put nothing here
Host Path: /mnt/user/Music/ (This is my music share on unraid)
Access mode Read/Write

Back in roon there is no evidence anywhere that mnt exists, in mnt/users/ roon says its blank, but I have checked every folder. I suspect I am just looking through the docker containers programme files.

If anyone can help me out, I know its me. However all other dockers on unraid have nicley laid out templates where as I have nothing to go on with roon

See here.

See the fourth and fifth pictures in the UnRaid forums thread.

Do exactly as is shown.

This includes putting /music in the container path field that maps to the /mnt/user/Music host path ;-).

1 Like

Hi there, sorry I forgot you had responded to me on the other thread. I am still unsure though.

IN runraid I have to Add another Path, Port, Variable, Label or Device

In there is a bunch of stuff to fill out, what and where am I filling out?

Fill out as needed. Depending on which docker you use, it might differ. If you’re unsure, refer to the unraid forums thread (I’m not saying this to be dickish, it’s just that it… works…).

The screencap before the Roon login screen (so the one that reads “add configuration” on top) shows how to fill the path to /music, just rinse/repeat for the others with /app , /data and /backup to match the “here’s the setup” screencap.

Container path is what the Roon docker sees, host path is what it maps to on your array.

Hi there, ok I found the missing link on the unraid forum, I was failing to fill out the container section which I think is linking the container to the unraid share,. Its up and running now!


Ah; glad to see…this thread is active.

I just got the ROON Core Docker, running on my uR box; but having some issues…pulling my library.

I posted at uR; but they probably can’t delve, into ROON…and I was afraid, ROON members wouldn’t know uR, lol.

Here’s my set-up…

No love? :expressionless:

Looks like you are using a different docker image so need to match the paths with what it requires. (

My paths are here -> Roon running in Docker on UnRaid 6.x

I never got the steefdebrujin docker to work so I use mikedickeys with these mappings:

I was running Roon core and my music on an Unraid 6.7 NAS for a month and it was great. This thread helped.

Yesterday I updated Roon build 521 and it stopped working. Now my remotes cannot find the core. I reported to support, subject is “Build 521 - Can not find Core on Unraid 6.7”. Have any other Unraid users had this problem, or not had it, when updating to 521?

I just want to listen to music, but at the moment roon is extremely high maintenance, with constant stuttering, disconnections, Tidal just being a waste of space.

Support need masses of data for each issue and running a business I just don’t have time to debug this stuff.

I built my own docker image yesterday with the latest debian and I still have the same problems as before, so the short answer is I don’t believe it is unraid, but I haven’t had time to try and track it down further,

With 521 its got worse, but I have just gone to Tauon Music Box and got back to listening to my music :slight_smile:

Sorry to hear. Thanks for the update. My Unraid w Roon was working very very well for a month or two, until update 521, then it does not work at all. My remotes are wireless, but the path on which the music flows is entirely wired Ethernet.

All playing fine today, no hiccups :slight_smile:

Thanks Magnus. So…not that I know, it really made any difference; because I am still missing some step. But I went ahead, and switched to Mike Ds app. Set-up like you


But my remote…is still not pulling in, my music.

Now…I guess I have to add that folder, under Storage (which seems weird to me. I mean…why create a path…pointing to my music, on the Server; only to have to do it again at the Remote…but…)

But I can’t seem to get it to take anything. I’ve tried /music and /mnt/user/unMUSIC/New ROON

yes, you have to add the folder in roon -> settings -> storage, your music will be found inside /music:

why create a path…pointing to my music, on the Server ; only to have to do it again at the Remote …but…)

If you don’t map the share, roon (docker) doesn’t know it even exists.
The server (unraid) is what is hosting all the files, the Remote or docker instance is only given access to it.

So from what I can tell you have made a share on unraid named unMUSIC with a Folder called “New Roon” and you have mapped this folder to /music in the roon docker.
Put your music files inside the “New Roon” folder and and they should get picked up.

1 Like