Roon running incredibly slowly on Mac and won't play - log full of 'unknown track'

UI incredibly slow responsiveness, on server and iPad client. Even Overview page just shows wobbly Roon icon for minutes. Tried restarting the Roon server software - no difference. Log is full of thousands of
02/27 17:58:55 Warn: itunes: unknown track ‘11989’ in playlist ‘5 star’ (F0F6FFD1A0E799EB). Sitting there burning 120% cpu but not letting me play anything. ‘Overview’ finally appeared after 10 minutes, but still can’t play anything. No other process is busy.

Just when I thought Roon was starting to behave better! This is Roon 1.1 (build 102) stable (64-bit) on a brand new Mac Mini running OS X El Capitan.

Going to try restarting the Mac. Everything else works fine.
Update: That didn’t help. Roon still incredibly slow after the reboot and won’t even show me the Overview page for ages. I hit play on the previous queue and TEN MINUTES later it started playing. All I’ve done recently is imported about 4 CDs into iTunes. The spinning wheel of import is turning, and says “Of 150 tracks, 0 added, 0 identified” in the popup. It does display the TIDAL page, but when I got back to Overview it gets stuck again.

Update: an hour later, and I can’t connect to Roon server from an iPad. On the server, the import wheel has stopped spinning but it won’t let me see “Overview” or do searches or anything. It’s still sitting there burning 130% cpu. :frowning: :frowning: :frowning: :frowning: Again, the TIDAL page comes up instantly, but Overview and search and actually playing music are completely broken.

On the same Mac, I tried to play music from iTunes and it worked INSTANTLY. As always.

1 Like

Hi Paul,

I’ve shifted your post into Support. Let’s drop some flags for @kevin and @vova to investigate.

Thanks @andybob. Finally, 15 hours later, I restarted Roon again and it has come back to life. I have no idea what it was doing all that time.

Hi Paul,

Pleased to hear you are running again, but you may yet hear from devs requesting logs if they regard you as an “interesting case”.

There was a wise person on these forums who noted that you could ask software developers to write a program with a specification like actual observed bugs and they would say it was impossible. Sometimes software gets itself in all sorts of knots. I blame cosmic rays.

Make sure to post back in this thread (or start another) if this should recur.

Hello @pcwilliams,

Apologise for an issue, would you mind to share Roon logs with us so we can check what has happened.

You’ve pointed out that Roon was running on a new Mac Mini, was it your first run on this device ?


Hi @vova, this is a Mac Mini I bought 2 months ago specifically to run Roon. Mac Mini (Late 2014) 2.8 GHz I5, 8 GB RAM, Running OS X 10.11.3. You Roon folks know all about my Airplay woes - much better recently since I ditched all my ethernet-over-power and moved to brand new 1G switches and wired ethernet everywhere - but yesterday was the first time the UI also stopped working. All I’d done recently was import a few CDs into iTunes (this Mac runs iTunes all the time). It feels like Roon spent about 20+ hours trying to re-import the library, and while it was doing that, the server UI was completely unresponsive - as well as all remote UI on iPad etc - and it only managed to play one album after a 25 minute delay between hitting play and hearing music. Nothing else was running on the server except the standard screen-sharing service (the mac is headless). My wife was very sad as all I was doing was trying to put some music on for dinner - needless to say the dinner went cold and my wife got cross. I will send the logs. Problem was happening around 18:00 uk time on Sat Feb 27 2016. Thanks