Roon running slowly, especially streaming

Core Machine (Operating system/System info/Roon build number)

Mac Mini 2018, 3.2Ghz 6-core i7, 32GB RAM
OS Catalina 10.15.3
WD 8TB external drive with library
Roon 1.7 (511)
Xfinity service provider
Motorola cable modem/hub
Google home wifi network
Mac --> Ultrarendu Sonore --> Benchmark DAC3 --> Bryston 4BSST --> Magnepan .7s/Sumiko subs


I restarted my computer as I often do when Roon bogs down and runs a bit slowly. However, this time when Roon starts up it loads very slowly, Qobuz doesn’t work, and there is a lag with all of the controls of close to a minute (press play, 1 min loading time; press pause, 1 minute delay). I check it with Tidal and it does the same. Even my home library on the external HD is slow, although a bit quicker. I clear the cache, shut down all other programs, check Activity Monitor, and nothing else is running except the Mac program that manages heat and throttles the processing. I shut the computer down to cool it, restarted it after about 30 minutes and the process repeats.

I have not done anything recently that is taxing for the Mac. In fact, all I did new was delete the Mac’s cache to help speed things up. I’ve shut off Spotlight and other processing hogs, and Activity Monitor says not much is using processing/memory/network time except Roon. But it continues to be very slow. Other apps run quickly and normally, such as Qobuz and Tidal’s native apps, iTunes, and Chrome.

What is going on here and what can I do to speed Roon up. This is not an old Mac Mini and it has a fast processor and plenty of memory to do this.


I am noticing the problem has less to do with library management, since it can search and show albums in my library with only minor delays. However, the player and the audio devices seem messed up. The player has long delays and the devices that used to show up go in and out. My Chrome Audio devices didn’t show up, and then popped up randomly last night. Now, it shows no audio devices at all. The fan continues to run after a night of no major computer program operating except Roon. What might be causing all of this?

I also performed an SMC reset, and it didn’t fix the problem. The devices seem consistently identified, and the library works (~28K songs), albeit slowly. But the player excruciatingly slow, and virtually unusable. Any suggestions?

Hi @Joe_Bandy,

What is CPU / GPU usage like during the time that Roon is running slowly?

Hi Dylan,

Here is a screenshot. I reinstalled Roon and it is still giving me the same problems. It also has returned to not recognizing any audio devices, too – my Google Chrome Audio devices, my UltraRendu, or another Mac that I have across the house. It doesn’t seem like it is overtaxing the i7 processors, but the player functions of Roon are unusable.

Thanks for any advice in advance,

Oh, and it is not loading my library from Qobuz either. Ugh.

Hi @Joe_Bandy,

How exactly did you reinstall Roon? This is a good step to try, but I would also make sure to set your old database aside to see if this helps:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Verify if the same behavior occurs with a fresh database
  • After verifying the fresh database for a day or two try restoring the backup

Hi @noris,

Yes, that’s the procedure I saw on another thread and followed. I am letting the old backup restore completely before seeing if it happens again, since it is working hard to compile everything. If it does, I am guessing it has something to do with Roon’s network and playback functions, so I will try to reset the network devices, too. Any other advice would be appreciated.


Have you tried restarting everything from scratch , modem, network etc wait until all that has started then start the pc?

Hi @noris, @dylan, and @Mike_O_Neill

Thanks for the questions and suggestions, but unfortunately the problems continue. Roon has been reinstalled via the process above, the backup has been restored, I have done SMC and NVRAM resets on my Mac, and restarted the entire network. When I restarted Roon after all of this, as usual, everything looked fine initially.

However, the symptoms recurred almost immediately:

  1. Roon does not download Qobuz albums that were part of the library (although it shows Qobuz recommended albums and playlists);
  2. the player is delayed by about a minute between play/pause and response (regardless of its source – TIdal, Qobuz, or my local HD), and it takes several (2-10) minutes to load new songs from the queue; and
  3. the Audio Devices are inconsistently identified, first showing everything, then dropping all Google speakers and Chromecast Audio devices, and sometimes dropping the UltraRendu and other computers in the house.

In another effort to troubleshoot, I decided to bypass the network hub/switch/streamer chain and feed the DAC directly from the Mac. When I went to enable the device and rename it, Roon crashed. I restarted it and tried again, and the player functioned more smoothly for a few songs, with little delay. Symptoms 1 and 3 continued, since my Qobuz library is not loading and the Google devices on the network get dropped after a few minutes (interestingly, it seems to either recognize my other computers in the house or the Google devices, but not both). So this didn’t solve my problems.

I decided to troubleshoot the Google network hub/switch/UltraRendu chain. The UltraRendu web manager said it was functioning fine, and I was able to stream music to it with no delay from other sources. So I guessed it is either the switch or the Google Hub, or potentially cables in between them. The switch and cables are unlikley, since nothing has changed with them at all - I haven’t touched them. I unplugged/replugged the switch and it seemed to work as normal. Therefore, I guessed that it is the Google Hub-Roon communication, especially since the device recognition issues are occurring around Google devices. I unplugged the Google Hub and replugged it, and things are working better.

Symptom 2 is better. The play functions are still slow and not as automatic as they used to be, but I am getting delays of seconds not minutes.
Symptom 3 is better for now, with all devices remaining stable for about an hour or so. (we’ll see)
Symptom 1 is still a problem and unaffected by any of this. I can play Qobuz albums that show up on the main Roon page, but my own library from Qobuz is not loading at all.

Any further suggestions?


I think the last reset of the network did the trick and things seem to be back to normal. Qobuz is now back and the player seems to be functioning without delay.

I don’t know why Qobuz would be more impacted by Google Hub issues than Tidal, or what could have possibly caused the disruption with the hub, since no changes were made anywhere in the network. If there are any explanations of this, I’d love to hear it.

I also wish Roon had been more active in helping with this situation.


Hi @Joe_Bandy,

Glad to hear that the system is back in working order since the latest reboot of your Google Hub!

The symptoms you posted sound very strange, so hopefully it is resolved, but if it does re-occur I would suggest testing on a fresh database (as in following the above instructions and not restoring the database), as this would tell us if the old database is problematic or if the issue is elsewhere.

I understand that setting the old database aside will limit your library, but as a test it would be a very useful one. In any case, if you experience any further issues do let us know and we’d be happy to take a look. Thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi Noris,

The problem has returned. Same as before. I came home and Roon was not identifying any devices through the network. I restarted Roon and the Google Hub again, and it worked for a short time just fine. Then it did not. The delays in the player are back, as are the problems with Roon identifying all of the devices.

Any thoughts about what is causing this, and what can be done to fix it once and for all?


You mentioned last time that reinstalling Roon without backing it up would be a good way to test it. However, I don’t want to lose my playlists or any settings in Roon. Also, it doesn’t seem like the database is the problem, since the library functions work just fine now. It seems to access Tidal, Qobuz, and my local library and navigate it with no problem. It seems to be the player and device recognition functions of Roon that are causing the problem. How would reinstalling Roon and having it generate a new database solve this problem?


Hi @Joe_Bandy,

I have merged your posts into the previous thread and have re-opened it so that we can take another look.

As for next steps here, can I please request that you access your Roon logs by using these instructions and upload them to Dropbox / Google Drive and private message me a link?

I would like to take a look at them to see if there are any clues. Thanks!

Hi @Joe_Bandy,

Thanks for sending those logs over. I have been looking through them and there appears to be quite a bit of networking errors and database activity contained in all of them which could explain some unstable behavior here.

The reason for why this activity is happening is not entirely clear, but I am seeing your Roon remotes disconnect and reconnect multiple times a minute and Roon trying to re-process multiple objects in your library. As the next step, I suggest that we try the fresh database to narrow down if this is network-related or database-related.

I realize you won’t temporarily have any playlists or settings, but to proceed here can I please ask that:

  • You set the current library aside using my previous Roon -> Roon_old instructions
  • Start fresh (with no backup restored)
  • Verify if you run into any issues
  • Run Roon in the fresh database configuration for the weekend
  • Send me logs once more

Thanks @noris,

I can’t reply to the reopened thread, since I don’t think you have allowed replies in it. So I will reply here.

The logs you see make sense. It definitely looks like Roon is working hard to deal with the devices, and is slowed because of it in the database management (somewhat) and the player (unusable).

I am happy to test with a refresh of the database, but if it works, how would I restore the playlists and settings without restoring some of the problems of the old database? And what could I have done in managing the database that would cause this?


Hi @Joe_Bandy,

Apologies you couldn’t reply on the thread, it seemed to have auto-locked last time we marked it as Resolved, but I just re-opened it so now you should be able to reply.

This is not exactly clear yet, but testing on the fresh database will allow us to rule out the old database as part of this issue. The restore process is an “all or nothing” process, you can’t restore specific parts of the database, but if you have older backups we would at least know we have to head down this route. Can you confirm if you have older backups of your database?

My suggestion would be to try using the fresh database so that we can separate the issue further. If the fresh database works as expected, we can try restoring one of your older backups (but please let’s confirm that the fresh one does indeed work properly).