Roon seaching takes for ever

Since a day it two we have a problem searching in Roon for artists. I can really quick filter in my own library and find the artist, but once trying to search using the “mirror glass” in the top right it takes for ever. Cannot point my finger on the cause of the problem. I haven’t change anything. Music 3000 albums on NAS, Tidal and Qobuz subscriptions. Roon core runs on a Mac Mini dedicated for this task only. Streaming to Devialet Expert Pro.

Anyone an idea where to look?


Have tried rebooting the roon server?

There have been issues with there search servers ever since 1.6 and the introduction of Qobuz. They have greatly improved it but it does still choke every now and then possibly still related to this.

Naturally, that is the first thing I do when I have such problems with the database.

Probably a good idea to give details of what you have already done so the preliminaries arent repeated :wink:

Hi @Philip_Feenstra,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this occur with every search? If you search for the same thing multiple times does it occur each time?

Hi, @dylan,

Thank you for checking out my problem. I have an internet router and a switch with my 11 network addresses in the house. There are two switches included an one Apple Airport Extreme for the wireless connections. All cables are hi-end Meicord Ethernet 700 cables. The Roon core is running on a Mac Mini running the core only. The Roon control on iPhone X max, iMac (WiFi connected) and iPad, they all run fine and showing the same. I have this running for two years of more without any problem.

This however is interesting:

I have a Tidal and a Qobuz subscription. With either one of those services enabled, the problem occurres. Only when both are disabled the search is as expected. With Tidal enabled, for example: I can not find any “Boz Scaggs” for instance. Not only one album. But when I look in “Albums” in my library the Boz Scaggs albums from a Tidal are all there. I also can select the “Filter” (second top from the right) to find the Biz Scaggs albums I was looking for on Borge the NAS as Tidal. Only the “Search” function seems not to be okay. Very disturbing.

Any ideas?


Problem solved!

Apparently the streaming source is causing the problem. As I am streaming from Tidal in the car the Tidal app is still open when starting Roon by the time I reach home. Normally Roon takes over the services so far. I closed the Tidal app on my iPhone which solved the problem. Roon now can search as before. Unclear it is to me why I never experienced this before.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.