Roon search does not show results for multiple artists

Roon search is not aware of barry white. Nor jack white. The albums released today are not searchable. Doesn’t work better at all for me. Can’t really figure out what kind of server work that would cause this kind of problem.

Hello @Magnus_Grondal,

I’ve moved your post to a new thread because it appears that the search issues you are seeing may be unrelated to the others in the previous thread.

Can you try to following steps to see if you can get search working again?

A. Restart the computer running the Roon Core.
B. Start Roon.
C. Go to the “hamburger” menu, open settings, then go to the “services” tab.
D. Click “Edit” on the services screen.
E. Click or tap the “Sync Library Now” button.
F. Click done and exit out of the Settings screen by tapping in the area surrounding the pop up.

Once you have done this, try searching again and let us know how it goes.

-John

No difference. Searched for Finding Gabriel by Brad Meldhau and Barry White. All that came up was Tony Joe White. I think it might be a syncproblem because normally the syncprocess takes a least some seconds but now just flash for a millisecond.

The clue may have been your statement that “The albums released today are not searchable”.

There’s always a delay of a day or two before albums get synced into the Roon database. Performing your search today is working for me.

I searched one hour ago. And the artist Barry White surely shoud have been there also yesterday. I did separate searches for the two. And a lot of other searches with no result.

Tidal directly works perfect. Problem just with Tidal via Roon.

The database syncs from tidal to roon can take several days, one or two might still be a bit optimistic for latest releases.

@wizardofoz In my case, albums decades old wont come up when searched for. Nor artists dead for decades.

Just realized that the search function works on PC. So it seems to be ios related somehow.

Hi @Magnus_Grondal,

I just wanted to check in here with you, is this behavior still occurring? If so can you try rebooting your Core + iOS remotes to see if that helps?

– Noris

Hi Noris,

Thanks for your email. No change after a number of reboots. The search function works fine when I use a PC as core but not with my iMac or my MacBook as core.

//Magnus

Hi @Magnus_Grondal,

Thanks for confirming that the PC operates as expected as a Core but the OSX devices do not. How is the PC connected to the network vs the way that the OSX Cores are connected? Are they all using WiFi? If there any change if you temporarily connect one of the non-working OSX cores via Ethernet instead of WiFi?

Also, can you please double check to make sure that both Roon and RAATServer are listed as exceptions in your OSX firewall using these instructions and that there are no other active firewalls which could be preventing Roon from executing a search?

– Noris

Hi Noris,

Both PC and OSX connected via wifi. No oppurtunity to connect via ethernet I’m afraid. No firewall in my OSX.

//Magnus

Hi @Magnus_Grondal,

I just wanted to check in here with you to see if there has been any change in the behavior of your iOS remote regarding search. Are things working better or has the issue remained the same?

If this behavior is still ongoing, can I please ask you to reproduce a search and let me know the exact local time + date in your country of when it does not return results? E.g. 1:41PM on 6/6/19?

Once I have confirmation from you that this issue is still occurring and I have timestamps I can enable diagnostics mode to see if perhaps there are any signs as to why the behavior might occur in the logs.

– Noris

Hi Noris!
Since a few days search function works again. All Apple devices and no problems.
Best //Magnus

1 Like

Hi @Magnus_Grondal,

Thanks for the update! Glad to hear that things are back in working order, if the issue pops up again please do reach out to us once more.

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.