Roon sees my HiFiBerry DAC+; but won't allow selecting to play

Core Machine
AMD 4 cores 4gb ram 3ghz

Network Details
Everything is wired to same network on unifi 24 port switch

Audio Devices
several sonos devices attached via ethernet → These are working

Raspberry PI with Hifi-berry DAC+ → this is partially not working

Library Size
zero

Description of Issue
I can go into settings → Audio

From here I can see all my audio destination options. I see in the “Roon Ready” section my hifi-berry. It looks like it is working perfectly.

The issue is it is not an option to select in the “select an audio zone” to play something.

I’ve tried disabling the device and re-enabling it. Still no good.

I’ve confirmed the HiFiBerry OS is working fine by enabling AirPlay and playing to it with my Mac. That works fine.

I’m running HiFiBerry OS 20210531

Playing to sonos devices from Roon works fine.

I’ve disabled all playback options on HiFiBerry OS except Roon.

Restarted Roon, HiFiOS, etc.

Logs are located here Dropbox - Robert_Ruddy_roon_server_logs.zip - Simplify your life

FWIW -
Roon running on MacOS (Catalina 10.15.7 - 2012 4xCore i7 @ 2GHz), ethernet-connected
HiFiBerry on R-Pi 4 with Volumio (NOT HiFiBerry OS), ethernet-connecetd
Pi hooked via USB to a Schiit DAC and thence to Schiit headphone amp
Works fine, just like the other end points
Volumio:in general playback options, I have I2S DAC turned on
I have HiFiBerry Digi+ Pro selected as DAC Model

Hope this is of some interest…

Also note that this setup worked fine at one point. I can’t say exactly when it stopped working as I was not using this device for a period of two weeks. I just know it worked before that and didn’t after.

Hey @Robert_Ruddy,

I am so sorry that we’ve missed your post for this long. I apologize for the delay :pensive:

Thanks for sharing all the information that you have. Before passing this on to our technical team, I was wondering if you there were any updates at all that you could share :nerd_face: