Roon sees PCM but not DSD on Aries G2

I am a new owner of the Auralic Aries G2.

I run the following:

Intel NUC holding Roon Rock

——>. Auralic G2. —> USB -->

Denafrips Terminator DAC—>

McIntosh integrated amp

I can play in PCM, but the G2 is not seeing the field Maximum Sampling Rate (DSD) in Roon advanced settings for the Aries G2.

Indeed, the field is completely missing.

Assistance appreciated. (I have my settings set exactly like those of a friend including turning off “convert to” settings

Beneath the Max Sample Rate (PCM) should be a field that says “Max Sample Rate (DSD)" but the field is not there.

Flagging @support on this one.

Just a quick question, you mentioned a friend’s setup. Is he/she using the exact same
NUC>ethernet>Auralic_G2>USB>Denafrips>McIntosh_Amp setup?

What happens if you remove the Auralic from the equation and just go NUC>USB>Denafrips>McIntosh_Amp? Do the DSD options appear?

Roon displays options in response to capability queries the connected endpoint or DAC returns. In this case, Roon is not being told DSD is a possibility so it does not display those options. There could be any number of reasons. But, the first is to check if the DSD options appear in Roon without the G2 in the chain.

Hello @7NoteScale,

Ensure that you have disabled the “Software Volume” option includes The AURALiC ARIES G2 settings.

-John

Where exactly is that setting? Is that in Roon or somewhere on the Auralic?

Maybe these bits?

I erased and restarted the G2. Thank you. All settings became available but the Output to USB is no longer a selectable item. Whether via the IP or the front panel USB Output is no longer there.

One for the Auralic forum probably.

I think I have it all working. I had to reset the Auralic G2 to complete factory settings.

It will not recognize a USB Cable if already plugged in (in my case) so powered off (switch) and then installed the USB.

Seems to now work. The recommendation to start from scratch was needed and appreciated.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.