Roon Server 1.8 on QNAP not playing audio from any control or to any zone/device

Roon Core Machine

QNAP TS-253a, firmware, 16G ram
Roon Server
Status : Running
Version :1.8 (build 806) stable
QPKG-Version :** 2021-05-18
fmpeg :System default
Location: /Multimedia

Roon app: android phone, Windows 10.

Networking Gear & Setup Details

WiFi/Ethernet → 10G router, 5g wifi

Connected Audio Devices

Chromecast, Riva festival speakers,

Library Size

Description of Issue

I’m able to use the Roon server on my win10 PC, but the v1.8 NAS version running on my QNAP never streams audio.

The music selection and zone/speaker selection interfaces seem to work, but when PLAY is hit, no luck. The progress bar on Android oscillates with a dark blue 2-3 sec period, but never has it progressed beyond 0 sec or made a peep on any of the output devices.

The QNAP shows plenty of memory and low CPU utilization, so I don’t feels it’s a hardware issue.

What are you trying to play?

Note: You can’t play AAC and maybe some other formats with " ffmpeg : System default". You have to provide a version where those formats are supported. Read also:

doesn’t matter the music encoding (i think) because the problem is with TIDAL or locally stored music.
Thanks for the interest.

Try rebooting everything then, from router over switches to your NAS and Roon endpoints (speakers).

yeah - that’s not helpful. Issues is on every output device: PC, Android phone, NAS (it has ADC i/o), chromecast and airplay speakers. I can browse, select, control - but the music just doesn’t start.

So you tried it and it didn’t help or you refuse to try?

I run a Roon Core on a similarly spec’d QNAP NAS (on current firmware) and don’t have issues. I once encountered an issue with Roon after updating the firmware but that was resolved by another restart of the NAS.

sorry - didn’t mean to sound flippant.
Rebooting doesn’t seem to help.
Did you do the manual ffmpeg before or after your roon1.8 server installation?
Although, I don’t understand how the ffmpeg encoder could affect playback of TIDAL to any of the devices. If I’m mistaken plesae inform me how that is so.
Thanks again for your interest. I like the roon concept, but this trial isn’t gonna end well if my nas can’t host…

I did it when the package that supports it became available, so maybe 2021-02-02, just for the occasional live radio station offering no other stream format. The RoonServer package for NAS is not directly connected to Roon (the software). The ffmpeg issue is NAS related (introduced with QTS 4.5.1) and affects users no matter if back then or still using Roon 1.7 or the current 1.8.

The quality and format you get from Tidal is dependent of your subscription (to Tidal). Premium is AAC only AFAIK, but i might be wrong here as I don’t use Tidal. You also have to choose the appropriate subscription type when you configure your Tidal access in Roon (a HiFi subscriber can choose to limit Roon access to premium).

Hello @randy_wolfshagen,

Thanks for choosing to let us know of the trouble that you ran into :sweat:

I was wondering if this still is the case or if you have any updates to share. We’d love the opportunity to help :nerd_face:

Never got resolved for my QNAP NAS. Please post if you see a resolution come across.

Hey @randy_wolfshagen,

I am so very sorry we’ve never seen this last post on the thread until today. We’d love to help sort things out in your case - I’m unsure that the issue you’re experiencing is necessarily widespread.

Would you please let us know how is the issue manifesting itself now, at the end of August? :nerd_face: