Roon server configuration issue with QNAP NAS

@support

QNAP TS-453Bmini with Firmware 4.4.1.0978 (20190626), with roon server version of 2018 (not the version that release no longer ago)

Hi there.

I finally managed get the roon server installed after two weeks attempt (I’m in China and installation stop at 50% …) and I’m now stuck at the first configuration page when i open the roon server, i have created a shared roonserver folder and pointing it to store the roon database at the configuration page, it gave me message of location is set and return back to the configuration page again which running in the loop.

i have stop and start the roon server service but it not helping. below is the debug it display

Architecture: x86_64
Database:
Session ID: k0ar6hpv
QPKG-Path: /share/CE_CACHEDEV1_DATA/.qpkg/RoonServer
Language:
Local http-directory: http://a61a.myqnapcloud.com:5000
HomeFeature disabled: 0

Any idea ?

Many thanks
Hong

Hi @Hong_Zhuo,

Welcome to the Community and thanks for reaching out to us here, I have a few followup questions:

  • Can you confirm that you used these instructions as to configure your QNAP for proper installation?
  • I am not sure I understand you here, are you trying to install an older version of Roon on the QNAP? If you install the newest one from the QNAP App Center do you still experience the same behavior?

  • Can you share a screenshot of your “Select Storage Location Folder” tab? For refeference this is what this screen looks like:

  • Is there any change in behavior if you try rebooting your QNAP (power off, unplug, wait 30 seconds, power back on) and then try again?

Thanks Noris.

  • yes, have follow the instructions and install the roon server thru the app center, I have installed the 2018-06-14 version three weeks ago and now failed trying to update by clicking the update icon, the update process took overnight and I got no response, background update job disappear but it still asking me to update roon server, see screen dump 1, let me try to remove the whole thing and try again
  • see screen attached screen 2, once the location selected, it goes to screen 3 and then back to 4 asking me to select the location again
  • have done the reboot, on/off but still the same

I will do a flesh installation again and revert.


Thanks Noris

Hi @Hong_Zhuo,

Thanks for providing that information. Has there been any change with the fresh installation or is the behavior still the same?

I wonder if there is any additional information in the Roon logs. Can you connect to your RoonServer storage location via QNAP’s File Station app and let me know if there is a folder called “Logs” contained in it?

If there is, can you please create an archive of this folder and then send these files over to me as a shared Dropbox / Google Drive / Send.firefox.com link?

Hi Hong,
I‘d like to look into it.

  • can you try to update the app to the latest version 2019-06-09 (should be available in the QNAP App Center)? This update addresses specifically one issue that might be occurring on your QNAP:

The QNAP API calls might not work when the web ui is opened in the browser by the local hostname.

  • if this does not solve the issue: Can you try and check if the issue persists, if you access your QNAP by its local IP address?
1 Like

Hi Chris and Noris.(@crieke @noris)

I can’t even install the server now, it show up at the App center (2019-06-09) but it never get install successfully, after few hours waiting, it says could not download installation archive from Roon labs website, please check your internet connection. (see screen dump)

I have the same issue before with 2018 version but it seems install “ok” after few try.
@noris I have not got the log file before and the roonserver folder was empty … so I guess the installation is not quite right.

any other way to get around it ?

Thanks !

What kind of Internet connection are you using?
Can you check if you are able to download the RoonServer Linux build on your computer and check what the download speed is, when you do so?

Hi Chris (@crieke)

sorry for late response, not sure type of internet connection but have optical fiber running into the apartment so assume it is ok, speed is fast for domestic sites but far from good if overseas.

i have test to download the linux build with 100k at the beginning and drop down to 20 something k, projection of 7x hours download, proof the point that something to do with the speed, i can download the build on my work network which took 3 minutes …

I have unzip the build and try to install to QNAP without success, is that anyway i can do the installation without using my home link ?

Thanks !

Hi Hong,
The current app installation routine has no other option to install RoonServer.
However, I could modify the installation routine to have the option to install the app with the RoonServer_linuxx64.tar.bz2 file from the Public share directory instead of downloading it during installation.
Then you could just download it somewhere (in your office?), copy it to that shared folder at home and then start the installation.

Would that be of any help?

1 Like

Yes, most definitely, thanks Chris.

@crieke

Hi Hong,
I have sent you a private message here, with the updated installer which is capable to install RoonServer without an internet connection if the RoonServer linux download is provided in the “Public” shared folder.

Thank you very much Chris, will try and revert.

Cheers

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.