Roon Server continually crashes

This is running under a VM in Unraid utilizing Linux Mint 19.1 utilizing 2 processors and 6GB of memory. Everything seems to work for 30-60 minutes, but then suddenly the music will stop. When I look at the logs, it shows a “Client Disconnected” message and then “restarting connection (Unable to read data from transport connection: interrupted)”. After that it seems to reconnect, but then just starts spewing memory stats like below.

02/23 21:19:39 Info: [stats] 2650mb Virtual, 556mb Physical, 328mb Managed, 0 Handles, 83 Threads

Hi @David_Cauthron,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this behavior occur for all endpoints?

Besides playback stopping are you also losing connection from your remote devices?

Machine/OS: VM Linux 19.1 w/ 6GB of ram 2 cores
-Wired: Netgear GS724T
-Wireless: Ubiquity WAPs
Audio endpoints: Sonos, Windows, iPhone, iPad
Library: Unraid Share storing about 500 tracks mounted to the VM, Tidal

Yes, it stops at all end points. The roon endpoint actually disconnects from the server and won’t reconnect until I reboot.

Hi @David_Cauthron,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the issue occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

I tried again between 9:50 and 10:30 tonight. It was connecting/disconnecting over and over again. Finally at 10:28ish pm it completely failed and would not reconnect. In the client logs, it keeps saying “Connection received no data for xxxms. Assuming dead. Connection dropped. Connecting to IP address. Connected.” Over and Over and Over

BTW - I’m on a free trial. I love the UI if we could just get the thing stable. :wink:

Thanks, @David_Cauthron!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

I restarted the server. Let me know if you received the files.

Hi @David_Cauthron,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link.

Is it possible for me to send the logs to you through email?

@David_Cauthron — PM sent

Hi @David_Cauthron,

Can you try moving this file out of your watched folder and let us know if you still experience this issue?

music/Aerosmith/Rocks/06 Nobody's Fault (2012 Remaster).m4a

I removed that entire folder, but that didn’t help. I decided to reinstall using Debian instead of Linux Mint, however it’s still not stable at all. It doesn’t instant reset like it did on Linux Mint and it will play music for a few hours, but I’m still seeing stack traces in the log file and resets. I have to restart the server every time I want to play music which isn’t practical. I’m starting to think that the Roon Server just doesn’t run well on Unix. Are there any successful combinations of linux/unix on the latest version that are stable?

Hi @David_Cauthron,

Apologies for the continued troubles here! Many successfully use Roon on Linux, so there is likely something else going on here. In the logs you previously sent it appeared that the file mentioned above was causing some issues, but there may be some additional issues that need to be looked at.

Can you send logs once more in this new configuration with that folder removed and I can have the team take a look?

Hi @David_Cauthron,

May I ask that you also try removing this media from your watched folder and let us know how things go after?

/music/Aerosmith/Aerosmith/07 Movin' Out (2012 Remaster).m4a


Unfortunately, I’ve run out of patience. It’s just not a stable application. Unfortunately, my music works just fine on plex, musicbee, foobar, and other programs, but it crashes Roon. To me, this is a bug with Roon, not my files so I’ll have to cancel my trial for now. Once it becomes more stable, I’ll check it out again.


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.