Roon server no longer functioning on windows 10 PC [solved, antivirus messed up]

After two weeks of functioning as expected, I can no longer get Roon server to run on windows10 PC. when I attempt to launch manually from desktop shortcut nothing happens; task manager no longer indicates presence of Roon services or applications. All endpoints (iPad Pro; iPad Air) now indicate “waiting for remote core”. No changes had been made to PC. Rebooted PC (obviously) with same result. Thank you for assisting.

Tagging @support. The Roon support guys will want to know details of your setup, as described here.

Describe Your Setup
version of Roon you are running (Settings > About; If you’re running Windows, please let us know whether you’re running 32bit or 64 bit)

It’s Roon server - cannot tell version if I can’t launch it.

What operating system you are running (Windows 7; OSX 10.9; etc)

Windows 10 64 bit

Basic information about the device you’re using (MacBook Pro 2011 w 4gb of RAM; HP Envy laptop w i7; etc).

HP desktop 64 bit 2GB RAM

Describe where your music is stored – this includes hard drive description and interface type (USB, Firewire, etc. If you are using a NAS or any other kind of network storage, be sure to include the information requested in the Network section below)

music is stored on WD MyBook NAS on netgear router USB connection
On WI-FI with Sonos (Sonos is still working OK)

Let us know your collection size (approximate number of tracks)

15,000 tracks

Describe The Issue
(if you’re having a specific issue or crash)

Roon server fails to launch no longer runs after two weeks functioning properly.

Additional Details

Worked for two weeks with iPad endpoints - now ‘waiting for remote core’

No changes were made to PC.

@support will help look into this deeper (probably when it’s not Easter weekend), but did you try just reinstalling the app from our download page?

Your DB should be safe, just the software install seems to be wedged.

I will try re-installing. Thanks.

I just re-installed the server 64bit windows 10. Looks like we’re back in business. I wIll continue on trial basis for now

Thank you for your assistance.

Roon worked fine for about one minute, then my AVG antivirus identified roonAppliance.exe as a threat “general behavioural detection” and proceed to isolate the file. Not sure what to do at this point. Maybe configure the anti-virus to ignore the roonAppliance file, as long as it is not a threat to my system. Can’t understand why it would work OK for a couple of weeks, though. AVG antivirus was present all the time in its current configuration.

Now I’m back to where I was this morning. Roon server cannot be found (understandably, as it has been removed as a perceived threat by AVG.)

I just added RoonAppliance.exe to AVG antivirus exception list. Seems to be working OK now.

You might want to take note of the observation that after a period of ten days RoonAppliance gets flagged by AVG antivirus as a threat, and isolates the file.

Actually, it gets flagged all the time. I can only get a Roon update through by disabling AVG and then restarting.

Must be a problem with AVG, specifically. I use Norton without any trouble.

It is specifically an AVG issue, I think. Norton, as you know, Windows Defender, Malwarebytes, Avast, and Kapersky don’t seem to have an issue. AVG specifically dislikes RAAT.

this has been discussed in the below mentioned thread, but most importantly, all these programs themselves have become a bane of their own.

Here, I proposed a modern look at malware protection and the impact it has on your system:

Thank you for the great advice

I just had this same problem and resolved it (at least for now) by re-downloading Roon Server and re-installing it.

I just want to say, however, that this is totally bush league that a $150 piece of software just stops working like this.