Roon Server no longer working on Synology after DSM update

Hi all,

i recently bought a new DS2419+ NAS in order to replace a former DS2415+ (i’ll move it elsewhere later on). I had roon server on the 2415, and it was working very well, at least last time i checked (say february).
i installed the roonsever package on the brand new DS2419. installation OK but impossible to start the server each time i get the same error message “impossible to repair the package” (in french : Echec lors du lancement de la reparation du paquet).
Then i checked back on the DS2415, and unfortunately it’s now the same !!!
i forgot to mention that DS2415+ is running DSM 6.2.2-24922 update 4 and DS2419+ DSM 6.2.2-24922 update 5. Both got ‘DSM’ updated 2 days back.
RoonServer folder is on an external USB 128G SSD. No need to mention that i move the USB attached SSD to the appropriate NAS each time i try;)

Any help would be appreciated ?



Hi @Pierre_Lambert,

Welcome to the forum!

Where exactly are you seeing this message? Could you please share a screenshot of where you’re seeing it and where the Roon database is currently configured to reside?

Hi Noris,
the Roon database is on an attached USB SSD. The message i got is from Package center when i try to start the Roon service

here is the content of the external 128G SSD

thanks for trying to help.
Is there some kinda migration i should perform between the 2 NAS ?

Hi @Pierre_Lambert,
I am not from support, I am just a user like you. I also run Roon on Synology.
Make sure that your whole SSD is a share named RoonServer. It’s a requirement. It won’t work otherwise.
Also I think it’s not a good idea to move the same SSD from one Synology to another back and forth. I think Roon adapts to a particular machine.

1 Like

I would also flag moving the ssd without doing a database backup and roon reinstall and restore to the new nas. I hope you have a backup otherwise you my have compromised the external moving it from system to another.

Maybe @crieke Chris can help here

Yes i’ll several backups of my roon database hence i’ll probably give a try to erase/format the external SSD and make a fresh install (RoonServer folder on it ad etc…). i’ll let you know.

I eventually managed to make it work again on my former NAS, so you’re probably right, there is something like a binding between Roon Core and the attached SSD.


Hi again,

i formated the external SSD, created a folder RoonServer on it, performed a fresh install and still the same error message. Any idea ? Thanks

Follow the installation instructions that can be found here:

1 Like

@BlackJack : very good reminder. Simply forgot to create a shared folder and not only a folder. How stupid i’m. It’s working now.


Hi @Pierre_Lambert,

Fantastic news that setting up the shared folder resolved this issue! Thanks for reaching out and do let us know if you have any further Roon issues and we can take a look.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.