Roon server not completing start-up: continaully attempts restart

Core Machine (Operating system/System info/Roon build number)

Antipodes DX2 (with local music storage) running latest version of Antipodes software. Roon Server version: 1.7 (build 528).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear ProSAFE GS108 switch connects Antipodes DX2, QNAP NAS (backup only), and Ethernet/wifi internet router. Wifi used for iOS controller.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

AMR DP777-SE connected via AES3 to Antipodes DX2 running Roon Core and Roon Ready.

Description Of Issue

Roon Server attempts to start and does not complete the start-up sequence. This occurs on a continuous loop. This sequence shows in the Antipodes system log:


This issue has been occurring for several months, starting roughly around the time my Roon subscription was due (not sure if this is relevant). Roon Server had not stated during this time until spontaneously starting correctly a week ago; server had then been operational until yesterday when the behaviour returned.

Roon Server has been reinstalled by Antipodes several times and no other customers report this issue.

Hi @Raymond_Daniel,

Is the behavior the same if you disconnect any USB attached devices to the Antipodes and try to reboot it? Do you by any chance know how to access your Antipodes Roon Logs folder? Logs would help us clarify what’s going on under-the-hood.

Hi noris,

I don’t have any USB devices attached. The Dx2 is connected to the network via Ethernet and the DAC via AES3.

Tony form Antipodes pointed me to the logs. I can certainly copy and drop them somewhere.

Tony also mentioned that you can contact him for further info.

Hi @Raymond_Daniel,

I will send you a private message on where you can upload the logs, thanks!

Hi @Raymond_Daniel,

Thanks for sending those logs over. I took a look through them and unfortunately it doesn’t look like there’s much information contained in them.

It looks like Roon is starting as expected until it tries to mount the storage locations. I have a few follow-up questions:

  1. Have you tried setting the current database aside and starting with a fresh database yet?

  2. If you disconnect everything connected to the Antipodes except the Ethernet cable and the power cord, does the same behavior still occur?

  3. Is there anything else on your network using port 9100? Are you using a Plex / Emby server on any of your PCs on this same network?

Hi noris,

Now, for the weird stuff. This sort of issue was occurring a while back, but continued a bit further into the start routine, until it tried to mount the back-up, then failed. Even though the log mentioned lazy mounting and such, the process would fall over until I started the back-up NAS. Recently, the NAS has been started and the problem persisting. Maybe not at all related; mentioned just in case it matters.

To answer your questions:

  1. I don’t think so. Can you point me in the direction of instructions to do this?

  2. I will try and get back to you. That would be odd, but I will try.

  3. Not that I’m aware of. No Plex / Emby; I can do some research and check.

Will get back to you shortly.

1 Like

Hi @Raymond_Daniel,

Do let me know if the other suggestions trigger any change in behavior.

You should be able to do this via the Antipodes WebUI, but you may want to reach out to Tony for more precise instructions if you don’t see this option in the WebUI.

I have had another look at the Roon Server logs captured in remote login session recording. I suspect that there is bad data that may be causing this problem.

As part of the attempt to resolve we deleted/reinstalled the Roon Server app. It started OK and then scanned in the music library. After it had scanned 869 tracks, and while it was still scanning, I changed a Roon Server setting in the Antipodes GUI and saved the change. This caused the app to restart, and it immediately reverted to the behaviour of repeatedly starting then stopping, displaying ‘error’ instead of ‘running’.

The music library on the Antipodes internal drive was the only data source accessed.

I suggest that I log in remotely again, check the points that @noris has raised, and also look to see if I can find any data in the referenced folder that looks ‘fishy’!

1 Like

Hi @Tony_Devitt,

Sounds like a good plan to me, let me know if you need our assistance after the remote session. I would try temporarily disabling some of the storage locations in case it’s related to media. If you find any logs which mention [analysis] traces, please send them my way and I can take a look.

I logged in remotely, deleted and reinstalled Roon Server (which was failing to start), and then allowed Roon to scan in 9661 tracks from the Antipodes internal storage. When this completed I then did a ‘Force Rescan’. This identified eight tracks that might have been corrupt. The first seven ‘possibly corrupt, unidentified format’ are listed here:

The eighth track was slightly different:

I deleted the eight tracks from internal storage, rebooted the Antipodes, and Roon Server started correctly. I stopped and restarted the app without problem, and rebooted again, and in each case Roon Server started correctly.

Several of the corrupt tracks had been processed with dbPowerAmp, and @Raymond_Daniel thought copy protection might also have been associated with the initial capture.

The logs of the full music library scan have been saved on the Antipodes and can be made available for download if required. However it seems the problem has been solved.

Hi @Tony_Devitt,

Thanks for your troubleshooting efforts here. It does look like an analysis issue with the Giant Leap - Braided Hair.flac file, so I would like to get this file over to QA if you still have it, so please private message me a link to this file.

In either case, I’m glad you were able to locate the offending file and the system boots as expected since removing it!

HI both,

Thank you so much for working through this issue for me. Special thanks to Tony who has been available on weekends - Sunday morning, most recently - to troubleshoot as needed. Impressive service.

Roon Server worked perfectly yesterday afternoon and is fine this morning. So far, so good.

@noris, if Tony does not still have the file I can grab it from a music back-up.

1 Like

Checking back I find that I did not delete ‘Braided Hair’ … although I should have! You may find that it is still there, and if so it is not causing a problem apparently. All the others appeared to be dbPowerAmp rips with incorrect tags and possibly incomplete rips:

No problem Tony. I deleted the whole 1 Giant Leap album soon after you logged out of my system.

Hi @Raymond_Daniel,

Can you you please send me the Giant Leap album just in case? I will ask QA to see if they can try importing this on their end without issue. Please upload it to Dropbox / Google Drive / and private message me a link (click my name here -> message), thanks!

Hi noris,

My pleasure - done and message sent. Please be aware that this is from a back-up of my music files and is not from the Antipodes drive; still, it should be the same as what Tony deleted.

1 Like

Hi @Raymond_Daniel,

Thanks for sending the album over, I can confirm I received them properly. I will get these files over to QA in case it will help prevent similar issues in the future.

Thanks again for reaching out to us @Raymond_Daniel and for your assistance @Tony_Devitt in troubleshooting this behavior!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

The Antipodes/Roon Server returned to the old behaviour after a couple of days. A few days after the issue was resolved I had start bouncing Roon Server to get it to start; after a few days Roon Server just failed to start, having the same behaviour as before, stopping at the point in the start-up process.

Sorry all, I really do not want to bother you with this - do I raise another ticket or can this one be reopened.