Roon server not launching automatically from Remote app on iPad (ref#SF4SD7)

Affected Product

Roon

Roon Issue Category

Description of Issue

Setup: Roon server mounted on Small Green Computer SonicTransporter (SGC) i5 media server connected to a TREND TEG-S51SFP Gigabit switch, which links to the Internet via ethernet cable and to a Sonore OpticalRendu network bridge via fibre. Bridge connects to a Gold Note DS10 DAC via USB and the DAC feeds the analogue output to a Leben CS600 preamp/amplifier and AudioNote loudspeakers. Music playback controlled by Roon Remote on an iPad.

For many months of faultless operation, launching the Roon remote on the iPad automatically started Roon on the SGC media server and displayed the music library on the iPad from which tracks could be selected and played on the chosen audio device. However, a couple of months back I had an issue with library backup that was easily resolved but from that point it has been impossible to launch Roon automatically from the Remote app on the iPad. Instead, I have to proceed through a tedious step-wise process which involves attempting to log-in to my Roon account, reaching a dead-end at the ubiquitous ‘Are you on-line?’ screen, and having to go into the media server’s preferences to launch the Roon server manually. Then I can reach the Roon ‘Welcome back’ screen that identifies my account and allows me to launch Roon and access my music library.

This lengthy sequence appears to be necessary because launching the remote app on the iPad does not now automatically start the Roon server as it should and used to. Interestingly, if I close Roon and then re-open it, there is no need to go through the steps noted above because the Roon server continues to run, BUT, only until the end of the current day. If I launch the app the next day, the server has to be restarted as described.

The problem is clearly caused by the remote app failing to launch the Roon server automatically when the software recognises that the day has been updated. I recall a forum comment that similar effects can arise if Roon thinks that the user only has a trial version of the software. My account page confirms that I have a full current subscription but there is a ‘Free Trial’ notice at the top-right of the screen. Does this indicate that Roon is indeed forcing me to go through the convoluted procedure that I have described because it thinks I am on a fee trial? Help, and a solution, would be greatly appreciated so that I continue to enjoy the full Roon experience and access to my music. Many thanks.

Roon Server Platform

Linux (NAS/SonicTransporter/Antipodes/Ubuntu/etc.)

Linux Server Type

SonicTransporter

Roon Server Specifications

Roon server mounted on Small Green Computer SonicTransporter (SGC) i5 media server with 1 TB SSD containing music library of 5,500 16-bit FLAC tracks connected to a TREND TEG-S51SFP Gigabit switch, which links to the Internet via ethernet cable and to Sonore OpticalRendu network bridge via fibre.
All software up to date.

Connected Audio Devices

Network bridge connects to a Gold Note DS10 DAC via USB and the DAC feeds the analogue output to a Leben CS600 preamp/amplifier and AudioNote loudspeakers. Music playback controlled by Roon Remote on an iPad.

Home Network Details

Internet connection via Alcatel Fibre Optical Network Terminal to Edge X-SFP router linked by ethernet to TREND TEG-S51SFP Gigabit switch with SFP fibre slot TREND switch wired to the SGC media server via ethernet cable and to a Sonore OpticalRendu network bridge via fibre

Hi @Tony_Norris,

Thank you for your post and for your patience in awaiting a staff response.

To clarify, there is no mechanism within Roon Remote for automatically opening RoonServer on a separate machine. If you’d previously encountered the server online when opening the Roon Remote app, it’s because your RoonServer machine had remained online continuously. It sounds like your RoonServer machine is now only running for a certain period before shutting down or losing connectivity. You’ll need to investigate why that’s happening.

Diagnostics from RoonServer might provide an indication. If you use the directions found here and send over a set of logs to our File Uploader, we’ll be able to take a more precise pass through.

Thank you!

You may just simply need to set your Roon server to “Launch at startup” on your SonicTransporter so that Roon server is always running if the computer is running.

Thanks Connor

I have submitted the logs and RAAT server zip files as requested. I hope they are helpful.

One additional piece of information - if (as mentioned in my original post) Roon Server is restarted on the SonicOrbiter media server then there is no need to restart it for the remainder of the same day PROVIDED the media server remains switched on. If the media server is switched off and then on again then it is necessary to restart Roon server and go through the login sequence.

Could you also respond to my suggestion that Roon Server may not start because it thinks I only have an expired trial licence and it has to check that I have a full licence before it will function?

Kind regards

Tony

Hi Jim

Thanks for you comment. Much appreciated.

Yes, you would think that would do the trick. However, I have looked but I cannot see a way to set ‘Launch at Startup’ for Roon Server on the SonicOrbiter media server. I can set ‘Launch at Startup’ for Roon Server on my main Mac computer but Roon still requires me to start Roon Server manually and then requests me to log in. Let’s hope Roon Support can solve the problem.

Kind regards

Tony

Hi Connor

I have also sent you the SonicOrbiter Roon Ready Diagnostic which may contain useful information.

Tony

You may also want to contact @agillis since you are using a SGC server. He may have some insight into your issue, as he is the CEO and owner of the company.

Hi Geoff

Thanks for the suggestion - already in hand. Andrew is very helpful and a strong Roon advocate.

Kind regards

Tonyf

Hi @Tony_Norris,

Your RoonServer machine is running the earlyaccess branch of Roon, which will cause compatibility with the production (publicly available) version of Roon Remote that you’re running on the iPad. This is possibly the source of your issue.

If you’d prefer to stay on the Beta track, then you will need to follow these instructions to join the Beta testing track version of the iOS app through Apple Testflight. This will allow you to download and install the earlyaccess Roon Remote app.

A simpler solution is to kick RoonServer to the public production build on our Small Green Computer by taking these steps:

  • Make a Backup of your current RoonServer Database
  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Roon Server” and connect to the new database

Hi @connor

Thanks for your reply and for the clear instructions.

The problem started before I tried the early access version of Roon so I was confident that this was not the cause of the problem.

However, I followed your instructions to the letter and, sorry to say, the problem still persists.

In summary, the key features are:

  1. Roon Server on the SonicTransporter does not start automatically when I launch Roon Remote from an iPad (Log-in, ‘Are You On-line?’ etc repeated failures)

  2. When I launch the Server manually through the SGC webpage then I can log-in and launch Roon directly to access my music library

  3. Roon then remains directly accessible until the SonicTransporter is switched off, in which case I have to repeat the manual launch

The root cause of the problem is clearly that Roon does not launch automatically when the SonicTransporter is switched on as it used to. Why should this be?

I have reached out to Andrew Gillies at SGC and he did not think that there was problem with the SonicTransporter setup.

I would dearly like to solve the problem since it’s a considerable nuisance and a deterrent when non-savvy family members want to listen to music.

I look forward to hearing back from you.

Kind regards

Tony

I doubt that a Roon Remote has any way of starting Roon Server on a remote machine. Does SGC have any provisions for starting an application (i.e. Roon Server) after booting?

Thanks Boris

No, you are right, Roon Remote won’t boot Roon Server so something else is preventing the start-up.

Still under investigation.

Cheers

Tony

Hi @Tony_Norris,

I wanted to ping this thread to check if you’ve uncovered a blockage on the SGC side - as others have indicated, Roon Remote can’t initiate a RoonServer session on a separate machine. We’d have to investigate the relationship between RoonServer and the OS in question.

It might be worth verifying again whether any third-party security is interfering here.

Hi Connor

Andrew Gillis from SGC was extremely helpful in investigating what you refer to as a ‘blockage’. We set up a couple of remote sessions (USA to NZ) in which he checked a wide range of possibilities but none of them solved the problem. The issue remains - The Roon Server will not boot automatically (as it did consistently for 18 months) when Roon is launched directly on a Mac or via Roon Remote on an iPad. Roon demands that I log in (which it never used to) after which I can then launch the server manually.

This change in behaviour suggests that I used to be logged in permanently to Roon and now I am not so that Roon is demanding a log-in, a sequence that bypasses the server launch. I speculated that I had inadvertently clicked a ‘Free Trial’ request, even though I have a full licence, and that was what Roon was checking and finding the trial had expired. That’s why I asked several times if you could check the free trial licence status. Perhaps you could do that please since I think the cause of the problem, and the solution, is along these lines even if my reasoning is incomplete.

Please let me now your thoughts

Kind regards. Tony

Hey @Tony_Norris,

It sounds like you are doing all that @connor has asked for and going even beyond. We’re so grateful!

As a member of the accounts & billing team, I wanted to chime in and confirm that on the Roon account you are contacting us from, there is only an active yearly subscription (not a trial). In fact, the last trial on this account was in February 2022, long before this issue came up.

Your subscription status hasn’t changed in at least two years. It is doubtful that this would have any influence over the log in process :pensive:

Thanks Beka

At least we can get that idea out of the way. Unfortunately, it still leaves us without a solution to the problem.

Tony

Hi @Tony_Norris,

Thank you for your patience. There are a few steps you can take here, as well as some conclusions we’d like to pass along:

  1. The issue here is that you’re being logged out of Roon’s single-sign-on service, (a separate entity above RoonServer, Roon Remote, and Roon Community), which prevents RoonServer from launching automatically. I recommend verifying that a process named “RoonGoer” is added as an exception on any network firewalls present on these machines.

You’ll be logged out of Roon’s SSO service under certain conditions - if you have multiple subnetworks, private networks, or network security features on devices on which you sign into Roon, these can sometimes interfere.

Diagnostics from our investigation show that you’re using an local IP address range associated with Private Networks on some of your Roon-connected Apple devices. This is quite possibly the cause of Roon’s repeated demands for login, since you’ve mentioned a Mac and iPad remote above frequently.

In your iOS network settings on the iPad, do you see Private WiFi address toggled on?

Hi Connor

Thank you for your e-mail.

Your analysis is that the problem is due to a network setting, which is logging me out of the Roon Single-Sign-On (SSO) Service thereby preventing RoonServer from being launched automatically.

You also suggest that the offending network setting is caused by a private network or network security assignment.

To my knowledge, however, neither condition is causing the issue. I was using a Private Wi-Fi address on my iPad, which supports the Roon Remote app but switching the setting off produced no change. Also, my Mac computer is cabled directly to the router and does not use WiFi.

I checked all of the network settings on the Mac Pro computer, including the Firewall, and for completeness, the privacy assignments on the Brave browser that I use. No changes make any difference. The problem occurs whether I am running Roon directly from the Mac or from the Remote.

Exactly how would a network settings log me out of the SSO?

I need to get to the bottom of the problem because the alternative manual launch of RoonServer is just not user-friendly for other members of the household.

Kind regards

Tony

Hi @Tony_Norris,

Please pardon the delay.

Allow me to elaborate on my previous response.

Whether background processes launch automatically on startup depends on the permissions in the host operating system. If you close RoonServer, you will need to reauthorize after you open it again in Roon Remote by selecting a RoonServer and logging in again. This is all expected behavior.