Roon server not running consistently on ROCK

Core Machine (Operating system/System info/Roon build number)

ROCK, Intel NUC. Version 1.0 (build 183) stable. (static) /

Control is running on iPad. /

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NUC connected to Netgear AC1750 router via ethernet. Router firmware up to date.

Description Of Issue

This is a new problem. I’ve had this hardware for a couple years, and previously have not had trouble connecting to Roon Core. Now I do. I have not intentionally changed any settings, though it’s always possible that a software update changed something.

I noticed it when the Roon Control software on my iPad couldn’t connect Roon Core. I’m still able to access the web GUI by typing the NUC’s IP address into my browser. When I do that, my impression is that Roon server isn’t running reliably. Sometimes it shows that Roon server is running, but for only “15 seconds”; then I refresh, and the Server is running for “6

seconds”; on later refresh, it’s not running.

I’ve power cycled my NUC, iPad, router, and cable modem. I’ve reinstalled the Roon OS through the web GUI. In an old thread, I found a suggestion to rename the “RAATServer” folder to “RAATServer_old”. I tried that, and power cycled the NUC. The problem persists – Roon Control cannot connect to Core.

What should I try next?

Hello @Charles_Wells,

Does this behavior only occur when first booting up your ROCK or does it seem to occur throughout the day (after you’ve been using the system for a while)? Does the system stabilize after a few minutes, are you able to connect to it then?


Since the problem first occurred (a week ago), it has been “constant” – I am unable to connect to Roon Core at any time, regardless of how long ROCK has been running. For example, I just refreshed the web GUI, and it shows OS running for 38 minutes, Server running for “0 minutes, 0 seconds.” Roon Control on my ipad does not connect to Core.

Hi @Charles_Wells,

What happens if you click on “Start” RoonServer on the WebUI? Does it start up successfully?

put it on dhcp and restart it and restart router for test.
maybe you have device with same ip in network

No, Roon Server will not start successfully.

Thanks for the suggestion. I’m at work but will try this when I get home.

Although…why would an IP address conflict keep Roon Server from running properly?

Hi @Charles_Wells,

When you have a chance, can you please send me a copy of your ROCK logs by using these instructions? The best way to get them over to me would be via a shared Dropbox / Google Drive / link. Thanks!

Hi @Charles_Wells,

Thanks for sending those logs over. I am looking through them and I do notice that RoonServer is not starting properly, but it is not clear as to why yet. Can you let me know:

  1. Do you have any backups of your database made before this issue started?

  2. If you disconnect everything from your ROCK except for the power and Ethernet cord (no USB devices/HDMI devices connected) and reboot it, does the same behavior persist?

(2) Disconnecting the USB hard drive that stores my music from the NUC results in one minor change: now, when I run the Roon control app on my iPad, the screen looks slightly different. Under “Roon Optimized Core Kit,” the version info and IP address, there’s a yellow circle and the word “Connecting,” which periodically changes to “Connection Failed.”
That’s the only change I notice. It still won’t connect.

(1) I haven’t backed up my databases, because I’ve never done much to modify them (like custom playlists, etc). I just search for music and play it. (I have the music itself backed up, obviously.)

Hi @Charles_Wells,

Since you don’t have any database info you need to preserve, let’s try setting up a fresh database to see if this will help:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Verify if the same behavior occurs

Oddly, when I just tried to rename the folder, I found that I could not see the ROCK directory in Mac finder. Can you explain that change? (Restarting Roon Server doesn’t seem to fix it.)

Hi @Charles_Wells,

Are you able to use the MacOS Connect to Server feature to access your ROCK share? I would try using the IP address and connecting as Guest. If that does not work, is there any change in behavior if you reboot your Networking gear + Mac?

This did not solve the problem. Same behavior occurs.

Hi @Charles_Wells,

Can you please upload a new log set after the fresh database? You can also try reinstalling the ROCK operating system via the WebUI, there is a “Reinstall” button in your first screenshot, please try to see what the behavior is like afterwards.

I’m at work but will upload new logs when I get home tonight.

I’ve already reinstalled the OS once, as I mentioned in my first post. Do I need to do it again?

1 Like

@Charles_Wells - It might be worth a try because now the database has been reinstalled as well. The logs should help the most though so do send those when possible.

Ok, I’ll reinstall the OS, then send a new batch of logs.

1 Like