Roon Server on Mac mini ... "Too many failures ..." error

Roon Core Machine

Mac mini (late 2012), 2.3 GHz Quad-Core Intel Core I7, 16 GB RAM, Mac OS Catalina 10.15.7

Networking Gear & Setup Details

Asus RT-AC88U Router

Mini is connected via ethernet.

Connected Audio Devices

microRendu (ethernet) - feeds Lyngdorf TDAI-2170

Raspberry Pi (ethernet) - Feeds Cary Cinema 12 Processor

Chromecast Audio (4 total wireless) - Feeds Peachtree M40, Peachtree Deep Blue, Cary Cinema 12, and Lyngdorf TDAI-2170

Wiim Mini (wireless) - feeds Lyngdorf TDAI-2170

Number of Tracks in Library


Majority of library via Tidal. I have an assortment of ALAC, FLAC, and even a handful of DSD tracks stored on Drobo connected to the Mac Mini via thunderbolt.

Description of Issue

Roon now just skips through the tracks and then I get a "Too many failures … " error. The Mac mini is running Roon server which eliminated the frequent crashes. Now the server seems to continue to run but no music can be played.

I have the same model of Mac Mini and experience exactly the same issues, although my mini is an endpoint; My post is about 15 postings earlier than this one. Can anybody help both of us?

Is the failure occurring on all your Roon endpoints? Or perhaps mainly the wireless ones?

I run a Mac mini (Late 2018) as my server and all my wired ethernet Roon endpoints are extremely reliable. My wireless endpoints are another story–particularly as the data rate of the songs climbs with 96kHz+ content.

Please see answer in the thread on my problem. the poster in this thread uses a mini as his core

Hey @Eric_Taylor,

Thanks for writing in, and my apologies for the delay! Our team was able to take a closer look at your core diagnostics and are curious to see if:

  1. If you temporarily disable the microRenu, does the issue occur?
  2. If you attempt to play non-MQA file formats, does the same issue occur?

We’re also seeing some airplay issues, is your router up to date? I’d give it a hard reboot while you troubleshoot.

I’ll be on standby for your reply. Thanks! :+1:

The router has the latest firmware according to Asus.

I restarted everything (microrendu, mac mini running roon server, and even my powerline adaptors connecting things). I’m no longer getting the same error and am able to play music.

But as you noted, there does seem to be some issues with Airplay devices. I have two Apple TVs and a WiiM mini that use airplay. The Wiim Mini comes and goes while the AppleTVs are just not there anymore.

Also, I can’t see ANY of my chromecast devices either.

please advise.

Hey @Eric_Taylor,

Do you see them pop up when reviewing your devices connected to your network? Are you able to stream them using another software? I would first give your router a hard reboot.

It’d be good to know what Airplay protocol your devices are using, Airplay or Airplay 2 - you can read more about that here:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.