Roon server on machine with VPN

Description of the issue

I am running my Roon Server on windows 10 pro with Mullvad VPN. At first, roon is accessible from Roon Remote on Android, however after a few hours the remote app is no longer able to connect to roon server. If I close and re-open the roon server on my PC, connectivity is restored.

To work around this issue, I tried adding Roon and RAATServer to be excluded from the VPN tunnel (with split tunneling). With this configuration, the roon remote can connect to the server, however any music I try to play skips every track. This behavior occurs for both titles from Qobuz and from my local flac library on disk. My audio interface is a Scarlett 6i6.

How can I configure Roon to work alongside a VPN?

There is no support for VPN configurations from Roon Labs. You can find other discussions regarding VPN in the tinkering section of the forum already – have a look there. I move your post over to the tinkering section.

1 Like

I had some success with this issue with the following steps. It is working for now, will have to wait and see if it works longer term.

  1. Assign a reserved local IP to my PC in my router DHCP settings.
  2. Enter this local IP in the roon mobile app after clicking β€œhelp”.