Roon Server on my Synology

[quote=“fore, post:12, topic:11720”]
So I said to hell with it and I’ll just run Roon Server on my Synology.

All setup, Tidal working, but it won’t take my pathway and am wondering if you could help me with that? It’s a PC and my Synology Pathway given is \DS1515server. Yet it keeps saying it’s invalid.

Btw, using the same Synology info on a Mac Mini, smb://DS1515server and Roon found it easily.
[/quote]I’m not sure if this will help. I don’t use a NAS.

Cheers, Greg

If your Roon Server and music files reside on the same device you`ll need to add your music library as a “local folder”.
In the storage settings of Roon, click on “add folder” and in that new windows at the bottom “add local folder”.
You did not say on which shared folder (on your synology) your music is located.
If it is for example “music” and you only have one volume set up in your Synology your local path is most likely:


I have instructions, to find out the proper path on the download page of the package. Take a look at the section “Adding your music to Roon”.

I am not sure what happened here, but the problem is solved being volume written with a capital V. It works well now.

that’s weird. I have not observed a capital “V” (in Volume) on a synology device, yet.

No, what I am saying is that I set the local path to /Volume1/Musikk but it should say /volume1/Musikk.
This was sorted out yesterday.

Ahh. Ok, i misunderstood your previous post. That makes sense to me now. :slight_smile:

Thanks, that worked partly. I have C:\Volume1\music recognized, but is only "watching for new files in real time’. The NAS is mapped to the Z: drive, shouldn’t that be Z:…?

Let me sum up (just to be sure I have understood your setup correctly):

  • RoonServer is installed on Synology
  • your music is stored in a shared folder “music” on the Synology
  • the music share is mounted on your windows computer as drive Z:

If this is all correct:
If you enter the local path in roon on your windows computer. keep in mind that you are actually telling the server (=Synology) a local path. The Synology uses a linux system and has no drive letters. It will also not see any volumes that are available on your windows computer. So, your C: and Z: drive should be irrelevant.

Have you tried the above given local path?
(Without any drive letters. :wink: )

That’s all correct. And yes, I used /volume1/music as mine is on volume 1, and hit add, and still getting the network path not found.

My Synology music is Shared Folders and Music is in this folder

If you are getting “network path not found”, then you are probably trying to enter this local path in the field for a network path.

In that window (where you entered the path before) should be a button that is labelled with “add local folder”. Have you clicked on this and tried entering the path there?

That’s exactly what I’ve been doing, using ‘add local folder’.

Hmm. interesting.
Is your music stored on the internal disks or on a usb hard drive that is plugged into your synology?

When you enter the local folder path, does Roon accept your entry and is showing an error in the storage tab or are you directly getting an error when you have entered the path and click the blue “Add folder” button?

If possible, it would help if you could create a screenshot of your folder “music” in the Control Panel when you have “shared folder” settings open. (like this one)
And another screenshot when you have entered the path in the “Add local folder” window.

Internal discs on NAS.

A few things I see on your screenshots:

  • Your music share on your Synology is written completely uppercase. So you have to enter it as “MUSIC” (paths in linux are case sensitive!).

  • You still added your drive letter. Do not add “C:”. There are no drive letters in linux.

  • Volume should be spelled lowercose and there is no space afterwards (it should be “volume1”, NOT “Volume 1”.

  • Don’t mix up the regular slash “/” with a backslash “”. I know you are using backslashes “” in windows (C:\Directory1\Directory2), but in linux you need a regular slash “/”!

In your case, your correct local folder path is:


Just enter this line in “add local folder”. Nothing else (like drive letter, or colon character).

Ok. Tried /volume1/MUSIC Here’s the screenshot. And btw, not ONCE did I ever add the C: drive. It automatically shows up after hitting the blue Add Folder under Add Local Folder.

Sorry, I did not mean to imply that you added the drive letters. I only wrote down what I saw from the screenshots. :slight_smile:

I just tried it in a windows virtual machine. Roon does not add any drive letters here if I add the path like in my previous post:

Ok. I think I know what is happening:
I think you are connecting to a RoonServer on a Windows PC.

There is no RoonServer shared folder in your Synology screenshot. That would be a requirement to launch RoonServer on the Synology. Otherwise it won’t start.

Do you use a DS1515 or DS1515+ ?

I am asking because RoonServer on Synology requires a 64bit CPU and the DS1515 is equipped with a 32bit cpu. The DS1515+ has the required 64bit cpu.

1515+. Do you have a link on how to set that up?

@crieke, I don’t want to but in, but I’m not sure that fore is running Roon on his NAS. The Music Folder is a default location put in by the server. In this case “C:\User\Music Machine\Music” indicates that the Core Server is still running on a Windows Machine, which is why the drive letter is being auto added.

IF you have not tried it this way, I would suggest you run RoonServer on your new PC. RoonServer is Roon without the UI. After RoonServer is loaded on the PC, install Roon on another Mac, PC, iPad, iPhone, Android Phone, or Android Tablet and link in to the RoonServer to configure and set it up.