Roon Server on my Synology

Hmm. interesting.
Is your music stored on the internal disks or on a usb hard drive that is plugged into your synology?

When you enter the local folder path, does Roon accept your entry and is showing an error in the storage tab or are you directly getting an error when you have entered the path and click the blue “Add folder” button?

If possible, it would help if you could create a screenshot of your folder “music” in the Control Panel when you have “shared folder” settings open. (like this one)
And another screenshot when you have entered the path in the “Add local folder” window.

Internal discs on NAS.

A few things I see on your screenshots:

  • Your music share on your Synology is written completely uppercase. So you have to enter it as “MUSIC” (paths in linux are case sensitive!).

  • You still added your drive letter. Do not add “C:”. There are no drive letters in linux.

  • Volume should be spelled lowercose and there is no space afterwards (it should be “volume1”, NOT “Volume 1”.

  • Don’t mix up the regular slash “/” with a backslash “”. I know you are using backslashes “” in windows (C:\Directory1\Directory2), but in linux you need a regular slash “/”!

In your case, your correct local folder path is:


Just enter this line in “add local folder”. Nothing else (like drive letter, or colon character).

Ok. Tried /volume1/MUSIC Here’s the screenshot. And btw, not ONCE did I ever add the C: drive. It automatically shows up after hitting the blue Add Folder under Add Local Folder.

Sorry, I did not mean to imply that you added the drive letters. I only wrote down what I saw from the screenshots. :slight_smile:

I just tried it in a windows virtual machine. Roon does not add any drive letters here if I add the path like in my previous post:

Ok. I think I know what is happening:
I think you are connecting to a RoonServer on a Windows PC.

There is no RoonServer shared folder in your Synology screenshot. That would be a requirement to launch RoonServer on the Synology. Otherwise it won’t start.

Do you use a DS1515 or DS1515+ ?

I am asking because RoonServer on Synology requires a 64bit CPU and the DS1515 is equipped with a 32bit cpu. The DS1515+ has the required 64bit cpu.

1515+. Do you have a link on how to set that up?

@crieke, I don’t want to but in, but I’m not sure that fore is running Roon on his NAS. The Music Folder is a default location put in by the server. In this case “C:\User\Music Machine\Music” indicates that the Core Server is still running on a Windows Machine, which is why the drive letter is being auto added.

IF you have not tried it this way, I would suggest you run RoonServer on your new PC. RoonServer is Roon without the UI. After RoonServer is loaded on the PC, install Roon on another Mac, PC, iPad, iPhone, Android Phone, or Android Tablet and link in to the RoonServer to configure and set it up.

Yes, I realised it after I set up a Roon Server on a windows machine: The local path is adjusted according to the operating system of the server. :slight_smile:

On the download page of the package are all required instructions.

Crieke, I didn’t see the specific Roon app. So that is the problem.

I tried following your guide, but when I try to dl Synology x64 NAS (spk) from the website, it takes me to your page:

So not sure why this isn’t dl’ing

please check your private messages.

Score! Wow, what an ordeal. I’m using Chrome btw that wouldn’t open that link.

Thanks Crieke and the team!

Great to hear that it is working now. :thumbsup:

And sorry for the back and forth before!

What was the resolution so others who read the thread might understand.

I send him the direct link to the package and to the instructions as a private message. I try to avoid to post the direct link to the package here due to the missing instructions.
The links might also not work in the future if there might be an update to a version 1.1 someday.

I am still trying to reproduce the issue why the download of the package did not work. I tested already various browsers on different operating systems without any problems.

If you mean display resolution? It’s 1440x900 on Maverick OS 2008 MBP.

No, I meant “what finally corrected the issue you were having”, as in resolution to your problem.

I see. The issue was I had thought I’d installed Roon Server on the Synology but I hadn’t. So as soon as you sent me the link on that file, it was simple and it accepted /volume/MUSIC finally.

Just when I thought I’m getting the hang of things, I do stupid things like this still lol

Thanks for all the help all


A post was split to a new topic: Thinking about upgrading to a Synology NAS