Roon Server on Synology Disconnects [Solved - Moved Database from SSD to HDD]

I would rate it unlikely that the Synology is part of the problem.
Got a DS416play with 8GB and lots more tracks More but 5000 albums in fact. 2 endpoints with DSP active, while roon still analyzes music and needs to keep track about re-tagged content from the PC (causing re-imports).
And I got docker, photo station and some others running besindes roon core.
A couple of things do spring to mind:

  1. in case you added the audio to the syno right now and have indexing turned on the snyo itself might analyze audio and create thumbnails? indexing is required for the syno audio station software for example.
  2. networking … I would look int othat if there’s something which causes peaks in a randomn manner. Perhaps a Wifi device syncing or something like that?
    A network spy utility might be glorious.
    Unsure if you have a managed switch or such like allowing to see network packet losses or collisions?
  3. did you really gain something from placing the database onto the SSD? I tried once and found that my btrfs volume (4 WD red drives) wasn’t much slower, so I gave up using an USB device.

And yes support is pretty kind upon such things. They do ensure that you have a test period for testing not just for sorting out issues which prevent one from testing the product.

Hello @Jeff_Greenberg,

Thanks for contacting support, I’d be happy to look over this issue with you.

I have a few questions that would help me have a better understanding of what’s going on here, can you please let me know:

  • Is this issue occurring for both the NAD and the Node 2?
  • Have you tried rebooting your Networking Equipment and Core yet?
  • Are you able to play local content to the NAD and Node 2 using other applications?
  • Is your Synology connected to the Router via Ethernet?
  • Does this same issue appear when using TIDAL tracks?

I look forward to hearing back from you when possible.


To Noris:

  • The issue occurs on both the T777 & the Node2
  • I have rebooted the core but not my router. My network appears to be running smoothly
  • I can play local content using the BluOS app without encountering the problem
  • Yes, the DS916+ is connected to a Cisco SG200-8 switch via Ethernet
  • Tidal is variable so I don’t use it as a test case. I have had Tidal MQA playback stall when using the BluOS app. This appears to be a Tidal server problem rather than a local problem.

To @noris:

If possible I would like to send you a log file via a private channel.

— jeff

Hello @Jeff_Greenberg,

Thank you for answering my questions and for sending the log file via PM, I did indeed notice the disconnects but there isn’t any conclusive signs yet as to why exactly it’s happening.

You mention that you are using both Netgear Orbi Routers and Managed Switches here, we have seen reports that making some configuration changes in them could help improve communication. Our Networking Best Practices Guide outlines the modifications suggested for your Router and switch and I have also copied the relevant parts below:

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

Netgear Orbi Routers

If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

Please let me know if the above suggestions help resolve this issue.


1 Like

Hello @Jeff_Greenberg,

Thank you for PMing me the logs regarding the most recent disconnects.

I did notice the disconnect to the Core but there is no clear explanation as to why yet. The logs are indicating that something caused your Bluesound Node 2, NAD T777 and Cerebrus to disconnect all at once. Have you been by any chance experiencing internet issues with your ISP or other apps exhibiting strange behavior?

Just to rule out possible internet issues here, would you be able to run a “ping test” and verify if there is a stable network connection when this issue occurs? You can use the Mac’s Network Utility to have an “unlimited number of pings” test running to a website, for example to see if google is reachable when the issue occurs. This article describes how to use the network utility.

Other than having the ping test running to verify network stability, I would try to see if you experience the same behavior when using an unmanaged switch as managed switches have been know to cause some issues with multicast operating properly. If you have an unamnaged switch that you can temporarily use in place of the managed switch, then that would be a good test for another data point.

As for a final test to rule out the QNAP if my above suggestions don’t yield results, I would verify how the behavior is like when you use the iMac as the Core instead of the QNAP. If you are still experiencing the same issues when using the iMac as the Core then we can rule out the QNAP hardware and take a closer look at the Network setup and configuration.

I hope I have given you some useful suggestions here, please let me know your findings when possible.



Thanks for the tips. I’m currently working on a different theory. I have not observed any network issues and I have no reason to suspect my switch. But when the last disconnect occurred I immediately tried to look at the log file on my Synology (not QNAP btw).

Although no error was reported I was unable to open the RoonServer shared folder for nearly a minute. That was very odd. I then shutdown Roon and moved my RoonServer folder from the USB3 SSD drive back to spinning disk on the NAS volume. I’ve been running that way since the incident. So far I have experienced no additional disconnects but I don’t have a lot of time on the system yet. I’ll keep you informed and my fingers crossed!

1 Like

So far, so good. Since moving my Roon database off the SSD, I have not encountered a single dropout. Not conclusive yet, but this is the longest period of time I’ve experienced without a disconnection. I suspect that the Synology USB3 implementation is to blame – it’s not really intended for this type of application. And with a colleciton as small as mine, it seems to be plenty responsive with the database on NAS volume.

Glad to hear it works well with the db running on spinning drives too. I have a similar setup to yours. DS716+ w 8GB of memory and Roon running right on the Syno with the DB on an external SSD via the Syno USB3. I’ve not had any hiccups - happily streaming to my Moon MiND 2 via ethernet and wirelessly to sonos. It’s funny that the USB should be the cause of the issue - the 916 and 716 are pretty similar and I would not be surprised if they had precisely the same usb implementation. For the record, I’m running exfat on the ssd connected via usb3 - not that I think the file system should make a difference.

I’m surprised to see how well the roon core runs even on lower spec spec hardware so long as you don’t go all in with DSP. I typically stream ‘as is’ with no additional processing, and the cpu and memory consumption is very frugal.

Will be setting Roon up on my father’s Syno next week and try to run the db on the internal spinning drive. He has somewhere between 5 and 9 thousand songs in his library, so time will show how the performance compares to my setup.

Got it running on a 416play with 8GB and more but 100000 tracks.
2 endpoints with DSP active (pi’s with allo DACs, no problem even if roon is analyzing audio in the background.

Where the specs tend to fail is for example if I create a tag and stick 8000 tracks it. Takes minutes to populate or open that tag. But I’m far from blaming roon here. I’m happy it does work the way it does.

And there’s docker, photo station and others running besides the roon core on the NAS.

I certainly can’t explain it but I haven’t had a problem since i moved the db so I’m beginning to really believe that was the root cause. The SSD is PNY 240GB that is formatted exfat. I have all three USB ports in use if that matters. The two on the back are used for a UPS and a USB3 backup disk. I plugged the SSD into the front. I have no idea why that would matter – the backup happens late at night and the UPS generates no real traffic.

I never got an error report from DSM either. But it was definitely strange that immediately after a freeze, I tried to check on the RoonServer shared volume and I couldn’t get a response from File Station for over a minute. It was as if the volume was locked or busy.

And I also don’t understand why temporary loss of access to the db would disconnect the my outputs. Perhaps someone more familiar with RoonServer internals can shed some light on that.

Nonetheless, if I get through the weekend without a problem I’m going to sign up for a paid year. I really like the interface, metadata and exploratory features of Roon.

One difference I can think of in our setups is that I’m using the rear usb port for the ssd. I’ve shunned away from the front one because I made the assumption the USB copy feature of the syno does some monitoring of that particular port. So I played safe and used one of the other ones…

Why loss of access to the db would cause audio dropouts is indeed another question, and one that only a Roon developer can explain, I would think…

For the record, I set up Roon for my father on his 918+ yesterday, and it seems to work flawlessly with the db on internal 7200rpm drives. He has in excess of 7000 local tracks on the system.

One could have a look into /var/log/messages if there’s something about usb looking strange. (on the synology)

Hello @Jeff_Greenberg,

Glad to hear that things have stabilized since moving your database from the SSD. As to answer your question:

When you lost access to your Roon Database due to the SSD, you likely also lost access to RAATServer/RoonServer folders which are two pieces of Roon that reside alongside the database and are needed for Audio Zones to function properly.

Are thing still stable after making the switch from the SSD? Do you have any other questions/issues regarding Roon that I could assist with? Please just let me know.


If you ever want to try moving the database to the SSD again, you may want to reformat it to EXT4 first. Your problems could well be related to ExFAT and the numerous reads (and less so writes) from and to the database.

I’ve been running Roon on a DS718+ with USB3 SSD for a few months without as much as a hiccup.

Thanks Rene. So far, performance has been good on the spinning media but it’s good to know if I need the SSD for something else.


I have had absolutely no issues at all since moving off the SSD. I’ve decided to try Roon for a year. Thanks for the patience and help getting things running well on my setup.

— jeff

Glad to hear that @Jeff_Greenberg!

If you run into any other issues don’t hesitate to reach out to us, we’ll be happy to help.
I wish you a pleasant listening experience and thanks again for contacting support, hope you have a great day :slight_smile:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.