Roon server on Synology DS416 play doesn't accept connections anymore after a while [Resolved]

Installed Roon Server on DS416 play, separate USB3 SSD

Connected from Ipad, worked well.
Added music library path, Roon starts adding tracks (about 100 GB of tracks, so should probably work on it for a day or two)

Synology Task manager shows a lot of CPU and memory dedicated to Roon processes (probably the searching and adding of tracks)

After several minutes, IPad connection with Roon server is lost, can’t connect anymore

In synology task manager all Roon processes are in sleep mode, no CPU load and low memory footprint

Stopping and starting RoonServer in package manager solves the issue for some time, but it keeps coming back…

Does anybody know how to solve this issue?

Thanks in advance!

I can only assume here, but it feels like RoonServer might fail on a certain music file of yours. How much Ram does your DS416play have?

Maybe @support can help out?

Thank you for your quick reply and suggestions.

My DS416 play has 1 gb of memory. I’v ordered 8gb today, so tomorrow i’ll upgrade.

For now I’ll configure roon to only see a smaller part of my music library and narrow it down to one album if necessary, to see if it solves something.

If not, or if I cannot pinpoint the exact music file(s) that fail, i’ll contact support.

Thanks again. In the meantime: any other suggestions about cause and solution are welcome…

Hi @E_Richters ----- Thank you for the report and sharing your observations with us, the feedback is appreciated!

Moving forward, please due keep us up to date on how things behave after the upgrade from 1gb to 8gbs of memory. In the meantime, if you’d like, I can have our techs take a look at your RoonServer logs to see if we can pinpoint what is causing the hang up :microscope:

Please use the instructions found here and be sure to flag “support” (i.e @support) in your follow up reply, when the logs are posted and we’ll have a look.


Hi @Eric , @crieke
The performance of Roon is much better after de 8 gb upgrade. I also moved the SSD from external to an internal HDD bay.

Together it solved the problem. Roon server works well now on my synology NAS.

Thank you for your suggestions.

Kind regards, Eric