Roon Server + Roon Remote + iPad/iPhone problem


I’m having big problems with Roon Remote from my iPad 9.7-Inch 5th Gen/iPhone 6. It sadly feels like it gotten worse lately to. I do not know where to problem lies.

My iOS devices loses the connection with my Roon Server more or less everyday a couple of times after the unit hasn’t been used for a little while.

Roon Server is installed on a 64bit Win10 HP Probook (i3 2370m 2,40Ghz, 8GB Memory, 120GB SSD), I only use this laptop for ROON. A 1TB external USB HD is connected with all the music.

Making it work again involves: (1) Closing the Remote App and staring it again, which works sometimes. (2) Restarting the Router TECHNICOLOR TG389. (3) Restart the Laptop with ROON Server as the final step. Even starting the Remote App when music is playing can result in stuttering, sometimes it skips a couple of tracks to.

The Laptop is connnected with Ethernetcable to the TECHNICOLOR, a Allo Digione ROON-Endpoint is connected the same way.

What could maybe be the problem? This is sadly kind of of destroying the experience for me.

I have a Annual Membership btw.

Big thanks in advance.

Hi @Henrik_123 ----- Thank you for the report and sharing your feedback with us. Both are appreciated!

Moving forward, to help aide in our evaluation of this behavior may I very kindly ask you to please provide me with the following information:

  • Besides the mentioned Technicolor router are there any other networking device involved with your setup? These items can include additional routers, switches, powerline adaptors, extenders, etc.

  • Since noticing this behavior have you tried reinstalling the application on the mentioned devices?

  • If you have access to another laptop can you please load Roon on the device to act a remote and verify what the experience is like with a WiFi connection and a hardwired connection directly to your router?


Hi Eric,

Thanks for your response, very much appreciated.

I will answer to my best ability.

I live in a apartment with fiber broadband. It starts with a Raycore mediabox, where for example TV and Broadband is separated. In my living room (where the stereo also is located) I got two outlets for the same thing. I connect a eternetcable from broadband outlet to the the Technicolor wireless router that my internet provider sent me. To the router is also only my Allo Digione ROON-endpoint and laptop with Roon Server connected with eternetcable. I got no additional routers, switches, powerline adaptors, extenders, etc. Could a different wireless router maybe help?

I think that I always been having this problem. The ROON Server program seems to work all the time. It is just my iOS devices that drops connection with it. I’ve tried reinstalling the remote app without any change.

I will try with a different computer tomorrow.

Thanks so far.

Hi @Henrik_123 ---- Thank you for touching base with me and taking the time to answer my questions. The insight is appreciated!

I am looking forward to hearing what the experience is like with Roon remote being hosted on a device that can make use of both a hardwired and WiFi connection. The outcome of this test should provide us with a get data point.

Furthermore, I know you had asked about the use of a different wireless router. Personally speaking, I am always weary of ISP provided hardware and often recommend using a strong, well reviewed, brandname router. If you are concerned that the router could potentially be the weak link in the chain here you could always bring the HP ProBook over to a friend’s house who you know has a strong Wifi setup and test how the remotes respond in that environment.


Hi again,

Tried it with a laptop now. But when I’ve been testing everything works sort of well. I get almost the same response from the laptop (wireless) as with my ipad. The iPad takes some more time with “Waiting for remote core” but it locks in after a while. Before nothing happend. I haven’t changed anything. Is there a newer version or so? I can’t explain it really.


Thank you for the follow up @Henrik_123 and sharing the observations made during the proposed test run. Very appreciated!

By chance, during your test with the laptop were you able to verify how things responded when the machine was hardwired directly to your router? Furthermore, can you please verify what you are referencing here:

"Is there a newer version or so? "