Roon Server ruins your folder structure and time stamps

Continuing the discussion from Synology SPK-Package: Development:

Sadly gave it a try. Years of careful folder structuring and file time stamping down the drain… completely messed up and no way to revert back!!! Thank you so much!!!

Sorry to hear you are having problems.

Are you speaking about your audio files here or something else?

Roon watched folders do not change your audio files (other than when deleting an album).

Roon orgainised folders do, but there’s a large warning message informing user to that affect before it is enabled.

Or is this something else? Can you share more details, so that the Roon devs can investigate further.

Yep, sounds like you have accidentally/mistakenly chosen organised folders.

Incidentally, I thought the Roon devs were thinking about binning off that option altogether?

Probably that’s the case… I’m pretty sure I selected the folder as music source though. Can you select the same folder as source and as organized folder?

The warning should be much more explicit with such potential impact. Larger font, red or something but this is just too easy to be mistaken… very disappointing

Hi wappie,
I am very sorry to hear this.
You can still check the storage settings and take a look if your music location was entered as a an “organised folder” to verify if this was the cause of this.

This is the Organised folder warning, it seems compliant to your request on how the warning should look … plus the user has to also confirm by clicking the check box and then pressing ok.

If you did not see / accept this then something else is going on.

Are you able to take a screen shot of the Roon storage page, so we can see more details of how your system is setup?

I removed the package already since I didn’t realize upfront that there is no support for Devialet AIR on Synology. Thank you for your understanding. The warning needs to be much much more explicit.

Have to recall it from memory and from my recollection didn’t see this as I’m fully aware of such things can happen but probably am the one to blame. Don’t recall. Just angry at the moment.

There was something strange though;

I had an instance running on my laptop which I did not want to touch because I wanted to be absolutely sure the NAS was performing good enough before making the move. So I installed the Synology package and configured a trial account via a secondary email address. Configured it (again in my recollection correctly) and scanning began.

Now the strange thing was that the instance on my laptop also started rescanning allthough this was clearly NOT connected to the NAS.

[quote=“iamwappie, post:8, topic:12180”]
The warning needs to be much much more explicit
[/quote]Seriously? I don’t think it could be any more explicit.

If you saw and accepted this; then I’m afraid the only way back is to restore your files from a backup.

If you did not see / accept this then something else has happened, but without more information (as you have now uninstalled Roon) then I don’t think anymore can be deduced.

Just a thought, if you still have the Roon log files available then @Mike, @vova, @Eric could look at them.

I just tried it on my QNAP: I did not see a warning when setting up an organised folder.
To check if this has something to do with the synology and qnap package I tried it in Ubuntu as well.
I also did not get a warning here. It seems there is a general problem with the warning message in the linux installation.

Can someone confirm this?

Thank you !!! Was starting to doubt myself…almost

Hi Chris,

Interesting… What device was the RoonRemote running on when you testing this?

My quick test was with Roon on a PC … I see what happens from an iPad.
(I’m not running on QNAP yet … so can’t try that).

I used a MacBook Pro as a remote.

I tested RoonServer on QNAP and Ubuntu (running on the same MacBook as the remote in a VM).

I’ll test Windows as a Roon Remote now.

I installed the roon package and did the configuration via an iPad. Don’t know if this is interesting to know for this case

Did some further testing:
I also did not get a warning when I use Windows as a remote. (Server on Ubuntu)

@iamwappie , @crieke

I just setup an orgainised folder using both an iPad and iPhone pointing to Roon running on a Windows PC … No warning message was given!

This looks more like a RoonRemote issues than Roon / RoonServer / NAS.

I’m leaving a tag for @danny to pick up ASAP.


Wonder why such an important high impact feature was not part of the test plan/quality assurance before release! Great product but room for improvement in QA I suppose… Well hopefully my case will prevent it for others… All my free time for the upcomming weeks can be spend to manually reverting to the old situation.

Thank you crieke for doing the quick testing and taking it seriously !

1 Like

@Carl, this looks ticket worthy. Unless you or @danny have done so, I can.

Not that it matters but this is the real impact:

  • The source folder was also used by the 6 Squeezeboxes we have and all family members use. No Squeezebox playlist created with care by multiple familiy members is functional. My 10 year old son was in tears.
  • All carefully collected album art (displayed by Logitech media server) is gone
  • Most of the filestamps have been reset to today
  • Everything is structured by Artist while I had sorted everything based on Artist album, compilations, soundstrack, seperate tracks, listening books etc

With a lot of work I may be able to get the folder structure back but the time stamps I of course won’t.