Roon Server running erratically

I have Roon Server running on a dedicated M1 mac mini with 8GB RAM.

I connect to it with two other computers and one mobile on my home network, and honestly, since I installed this solution last month, it’s been completely erratic to the point of being unusable. I’ve had to delete caches, rebuild databases, and completely reinstall Roon Server on a handful of occasions now. It’s all supremely annoying, and miles away from the seamless, turnkey experience that it’s supposed to be.

There have been a number of bizarre issues over the last few weeks, but the latest is that Roon Server is completely invisible to other Roons on my home network unless I VNC into the mac mini, at which point the core becomes instantly available to other computers on the network. This is after completely deleting the last instance of Room Server (plus all attendant /library files) from my mac mini and starting fresh with a brand new installation.

Last week I moved over from Xfinity cable to AT&T Fiber, and now I’m connecting to a BGW320-500 with 3x AT&T Wifi Extenders. Could this be part of the issue?

My library is approximately 2000 FLAC files and another 10000 Qobuz tracks or so.

I have logs, just not sure if I’m allowed to post them here or not.

Any advice would be appreciated. It’s been a month and I’m already at my wit’s end. So far, all I have to show for investing in a Roon subscription and some dedicated hardware is a lot of frustration.

Yes it is your network if you are having to remote in. Probably you have two networks running, one on the router and another on the extenders.
What IP addresses are your equipment getting?

Thanks for the quick response.

I don’t see how it could be two networks, since my modem is also operating as my router and the extenders are AT&T-supported extenders that are meant to be plug and play…

Which equipment specifically are you asking about? The IP of my Roon server?

What ip address does the server have. What IP does the machine you are remoting in from have.

Roon Server is on

My Macbook air is on

Ok so thats normal. What error message or screen do you see on the remote when you try to connect normally without the VNC?

you should at least disable all energy saving like screen saver/sleep modes etc… sounds like its going to sleep thus no roon server is actively running

what OS are you running on the M1 Mini? I have found 12.x.x to be rather unstable, and the 11.6.5 is much better…I run with 2 partitions so I can swap between them. backing up and restoring the Roon database as needed to test or fall back from one to the other, oh and always backup to more than one physical device/location.

1 Like

Have you tried disabling the firewall on the M1 Mac mini?

You could try to connect your mac mini with an ethernet cable and disable wifi.
Maybe the mac turns off WIFI to save energy or whatever when network operations are not needed.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.