Roon Server Software Not Running (ref#A8JXK8)

Affected Product

Roon

Roon Issue Category

Installation or Setup

Description of Issue

I have Roon ROCK installed on an Intel NUC, and Roon Server Software is not running. Multiple attempts to restart produce the same error message: “Roon Server could not be successfully restarted. Please try rebooting, or contact support.” Multiple reboots have not resolved the issue.

Roon is not accessible from my mobile devices or the OS app. I am able to access ROCK using the web UI, however.

Roon Core Platform

Roon Optimized Core Kit (ROCK)

Roon Core Specifications

Intel NUC8BEH, plenty of RAM, 1TB internal hard drive 88% available

Connected Audio Devices

Hegel H390 amp

Home Network Details

Roon core is connected via Ethernet, Eero 6 router, TP ethernet switch

Screenshot

https://api.typeform.com/responses/files/d7d65ac9e6ab8fbf61266932dd7b46c5f2c6a242613aea67be79ee2bbf1df36a/roon_error_.docx

Hi @lontroyer,

I would suggest clicking on the Operating System Reinstall icon.
This will update as required both the OS and Roon Server.

Thank you for the suggestion. I get the following error when I click on the Operating System Reinstall icon.

What brand and model of m.2 SSD are you using?

[Edit: please ignore this paragraph] If you’re using the 1TB SSD to run ROCK as boot drive, most of the space is wasted as music cannot be stored on ROCK boot drive. To avoid this wastage, you can install Windows instead. [End Edit]

Reinstall it from scratch, no matter you continue to try ROCK or use Windows.

One more thing. Even if you succeed with this, if you find that your mobile devices cannot see Roon, you’ll need to turn Eero into bridge mode and use a proper router such as TP-Link or Asus (turn on settings - LAN - IPTV - Multicast Routing).

Try rebooting your ROCK/NUC - if the Roon Server is still not running, try reinstalling the Operating System again. I notice that Roon OS is still at build 258 - it should be at build 259, which is the latest Production build.

Peter - I believe that he has a 1TB Samsung 2.5" SSD installed because the Internal Music Storage section is being displayed. This would not be the case if he was using just the M.2 SSD for music storage…

Thank you for the suggestions, but rebooting my ROCK/NUC and reinstalling the Operating System have had no effect on the Roon Server Software, which is still not running. Any other suggestions?

Did you get an error code like last time?
Has the Roon OS been updated to build 259?
What is the size and brand of the m.2 SSD that you have in your NUC?
Thanks.

Hello @lontroyer ,

An exit code 43 is related to extracting RoonServe, though it looks like your OS drive is empty, so it should work. Let’s try the following:

  1. Send me a set of your current ROCK/Data/RoonServer/Logs folder by using these instructions, you can upload the logs here:

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

  1. I would try to rename the current RoonServer database and try a fresh one to see if this changes anything:
  • Navigate to your ROCK’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database
  • Try to Reinstall ROCK from WebUI and see if the update now works

Thank you, Noris - I have compressed my log files and uploaded them following your instructions. I will now try your other suggestions and report back.

When I restarted Roon Server after changing the name of the current folder to “RoonServer_old”, I got the following error message: “Roon Server could not be successfully restarted. Please try rebooting, or contact support.”

image

Hi Noris -
Have you had an opportunity to look at the log files I sent? I’m at a bit of an impasse at the moment.
Best,
Lon

Hello @lontroyer ,

Thanks for sending those logs over. It looks like the issue is that your ROCK is not downloading the complete update package for some reason, and it is being downloaded as corrupted to your ROCK disk.

It is possible that we may be dealing with a failing hard drive on the ROCK or something of that sort. If you try to follow the ROCK install guide and reinstall ROCK from scratch using a USB drive, does that work?

Hi Noris -
I reinstalled ROCK from scratch and the server is now working. I appreciate your help along the way!
Best,
Lon

3 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.