Roon Settings->Audio not seeing new RPi4 (USB) roon bridge

Roon Core Machine

Win10 64bit amd ryzen 5600x, 16gb ram
running Roon v1.8 build 936

Networking Gear & Setup Details

new (2022) Asus routers in AIMesh mode, works fine across both ethernet and wifi (no LAN/WAN issues, etc.)

Connected Audio Devices

RPi3 w/ Inno-Maker DAC HAT (RCA out), DietPi and RoPieee
RPi3 w/ Allo DigiOne Signature (SPIDF out), DietPi and RoPieee
RPi4 (no HAT - USB out only), DietPi and RoPieee (Roon Settings->Audio does not recognize!)

Number of Tracks in Library

20,000 tracks in library

Description of Issue

The two RPi3’s I’ve had for some time which were running older DietPi OSs.
Today I flashed a current RoPieee image onto a RPi4 (no HAT).
All 3 bridges show up in Roon Settings->About. This is good!!
But the new RPi4 bridge will not show up in Roon Settings->Audio. This is bad!!
I tried replacing RoPieee OS with a current version of DietPi, as I am experienced with that OS, but no luck - the new RPi4 bridge continues to show up in the “About” window but not in the “Audio” window.
I also “upgraded” the two RPi3s with new RoPiee OS, and they are still functioning nicely with Roon.
I’ve ruled out LAN issues. Roon 936 seems to be having trouble allowing newly recognized bridges to be “enabled” in the Audio window, but it works fine with bridges that have already been identified prior to recent software updates.
Please help, thanks!

1 Like

Hi @sonicflux,

In the Roon ‘About’ screen a RPi4 with RoPieee will show up because Roon will recognize the Roon Bridge or RAAT server running on it. The ‘Audio’ screen on the other hand will only show active audio devices and, as such, your RPi4 will only show up while an active USB DAC is connected to it.

In your post you don’t comment upon having a DAC connected; if so and it still won’t show up, ignore my post. But if you didn’t connect an active (turned on) USB DAC to your RPi4, connect one and check again in Roon’s ‘Audio’ screen.

2 Likes

Thank you @Andreas_Philipp1, you solved my problem!!

I do recall seeing that specific instruction in the easy-to-read RoPieee setup guide. However, I’m afraid human factors got the best of me! I’ve been so familiar with the RPi HATs, not having to turn on downstream devices to see them in Roon, that I skipped a simple but critical step for my first-time USB digital out bridge. It’s sounding great now :grinning:

1 Like

My pleasure; good it is working now!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.