Roon shows Hegel H390 as multiple AirPlay devices

I noticed that everytime I reboot my router, a new AirPlay instance of Hegel H390 with the same IP-address appears in the device list

So I have to turn off my router, reset H390 and reboot my Roon Core to make it right


Current Setup:
Roon Core - Intel NUC 8i5BEH2 (16Gb RAM, 512Gb M.2 SSD) - ROCK Version 1.0 (build 227) stable, Roon Server - Version 2.0 (build 1107) earlyaccess
Roon endpoint - Hegel H390 (firmware p5119.2002.0) via ethernet cable. IP-address reserved by DHCP. Not fixed, but constant.
Network Router - MikroTik hAP ac2
Core connected directly to router via ethernet cable

Actually I noticed this earlier with previous Hegel firmware and stable Roon 1.8
And there are a few topics regarding such issue:

Please, comment and let’s ask for @support

Hi @Serge_Tse ,

Can you please try these actions, one at a time to see if one, in particular, resolves the issue (until the next time it happens)?

What is the model/manufacturer of your router and any other networking gear?

Actually I have to do at least two things: reset the Hegel and reboot the router. Exactly or almost at the same time.
Sometimes this enough and I don’t need to reboot the core.
Resetting the Hegel is essential. But it looks like after that, some residual information remains in the router and network.
Therefore, the exact algorithm of actions is as follows:

  • Power off the router
  • Reset the Hegel
  • Turn off the Hegel
  • Turn on the router
  • Turn on the Hegel

MikroTik hAP ac2
I also used the TP-Link Archer C2300 a year ago and had the same issue

Hi @Serge_Tse ,

Thanks for that additional information. If you try to enable one of the duplicate Hegels, what happens? Do you hear sound when playing to any of the duplicates? Usually, this can be caused by multicast issues, do you by any chance have any MDNS reflectors apps on this network? Also, please see this article, it may be helpful:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.