Roon shows no Artwork after start

Roon Core Machine

Roon 2.0 Build 1182
Linux Debian 3.16.0 64bit

Remote Machine:
Roon 2.0 Build 1182
Windows 10 Core I3 8GB RAM

Roon 1.8 Build 1125
Linux 4.8.13

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

ca.10000 Tracks

Description of Issue


After the last updates the artwork on my remote Windows10 machine are gone. After some time the artwork comes back but this take a lot of time. On my Android tablet and handy all covers and pictures are there. Seems this a problem of the Windows machine.

Music streaming (Qobuz) and playing music from local database are no problem only covers and artwork not showing after start.

For testing I have uninstalled and installed again Roon on the remote machine but no change.

Hope you can help me


From Roon’s Settings → Setup menu, try clearing the image Cache and then shutdown and restart Roon.



i have already made but no change.
Is it possible to backdate to an earlier version ?


making some tests with my Win10 Laptop in the same network. Installing Roon in current version > no problems all artwork are there after start. Same on my second Win10 machine.
That indicates that this is not a problem with roon but is due to the hardware/win10 software from the audio-pc (DH61DL Intel Board with core I5 3470T).
I make a clean win10 install with current win10 version then installing roon again > same problem no artwork after start.
Then i install current intel driver for the mainbord of the pc, network, chipset, audio etc…restart the pc and starting roon > all artwork is loaded immediately.

So this might be a problem with the windows driver for the board.
The board is a Intel DH61DL mini ITX with Intel coreI5 3470T prozessor and 8gb ram.

If any one has same problems first install actual driver from the board manufactor.
It seems that the driver that comes with windows are not the best choice…

Hope that can help anyone…


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.