Roon shuts down on my PC

Core Machine (Operating system/System info/Roon build number)

Windows 10 64 bits
12 Go RAM
SSD Samsung EVO 2 To
i7-4770 3.40 GHz

Roon.exe is (which quite strange as I downloaded it yesterday on your official site as a free test)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Auralic Altair G1

Description Of Issue

Roon is quiting on my PC. Tried everything, uninstall, reinstall, run admin; located my audio library localy or on my Synology DS212+ NAS. Roon starts to index my library, perhaps between 800 and 900 albums and shuts suddendly. If a restart it, after a few seconds, Roon shuts down.

Thanks for help before the end of the free test.

This sounds as though you may have a corrupt or problematic file in the content that Roon’s indexing. If you start it with no music library connected does it run OK?

Thanks for answering. In that case, how can I star Roon without library ? And, if that is the right reason, how is it possible to solve the problem ?

Roon support will look at logs and advise.

Thank you,

My library is either on an external hard-disk either on my NAS, they are the same, as they are synchronized. The problem of shuting down happens with both. I looked and finded 5 files 0 bytes that I deleted. Installed Roon again and did ask to load the local libray on my external hard-drive. Roon shuted again. There are 4 files in C:\Users\Username\AppData\Local\Roon\Logs, total size is quite 18 Mo. I can zip that and send it through WeTransfer to the support ?

My free try ends in 11 days, until there I hope to be able to resolve my problem… but for the moment, adding my library always finishes by Roon’s shutdown. For now, my tests are limited with Qobuz, which is nice, but not enough to spend that amount of money.
Anybody could help furher ?


This is Noris from Roon Labs support here, I can certain assist!

Can you please send me the Roon log files you have? If you want, you can send me the link via private message (click my name -> message) to send a private message.

Can you confirm you downloaded this .exe from our Downloads Page and not elsewhere?

Hi Noris,

as I am not used to this forum and its subtleties, can you just confirm that you have received my logs?


1 Like


Yes, I can confirm I received logs, thanks!

Based on what you said here, this could be an issue with problematic media files.
I am looking over the log and it looks like the last item Roon tried to import was:
\Perso\Music\Classique\Debussy\Debussy - L'oeuvre intégrale (2018)\1_491_Andre-Cluytens_Le-Martyre-de-saint-Sebastien-L-130a-Act-2-Sebastien-archer-du-Christ-Les-Esclaves-Les-Briseurs-didoles-Les-Zelateurs-Les-Catechumenes-Le-Saint-Cordule-La-Fille-malade-des-fievres-Basile_6.flac

Can you please try to move this file out of the storage locations you have Roon scan and verify if it helps with the issue? Please do not delete the file just yet, because if it fixes the issue it may be useful for QA, thanks!

Sorry, it changed nothing. I tried also with Bitdefender AV and FW closed, but the same happens. I send the last log file.

1 Like


Thank you for sending latest log file! I am seeing some strange traces in the log, let me inquire with the technical team as to what these mean. In the meantime, I have followed up with you via private message!

Hi Noris, again,

I know how important it is to be precise when trying to reproduce a problem. I live and listen to music in 2 places. The first logs came from location A, the last one from location B. Yesterday at location B, after sending you the last log, I again deleted everything (including settings and database) and reinstalled, then I stopped my firewall (Bit Defender, latest version) then I started indexing the files on my NAS, without choosing an audio device or installing the Qobuz service. I left for a few hours without touching anything. When I came back, all my music was indexed. I restarted my firewall, installed Qobuz, let the indexing finish, then everything worked normally.

Tonight, at place A, I will try the same thing, knowing that the configuration is identical, except for the DAC / streaming player which differs.
In the meantime, thanks for the 30 day extension (I thanked Rebeka live). I’ll keep you informed.

Have a nice day.



So, I arrived and launched Roon in location A. Only Qobuz was running, no library. I installed my NAS library and let it work indexing. Everything was fine, so I wanted to discover more. I was listening to Mahler #3 on Qobuz with some DSP while the indexing was working. Suddenly Roon shuted down. I tried to relaunch Roon, not possible. I restarted my Pc and tried again, no possible.
All the logs of this session of try are on
Let me know… I’m a bit disapointed.

Hello @Eric_JARROUSSE,

Thank you for sending that log over! I would like to escalate your case to our QA staff, but one other piece of information which will be helpful to have is is your Windows Event Viewer Logs. Can you please use these instructions to submit a set?

  1. Press Win + R and type eventvwr.msc
  2. Press OK – this should open Event Viewer window
  3. From the left sidebar go to Windows Logs > Application
  4. Right click on the Application subsection and pick Filter Current Log... from the context menu
  5. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK
  6. Right click on the Application subsection again and pick Save filtered log file as.. from the context menu
  7. Enter the log file name, for e.g. Roon_USERNAME , and press Save
  8. Upload the Event Viewer logs for our support staff

Ok Noris. But before, let me explain what happened yesterday evening, so eveything will be “in line”.
As Roon stopped again and I did not want to install again, I just did plug off the ethernet. So, of course, Qobuz was off line (I just deactivated it) and my library also, I deleted the path to it, and launched it again to index from zero… And I went to bed ! This morning, no more Roon on my screen.
I uploaded 2 files for you on

  •, tonight’s logs
  • Roon Eric.evtx, the eventlog (where I can see many errors binding Roon.exe and Windows ntdll.dll
    Hope you can help !

Until you find the problem. I saw that some users already have/had this problem with ntdll.dll while using a NVidia graphic card, which is my case. So, I updated my GTX 645 to the last pilot (… which changed nothing.
Always testing and testing… but as Roon did not want to rest more than 5 secondes before shuting down, I tried in Windows 8 compatibility mode… And succeed… for the moment… the indexing started again.

The indexing has finished, and Roon is alive ! It went much much faster in Windows 8 mode.
Let’ see if it is stable.

Without counting that looks bigger then 255 char , Windows won’t like that ?

Thanks for the updates, @Eric_JARROUSSE! I’ll be looking into this while Noris is out of town.

I’ve passed along the Event Viewer logs that you’ve shared with us to our QA team and we’ll be sure to follow up when we have more information from them.

Definitely let us know if things continue to work okay for you here!

Exactly, that’s what I was thinking too (it’s exactly 276 long!) but there is a way in W10 to deal with longer than 255.