Roon skip issues

Roon Core Machine

Virtual Ubuntu VM, 8 x vCPU, 64GB Mem, NVME Storage on ESXi 7

Networking Gear & Setup Details

Unifi UDMPRO, US-16-XG, USW-Pro-48, US-8-150W, U6-LR, UAP-NanoHD, UAP-AC-M

Connected Audio Devices

Sonos Amp, Sonos Play:3, 2 x Sonos Five

Number of Tracks in Library


Description of Issue

I control Roon via my MacBook Pro, or my iPhone/iPad… all of which have the issue where it can “for some reason” skip the track I have selected… It is like it is having issues playing the track, and then just skips to the next track… I have had this issue many times, both plying from my own library and from Tidal…
I have not had this issue using Sonos or Plex

I also have the issue that if I am playing a tone on the Sonos Amp, and I turn on my TV, the TV takes over the sound (connected via HDMI)… Roon the keeps playing in the background… and it will take over the Sonos Amp again… ie. if you turn off your TV… it will start playing via the Sonos Amp…
This does not happen right away as I turn off the TV… I think it happens when a new tune starts in the Roon playlist… basically it would be great if Roon was able to figure out that it is no longer playing, and then stop, instead of just keep playing…
Again I have never had this issue using the Sonos player, which just stops as I turn on the TV…

I like the way Roon works, but since my subscription has expired, I am forced to consider renewing it, and still having this issue… I know this it is a bit late to bring this up… it has been annoying me from the start… I think I have been using Roon for 2-3 years…


Hi @Heino_Walther, I’m happy to take a look at what’s happening here! Is it always the same tracks that skip, or is it seemingly random? Once a track skips can you go back and play that same track later?

Nope it can be any track… and it is typically when I choose a specific track in a playlist… it then start the playback for 2-5 secs. then skips to the next track… I can the choose the skipped track again, and it plays ok… as I mentioned, this happens with both with Tidal and locally stored tracks…
(locally is an NFS mounted filesystem on my storage server, connected via 10GbE)
My internet connection is 1Gbit Up/Down.
The Virtual Ubuntu on which Roon Core is running, should have more than enough headroom to handle this… :slight_smile:

1 Like

Thanks for the update, @Heino_Walther. What happens if you run your Core on your MacBook Pro instead of the VM? Any change or do you have similar issues?

Well, I have not tried that, mostly because I move around with my Macbook… and the datastore where I have all my music will be tool slow (wifi) and a mess to get stable with NFS on MacOS…
But I guess I can give it a shot to see if I can replicate the issue…

OK, I have not been able to reproduce the issue while running the RoonServer on my MacBook…
So the question is if there is some issue with running the server on Linux (it was actually Centos 8), or running it in a virtual machine?


Thanks for giving that a try, @Heino_Walther. That confirms it’s likely not your network / devices and is specific to the Linux server / VM configuration. VM setups aren’t something we can provide official support for, but likely there is something in this setup that is not configured properly and it’s causing issues with playback.

Well… I have now moved the Roon Server onto a Intel NUC (NUC6i5SYH) (32GB Memory, NVME Disk)
Ubuntu 20.04 Server
Nothing else installed but “Cockpit” and ffmpeg etc. required by Roon Server.

And I just had the issue again… I skipped a track, it started to play, but a few secs in, it skipped to the next track… this was TIDAL tracks from the “random” TIDAL “playlist” which plays once a playlist is done… (guess it tries to play what it things I like?, donno if this is TIDAL or Roon?)
Anyway, I was able to reverse to the track and it then plays OK…
Annoying issue… and hard to reproduce at will…

I’m pretty sure it is not just when playing TIDAL tracks… but so far I have only had the problem with TIDAL tracks on this installation.

The networking is 1Gb out of the NUC, and through a few switches, on to my Unifi UDM-Pro which has a 1Gb internet uplink (both up and down, which is nothing near its capacity)

Any suggestions other than installing Windoze on my NUC? (which I don’t think will ever happen) :wink:


OK, this is getting very annoying now… I am starting to regret renewing my subscription to Roon another year…
If an Intel NUC with 32GB Memory and NVME disk cannot run the Roon server, without it skipping random tracks, what does it take then?
Today I have been listening to Tidal tracks, and it have been skipping tracks like crazy.
I am playing on only one Sonos Amp.
I have never experienced this directly using the Sonos Player…
I do not use any DSP or anything else sophisticated, just FLAC as the Source (Tidal) and SONOS Amp as the destination…(The Sonos AMP is connected via Wifi but the Server is connected via 1GB Ethernet)… all networking is Unifi and it reports no issues…
I would guess this should be very easy to replicate and hopefully fix…? that is if anybody else than me cares?

1 Like

Try to factory reset the Sonos… iirc this was noted elsewhere, also check the firmware is latest. One problem with Sonos I recall is it creates its own WiFi network too that could be interfering with your WiFi. Not sure if that can be turned off. Some things to check anyway.

Just as an experiment, I’d be tempted to take WiFi out the equation if possible with a temporary long Ethernet cable, just to see if that’s where the issue lies in some way

I’ve had quite a bit of trouble with recent Unifi firmware and endpoints on 2.4GHz, which I’ve never experienced before. There’s some simple changes between the firmware versions which may account for this (changes in signal strength, dropping to 20MHz from 40MHz channel width automatically) or it could be a more subtle interaction in my network. Either way, I’ve dropped back to 4.3.20 on the AP that connects to endpoints, and I’m using current stable on the rest. This resolved all my intermittent issues. Of course, no idea if this is relevant for you!

Well I tend to keep my Unifi APs firmware up to date, and this issue isn’t something that has introduced it self recently, it has been there right from the start. I started with the server running inside a virtual machine on my ESXi host. Someone told me this could be an issue, so I moved it to a physical Intel NUC, only to find out it didn’t help at all.
There is about 5 meters between the AMP and the AP with a cast-sealing and rockwool in the way, inside Unifi the AMP shows 100% WiFi Experience and has no drops, it’s connected with 2.4Ghz at -51 dBm. Even if a wired cable would fix this issue, it is not possible to do as a permanent setup.

Seems like I will have to debug this myself? Does anyone know how to setup some kind of debugging on the server side or even on the client side?

Indeed, but it might help to focus the problem-solving and is quick and easy to do.

OK, I’m able to replicate the issue now… I just need to pause the player for 2-3 minutes, and then “unpause” it again, and very often it starts to play a few secs of the song, then skips to the next tune in the playlist… very annoying… I can the press back, and it plays the track OK…

Also today I have the issue that after a pause of 2-3 minutes, the player your not work on my Amp anymore… it showed as if it was playing, but no sound from the Amp, I tried to stop, adjust volume etc… nothing helped… I then paused the player again… waited a few more minutes, while writing this… then just now (4-5 mins after) I press play, and it plays just fine again…

It’s just way too unstable… are you sure that your Sonos support actually works correctly?
Other things which I find strange is that you do not query the volume status of the Sonos device… you just assume that the only thing using the Sonos is Roon… which is not the case here… this of cause results in “jumpy” volume jumps as one tried to change the volume… as soon as I start to change the volume, it “sets” the volume on the Sonos… this is of cause not the case if you use the Sonos App…
Maybe you should change the supported devices list and set sonos to “limited support”?

Yes I’m a but annoyed, but if I can help in any way, please let me know, because I do like the ways Roon works… It’s just a pitty that it has soo many bugs… and I wouldn’t even be so annoyed if the price for Roon was lower… for what you get (with my Sonos devices) I expect flawless playpack, which is sadly not the case…

1 Like

Just another update… to this saga :slight_smile:
Since I have changed the “speaker” to use AirPlay instead of the “Sonos” connection, the skip issue seems to less… I will need more time before I can conclude that it is completely gone…

But maybe there is an issue with the “Sonos” implementation?

1 Like