Roon skipping ahead to next track without playing music (Mac Mini)

Thanks for all the info in this thread. I’ll (finally) be home Friday and will submit my logs then.

I just had this skipping problem in one zone, MicroRendu + Geek Pulse.
Both SonicOrbiter + Geek Out and the 818 work fine.
Rebooted the MicroRendu and Geek, no change.

Everything worked fine yesterday.
No configuration change, but the Geek Pulse had gotten unplugged from power; rebooted everything, but I wonder if this loss ov connectivity could have left some lasting confusion. @vova?

Hi Anders

Did it happen to you before Roon 1.2.

I did not experience it before I upgraded to 1.2
[but I also upgraded to OS X 10.11.5 (from 10.10.5) at the same time
so it could be either or a combination of the two].


No, this is new for me.

However, I just systematically powercycled everything, paying attention to boot order, and the problem went away.

Seen that before. Something causes the Roon server to get into a bad state, wrt one specific zone. @vova

This has also been happening to me more frequently recently. (Latest Roon Core running on MacMini)

I cant attribute it to the newest Roon release - I started using HQ Player about the same time.

Sometimes when the music skips from track to track my DAC (Geek Out 1000) disappears from zones. But not always.

The fix has always involved disconnecting the DAC momentarily from the USB cable. In effect, a restart of DAC.

I’ve lived with it, thinking:

1- the DAC isn’t exactly high-end,
2- the sample rares being sent to it are more varied than ever, and
3- there’s probably a setting in Roon or HQ Player that would fix this if I get motivated to research it.

But since anothe Mini user has reported a similar issue, I would add my experience.

1 Like

Hi @vova

OK, I’m back. Everything was working fine this morning. Strangely though, I paused the music for a couple minutes, and then when I came back the problem happened again. I’ve submitted my logs, so let me know what you think.

thanks again,

Here another data point. I have a Mac Mini and a new Raspberry Pi running Roonbridge. This works fine (wifi or hard wired) with a Schiit DAC (Modi 2) but skips without playing-or even making a sound-on my Peachtree Nova 220SE (wifi). It does not appear to be a network thing, but a basic issue between the Peachtree and the Raspberry Pi. Confounding.

I have exactly the same issue on my headless (old) Mac Mini running the latest version of OS X (El Capitan) and RoonServer (1.2). The music is stored on a Synology NAS (ethernet connection), and played on a DEVIALET 120 via USB.

I tried to change the USB port when it occurs but the only solution is either to use Apple Remote Desktop to kill and restart RoonServer or to force reboot of the unit.

I didn’t have this problem with RoonServer 1.1 :confused:

Thanks for all the advice, everyone. On the recommendation of @vova I switched to Exclusive and Integer mode in the Roon audio settings for my DAC. That did the trick for about 5 days, but the problems have resurfaced. Thought I’d check in to see if anyone else had any luck figuring this out.

@vova I recently had this behavior again. Turned out it was caused by my familiar boot order problem: I have a microRendu driving a Geek Pulse LPS/USB-passthrough to a Geek Pulse, works fine, but I was out of town and I think we had a power outage, and when power came back the devices didn’t boot in the correct boot order so the microRendu didn’t see the Geek Pulse. That is not your problem, it is a fault in the Geek Pulse architecture, or maybe the microRendu. It is one thing to not recognize the USB DAC, when that happens the whole microRendu thread is invisible, but here both microRendu/RAAT and Roon Server see the DAC but still can’t play to it correctly.

I think there have been several separate causes mentioned for this track-skipping behavior.

But the failure behavior is bad: Roon just skips through each track of the album. There needs to be an error message. Repair guidance if you can, but at minimum a notice that something is wrong in the playback chain. Whatever code you have that causes the track skipping behavior needs to be more robust. I think a lot of us have spent a lot of time troubleshooting this.

Still happening here too.

As another data point: I recently changed from the Mac Mini as endpoint to a microRendu (so that I could use the Mac for other things), since then I have never had the issue again. So it seems that, in my case at least, it could be related to some Roon 1.2, OS X, Mac USB hardware interaction …


By way of another data point, having just changed the configuration of my system …

As before I am still running Roon on a MacMini
Mac Mini (Late 2012), 2.6GHz i7, 16GB, 256GB SSD, OS X 10.11.5
[Power Saver options: Computer Sleep never & Put hard disks to sleep whenever possible]
Music (iTunes Library) on LaCie 5big Thunderbolt 2 [RAID 6]
Roon Version 1.2 (latest build)

I have two USB DACs, both dCS Debussy DAC (latest firmware)

One is connected via a microRendu
and the other is connected via a MacMini running RoonBridge
Mac Mini (Late 2012), 2.6GHz i7, 16GB, 256GB SSD, OS X 10.11.5
[Power Saver options: Computer Sleep never & Put hard disks to sleep whenever possible]
RoonBridge (latest build)

Both the microRendu & the MacMini running RoonBridge are connected to the same switch
[NETGEAR ProSAFE GS108 8-Port Gigabit Desktop Switch (GS108-400NAS)]
as the MacMini running Roon.

I have never experienced the skipping issue with the microRendu
Even if I turn the DAC off, when I turn it on again all works well.

Via the MacMini, as before I experience skipping even if the DAC is left permanently on.
NOTE: I have never seen an error message when the skipping occurs.
The only way to stop it skipping is to either power off/on the DAC
or restart the MacMini running RoonBridge.


Anybody else still dealing with this problem or found a way to stop it?


Has the Roon team identified the cause of this issue
and how to fix it in some future release …?


4 posts were merged into an existing topic: Audio analysis completed, but I’m still getting stuttering

I have the latest roon version and this annoying problem keeps on. When roon looses connection, even for only a few seconds, it jumps to the next track. This is the wrong algorithm in the wrong place, as it looks like a decision that is made upon encountering a non-playable track, e.g. for format reasons.

I just state when I would like this action to take place upon “connection lost”:


A post was split to a new topic: Roon skipping ahead to next track without playing music (SonicTransporter i5)

9 posts were split to a new topic: Dropouts with 2 Macs and crossover cable