Roon skipping ahead to next track without playing music (Mac Mini)

Thus far the only ‘solution’ that I have found it to restart the Mac or power off completely the DAC and power it on again and then restart Roon.

OK, me too. Hopefully someone will chime in and help us out.

Is it possible that the external Hard drive with your music has gone to sleep?

I am running RoonServer on a Mac Mini, and all my music is on a NAS network drive.

If I get a moment I will try and take the NAS offline and see if I get the same behavior ( music skips track to track with no playback ).

Thanks for the suggestion …

But if that was the case shouldn’t Roon simply wait for the disk to spin up again before starting to play the track?

Also why should turning the DAC off and on without touching the Mac fix the problem?

Ah ok, we might be onto something here, could it be after the DAC has gone into a idle or sleep state?

Hey guys,let’s try to figure out your issues.

@Rob can you please start from describing your setup (use this FAQ as guide). You mentioned that an upgrade has happened. Was this a Roon app update, OSX update?

@reeve_mike, can you also describe your setup. Are you sure that DAC’s firmware / OS drivers are up to date ?

Sorry, I meant a Roon update. Here is my setup; let me know if I left anything out:

Roon Version 1.2 (build 142)
OSX 10.11.4
Mac Mini (Late 2014) with 4 GB RAM
Music is stored on a Western Digital 2TB external hard drive
DAC is a Fiio E18 Kunlun DAC/Headphone Amp

The issue occurs whether I choose “System Ouput” or “Fiio” as my zone. I’ve noticed no problems when using my Squeezebox/Schiit Bifrost setup, which I typically control via an iPad or Android phone.

I also haven’t noticed it being a problem with Tidal, only the files on my HD, which are mostly FLAC of various bit depths/sample rates and from various sources.

@bplexico Thanks for the suggestion. I have found though that I can access other files on my HD while Roon is behaving this way, so the HD isn’t asleep.

Mac Mini (Late 2012), 2.6GHz i7, 16GB, OS X 10.11.5

[Power Saver options: Computer Sleep never & Put hard disks to sleep whenever possible]

Music (iTunes Library) on LaCie 5big Thunderbolt 2 [RAID 6]

Roon Version 1.2 (build 142)

DAC: dCS Debussy [Firmware 2.2] [No driver required on OS X]

Note the behavior described in Files loading slowly. It starts with another error message, but then it leads to the same skipping behavior.

If it is the same, it has nothing to do with network connection to a NAS: happened on my system that has music on a local SSD in a Windows 10 NUC.

@Rob, @reeve_mike we would like to check your Roon logs. I’ll contact each of you guys via PM with detailed instructions. Stay tuned.



Thanks for getting back to me.

I’m currently away from home. I’ll be back on 6 June and will send the logs at that time.
Sorry about the delay!


This has happened to me several times and each time it’s been due to the DAC not being available. Either it has got turned off or changed to another input. Since I am using Asio and Jplay from Roon to my DAC it seems (not too surprisingly) that Roon does not know that the DAC is not available and Roon attempts to play the track and I get this skipping behavior until the Queue is empty.


Yes I can accept that that would happen.

However, before my upgrade to OS X 10.10.5 & Roon 1.2, I could put the DAC into standby
and then when I took it out of standby Roon would happily play to it.
This is no longer the case, I get the skipping behavior when I bring the DAC out of standby
PLUS it seems to happen randomly even when the DAC is left fully powered up.

Stupidly I upgraded OS X and Roon at the same time so don’t know which of the two
is causing the issue. Or indeed it could be the combination of the two …

Anyway, once I return hope I’ll be able to send @vova the logs.


Hi @vova

Home from my travels earlier than anticipated, just sent you the logs of the recent occurrence.

I started Roon playing an album yesterday afternoon
and then stopped it after the first part of the first track.

I then left it overnight with the DAC powered up & with the Mac Mini not going to sleep
and tried to play the album again this morning.

It skipped through the tracks …

Regards, Mike

Mines doing the same. Windows 10 laptop>Uptone Regen>Auralic Vega DAC

First track appears to start and then it skips through each track in the queue.

Thanks, your logs are being analyzed.

Hi @vova

As I mentioned in a PM, the first set of logs may have been compromised.

I have just sent a second set of data which should clearly show the problem.
[I completely erased all the old logs, started Roon, started an album playing and after a minute or so of the first track stopped it, I then waited to the next day and started to play the album again. On the second iteration of this I got the skipping behaviour.]


Thanks for all the info in this thread. I’ll (finally) be home Friday and will submit my logs then.

I just had this skipping problem in one zone, MicroRendu + Geek Pulse.
Both SonicOrbiter + Geek Out and the 818 work fine.
Rebooted the MicroRendu and Geek, no change.

Everything worked fine yesterday.
No configuration change, but the Geek Pulse had gotten unplugged from power; rebooted everything, but I wonder if this loss ov connectivity could have left some lasting confusion. @vova?

Hi Anders

Did it happen to you before Roon 1.2.

I did not experience it before I upgraded to 1.2
[but I also upgraded to OS X 10.11.5 (from 10.10.5) at the same time
so it could be either or a combination of the two].