Roon skipping on playback

Hi guys, new here. Just set up Roon on a brand new Mac mini with M1 chip. My solid state hard drive is connected to my net gear XR 700 gaming router. The Mac is connected via Ethernet cable. All my Roon devices are connected via Ethernet also. Never had an issue when using other apps before Roon. Skipping occurs when streaming from my hard drive, also occasionally skipping to next track. Kinda expected this to work flawless seeing the Mac was purchased only for this application. I played music through the iPad that is the remote and it even skips playing through that.

Welcome Trent,

I haven’t upgraded to Ventura but some users with Ventura have been reporting some odd behaviour.
You might try searching for those threads.
But two common causes for your issue are network stuff (but usually wifi which doesn’t apply to you) and your DAC not being in exclusive mode with Roon.
Perhaps start with being sure you’re in exclusive mode.

1 Like

I’ll be honest. im not very tech savey, this exclusive mode is that a setting on roon somewhere. I must say im very disappointed with roon so far. I’ve literary spent well over a grand to get it up and running for a result that is quite frankly disgraceful. The 2 devices i play it through it are Auralic Aeries G1 and an OPPO 205, 2 very highly regarded pieces of equipment. Both have never had an issue before roon was introduced.

I just looked up exclusive mode. They don’t show with either device. The Aurilic doesn’t have a built in dac. It is connected to an external one. The oppo doesn’t have an exclusive mode in its setting on roon either. Is there tech support here at all?

There is support staff (although limited now as it’s holiday season) but there’s also a very knowledgeable community willing to help.
As I’m not using Ventura I might not be the best person to assist you but I’m confident someone more knowledgeable will step up.
In the meantime I’ll have a look at my Mac settings and report back.

1 Like

The exclusive mode settings are under Device Setup.
You get there by selecting the audio zone with that device.
Click the volume icon, then the gear icon, then device setup.

It also might help if you provided a screenshot of
Mine looks like this.

1 Like

I use my Mac less often and with a DAC connected to it via USB.
Thus I forgot exclusive mode doesn’t apply in your case as you’re using Roon Ready endpoints via Ethernet. Sorry about that.

I’m afraid I can’t help you here but I can refer you to another thread where folks are discussing some issues with Ventura.
I honestly don’t know if this is even relevant to you but it might be worth a look.

Local roon versus roon server (core) devices

1 Like

Hi, and welcome!

Roon skipping tracks is more often than not related to networking issues - I realize you are connecting core and endpoints by ethernet as recommended, but there are still other possible sources of interference. Here are some things to try:

  • Connect the drive with your music files to your Roon core Mac mini rather than the router, and point Roon to it
  • Direct your Mac mini (or router) to use Cloudflare DNS servers - System Preferences > Network > Advanced > DNS, remove the defaults, and use the IP addresses as shown in the attached screenshot
  • Use reserved IP addresses for your Roon core machine and endpoints
  • Power down your endpoints, remote(s), core, router, and your ISP modem. Restart them all in the reverse order. (I’m assuming all ethernet connections are direct to your router, but if you are using a switch then power cycle it as well).

As suggested by @Placebophile there are some issues with Ventura, but reading the forums these seem to have been (mostly) resolved with Version 13.1 so make sure your core is running that.

Maybe a Mod can move this to the Support thread?


Put this to a Support Thread and tagged @Support

Given holidays coming up, not sure how long a response would be…

Thanks guys for the warm welcome and assistance. I’ll try the things you have suggested and see how i get on. Thanks again.


I didn’t see if you were experiencing this issue with Qobuz, Tidal, local files, or all? If there are network issues, Roon can get impatient and skip to the next track especially when it’s maybe not coming in fast enough from your streaming service. So I’d Audit that and see if you notice a pattern or can isolate if one source is more problematic.

You mentioned you’re a new user but I didn’t see how large your library is, how many zones and if you’re using DSP. Roon does a lot of Background Audio Analysis when files are added to a library especially if they are local. It usually does this throttled in the background slowly and you don’t notice, but it’s possible to tell Roon to speed things up by increasing CPU energy to this. If per chance you changed the setting (under “library”) to something higher than “throttled” it could be as simple as your CPU is too busy processing your newly added library and can’t smoothly stream, especially if your library is large.

Also, are you running any other processes, start up programs, or other apps on this Mac? Apple isn’t as bad as PC vendors but they do like to make sure you’re configuring iCloud,and if you sign in it’s going to be busy syncing. they’ve got spotlight indexing and a few other things you don’t need on a machine dedicated to Roon. It’s possible those are taking resources Roon could make use of.

Not sure, but assuming your network speeds are ok these are the first things I’d take a good look at.

I think having your music connected directly to your core could rule out your LAN as a bottleneck, but that seems less likely

It’s also still not clear to me what your DAC is. The Oppo?

Hope that is useful

1 Like

Hi @Trent_Rosenberg,

It looks like you have some things to work with (fellow user suggestions). If you would, please complete the template below. I would also kindly ask that you supply 2-3 date/time/track played instances of the issue. I will be able to look at diagnostic logging and see what Roon thinks is happening at the time!

Here is the support template:

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM).

Networking Gear & Setup Details

Your networking gear (model of routers/switches/etc), connection types (Wifi/Ethernet), and any firewalls, antivirus, or VPN software.

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”.

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

1 Like

Good morning everyone, i followed all your suggestions. I believe it’s working properly now. I think the fix was i plugged in my SSD directly into my Mac Mini. I think having it plugged into my router was the problem. I appreciate all the help with this matter. I’m on a day off today so i will use it a lot and see if it performs correctly.


Good to hear - enjoy the music!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.