Roon Skipping Tracks and Playlist issue

Core Machine (Operating system/System info/Roon build number)

iMac (Retina 5K 27 inch 2019

3GHz 6 core intel core i5

Memory 32Gb

Catalina 10.15.5

Hybrid Drive


MacBook Air
1.7GHz Dual core intel core i7
Memory 8Gb

Catalina 10.15.5


Synology DS216Play

Running DSM 6.2.3

4TB HDD Raid 1

Total tracks currently 12275

Roon 1.7 Build 555 with latest updates applied
Preferred install is with iMac running RoonServer and Roon as Control so that Roon is always running whether or not Roon control is running. Also use iPad and iPhone apps.
However have also tried installing just Roon as control, core and output and this makes no difference to the issue.

Lifetime licence

Also have a Qobuz Sublime+ account

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

BT SMart Hub 2
Netgear 24 port gigabyte switch
BT Whole Home Mesh and ethernet (NAS)
Have tried iMac both ethernet and wireless

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

System Output plus Auralic Aries and Auralic Altair G1.
N.B. this issue applies whatever output device is used.

Description Of Issue

I recently purchased an iMac and removed Roon from my old MacBook Air and installed it on the much more powerful iMac.
I had never had any serious issues with Roon and have had a lifetime licence for 3 years. No drop outs no intermittency, nothing worth mentioning but this ‘upgrade’ to my system has created a big issue.

After a period Roon stops. Any attempt to play tracks from any source results in Roon starting to play a track but then after 2 or 3 seconds skipping to the next rack. No sound and no display of the sound. The period after which this happens is typically a few hours (3 to 16).

I note a number of similar support posts but there doesn’t seem to be a general fix.

I have also noted that when this happens going to playlists and selecting a playlist and trying to select Play Now doesn’t work, the button is the paler shade normally associated with what you see when you select the button- I have to select a track and ‘play from here’. This may or may not relate to the core issue.

Once the core issue arises nothing will fix it. The only way is to restart Roon (or if running with Roon Server just restart Roon Server.

I have tried both types of installation (i.e. with and without RoonServer). I have reduces testing to just using System Output to eliminate variables. I have tried using music storage on the local disk instead of the NAS. I have tired with albums and playlists bot local and Qobuz. I have tried disabling Qobuz. I have tried rebooting the router, NS, Switch, Mesh WiFi. All to no avail.

I have tried uninstalling and doing a clean install. I have tried creating a new library or restoring a backup. The problem persists.

I have also tried using my 2013 MacBook Air instead and that works without any issue with or without RoonServer, with or without Qobuz, with or without local storage of music files.

So given that I am testing on the same network with the same NAS, with both systems running on WiFi (except whilst conducting tests where I tried WiFi and Ethernet), both on Catalina, both using System Output the only key difference is the Apple hardware - but surely this shouldn’t lead to a problem.

I am currently running the MacBook Air with a second trial installation of Roon both to test that over several days no issue arises and to have something to use but as I take the MacBook Air with me when I go out. our am working away it is the iMac that I want to use for running Roon so it is available for y wife to use who is beginning to loose patience with the system…

I hope that the testing I have done will enable you to find a full solution.

Many thanks in anticipation…


I should add that in all cases Roon Radio is enabled and works on the MacBook Air but is never reached on the iMac

Hi @Marcus_Russell,

Thanks for reaching out and for the extensive testing you have done here!

Based on your findings, there seems to be something regarding the iMac that is causing an issue with playback, have you by any chance checked to make sure that Roon is added as an exception to your MacOS firewall by using these instructions and that it’s also part of any other firewalls you may have?

Are you by any chance running Little Snitch / Bullguard / Kaspersky on the iMac but not on the Mabook?

Is there anything notable that happens on the iMac after 3-16 hours? Does it automatically go to sleep and the issue only occurs once it’s woken up?

Hi Noris

Thanks for response.

No firewall set on the iMac. Not using any of the apps you mention but am running Sophos on the iMac and not on the MacBook (only as I recently rebuilt it and forgot!)

I’ll try adding it to the MacBook and see if that causes any issue.

Nothing noticeable happens after the 3-16 hour period. The iMac and MacBook both lock after 5 minutes and require a password to sign on.

Sometimes the issue occurs whilst I am using the iMac, sometimes when locked. IF I check the history I can see what track it stops at and this is always before the end of the PlayList.

1 Like

Hi @Marcus_Russell,

I would try temporarily disabling the Sophos in that case and verify if that triggers any change in behavior.

Could you please let me know the exact local time + date + track you next experience this issue on? This would be useful in case we need to do a deeper dive into diagnostics from the iMac.

will do both Sophos and as far as I can on time + date + track

1 Like

Hi Noris

OK restarted Roon at 06/08 21:26:09 BST
Log file shows
At 06/09 06:53:04 Warn: Track Stopped Due to Error
There after same error every 2-3 seconds and still running as at 06/09 10:10:10

Unfortunately Sophos seems to have made no difference but I am now restarting Roon having quit all applications and services except Roon, Safari and Mail.

I will let you know whether I get the error again having quit all other apps/services

As of this morning Roon is still running correctly for the first time in a long time. I checked the log files and only two ‘Track Stopped Due to Error’ messages. Roon Radio running now after a 12 hour local playlist.

So this suggests a potential conflict with one of my app/services. I will now reinstall Roon Server and restore from my last backup before I started testing and change nothing else and see what happens over the next 24 hours.

1 Like

Thanks for the info @Marcus_Russell, do let me know how further testing goes here!

If the issue reproduces, would you be able to zip up your Core Logs folder by using these instructions and upload a set to Dropbox / Google Drive / and provide a link?

Sure will do

1 Like

Hi Noris

Unfortunately the issue has returned and before I re-installed Sophos or other service/apps

I have sent you a PM with link to drop box and zip of the logs as requested.

Over to you :slight_smile:

Sorry Noris

I have also noticed that the symptom:

I have also noted that when this happens going to playlists and selecting a playlist and trying to select Play Now doesn’t work, the button is the paler shade normally associated with what you see when you select the button- I have to select a track and ‘play from here’. This may or may not relate to the core issue.

Persists after restarting Roon Server - It seems to only relate to Qobuz playlists (with the Q icon in the list of playlists - and the only fix for this seems to be to disable and then re-enable Qobuz in the services setting.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.