Roon skips to next track in queue before finishing current track


I have another issue with Roon, for my setup please see Roon loses control of audio device.

When I am playing an album or playlist from Tidal in Roon the playback randomly skips to the next track before finishing the current one. Error message: “Network or connectivity problem is interfering with Roon playback.” My own library is located on a NAS and plays fine so it does not seem to be a network problem and I have a very fast internet connection, streaming videos in fullhd without any hickups.

This is the log trace:

04/30 13:13:57 Trace: [prebuffer] status 441000/441000 (100%) @ 50/381 sec
04/30 13:13:57 Trace: [transport/raatclient] [Weiss Firewire IO Audio] GOT [7] {"status":"Dropout","samples":51571948}
04/30 13:13:57 Warn: [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream
04/30 13:13:57 Trace: [zoneplayer/raat] too many dropouts. stopping stream
04/30 13:13:57 Trace: [zoneplayer/raat] Endpoint Weiss Firewire IO Audio State Changed: Playing => Prepared
04/30 13:13:57 Trace: [transport/raatclient] [Weiss Firewire IO Audio] SENT [9]{"request":"end_stream"}
04/30 13:13:57 Info: [audio/env] [zoneplayer -> stream -> endpoint] All streams were disposed
04/30 13:13:57 Info: [audio/env] [zoneplayer -> stream] All streams were disposed

And my playback history as an example.

Settings: WASAPI in exclusive mode, buffer size 250 (was playing around with this but nothing changed), all Tidal tracks are 44.1k and upsampled to 192k.

Anyone else having similar issues?


Hi @Johni ---- Thank you for the report and sharing your feedback with us.

I just took a look at the other thread you are referencing in your post to get an idea of what your setup looks like :thumbsup: Moving forward, I saw that you had mentioned the following in your post:

“I have a wired network connection…”

Can you please expand on this information for me and provide the exact details of your network configuration/topology? Please be sure to include any networking hardware you are implementing in your setup, I want to have a clear understanding of what the chain of communication looks like and what “links” make up the chain (i.e routers, switches, repeaters, etc).


Hi Eric,

Lets start with the central hub in the entrance hall of the apparment:
Internet (download 250mbit/s, upload 25mbit/s) -> Cabel modem (Technicolor TC7200) -> Wireless gigabit router Netgear WNDR4500/N900 -> network cables to all other rooms of the appartment via inwall installation.

I have the HTPC running Roon described previously located in my living room. The LAN cable directly plugged into the wall socket, so there is a direct connection to the router and the internet without any other switches or repeaters.

The Synology DS214+ NAS is located in my office. Here I have a Netgear GS305 unmanaged Gigabit switch plugged into the wall socket and the NAS and my office computer connected to the switch.

I am using an ipad and an iphone over the wireless connection to control Roon.

Thats it, a fairly simple setup.

I restarted everything, including the modem and the router to ensure that its not some hickup that sometimes comes up over time. Anything else I can provide you with to help find the problem?

Thanks for your help!

I did some more testing. Apparently, its not just Tidal albums/songs which arent completed and skipped but also songs from my own collection, just much less frequently. Here a snapshot from a history of an hour playback.

Tested a bit more. Running Tidal App on the same PC since about two hours without any issues. None of the tracks were skipped.

Hi @Johni ---- Thank you for touching base with me and taking the time to answer my questions/share your observations. All of the provided feedback is very appreciated!

Can you verify the following for me:

  1. Are jumbo frames engaged anywhere in your configuration? If there are, may I very kindly ask you to disengage them.

  2. I understand from your other post that your core machine is running headless, have you tried the following yet (if possible of course):

  • Playing some content out of the unit via the headphone jack or USB connection to a DAC? If so what was the experience like?

  • Have you tried taking an album and moving it to the internal storage of this device to try to see how things function with NAS temporarily removed from the equation?


Hi Eric,


  1. I checked my settings and Jumbo Frames are disabled (I hope this is what you meant)

  1. Yes, I am running the media PC headless. Unfortunately, I cannot use USB or a headphone jack to connect to my DAC, it has XLR/spdif inputs only.
    I did copy a couple of albums to the SSD drive of the media PC to see whether I get the same error. After about 50 minutes the first track was skipped with the same trace log as before. So its not a networking issue. I even played the same track twice to show that the file itself is not corrupted. See the history screenshot below: “23 minutes ago” and “4 minutes ago”. The system is only running at about 25% so I dont see that as an issue, either.
    If I would have to guess, I would probably look at the WASAPI driver. Since I had the issue with the ASIO driver stopping playback from time to time I guess this could be very similar.



Hi @Johni ---- Thank you for follow up, the input is appreciated!

I must apologies as I may have not been clear enough in first part of my second question:

  1. I understand from your other post that your core machine is running headless, have you tried the following yet (if possible of course):
  • Playing some content out of the unit via the headphone jack or USB connection to a DAC? If so what was the experience like?

Looking past sound quality for a moment, I am curious to see if you were to say hook a pair of head phones up to the device hosting your core if you are able to playback successfully without the tracks skipping.


Yes, that works. I setup Roon audio to “system output” which is my integrated sound card on the motherboard (usually disabled). All tracks are played without any issues (NAS, Tidal, local).

I also tested the following: I disabled WASAPI exclusive mode but kept the output the same as previously (Weiss Firewire -> DAC). This also works without any problems. The audio quality is not as good since the OS mixer is used but this clearly shows that there is an issue with the ASIO and WASAPI connection between Roon and the Weiss firewire interface.