Roon skips tracks even from local SSD

Core Machine (Operating system/System info/Roon build number)

Intel NUC 10 i7 / Ubuntu Server / Roon 1.7 (610)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

AVM Fritz Box 7490, Core + SONOS Port on LAN (same switch), iPad Pro on WLAN

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

3x SONOS Play:3, 1x SONOS Port

Description Of Issue

I have my music collection (mostly mp3) on the NUC with the Roon Core on a M2 SSD. But Roon skips tracks very often. When I start to play a new album, about 40-50% of the time the first track is skipped - no matter if I play on the Port or on one of the Play:3. Pressing “play” again helps 99% of the time.

Is there anything I can do to prevent this? An overlooked option?

This is a real dealbreaker for me. Please fix this behaviour - and for Tidal titles too!

Hello @Stephan_Lachmuth, and my apologies for the issue here, but we’re happy to help! Does this behavior occur if you bypass the switch and connect directly to the router? Does it happen for any endpoint? For example, system output of your iPad?

Hi @nuwriy,

To connect the Core and the SONOS Port directly to the router is not possible, as the router is in a different room and there is only one cable going through the wall to the switch in the living room where the devices are.

A quick check seems to indicate that there is no skipping when playing directly on the iPad.

Can I check somewhere the reason why Roon skips?

Hello @Stephan_Lachmuth, what kind of switch are you using? Is it managed or unmanaged? If you do have a chance to connect the SONOS directly to the router temporarily that would help us eliminate potential variables and narrow down the issue. Thanks!

Hi @nuwriy,

the switch is a Netgear ProSAFE 16 Port Managed Switch.

I don’t know if it would help, when I connect the NUC directly into the second LAN port of the SONOS device?

Is there any way to detect in the logs what the reason for the skipping is? The problem still persists and it’s really annoying.

Hello @Stephan_Lachmuth, in our networking best practices we recommend against using a managed switch so I’d like to bypass it as a test. Could you please connect the Sonos directly to the router and see if you still have the issue? Please also try going to the core as you said earlier and let me know if either option works better.

I think you meant to say “recommend against using a managed network switch”?

1 Like

Hi @nuwriy,

Now I tried the following:

1.) Connected the NUC directly to the second LAN port of the SONOS Port
2.) Replaced the managed switch with a simple unmanaged one
3.) Connected the Sonos Port directly to the LAN cable from my FritzBox and the NUC to the SONOS Ports’ second LAN port

Still skipping.

Tomorrow I will take the NUC in the other room to be able connect it directly to the FritzBox as well. But I am very sceptical that it will change anything.

Maybe you could explain to me why skipping is a behaviour of Roon in the first place. As a user I would accept hiccups or small delays (even on live performances or operas) but just skipping a track is simply the worst “solution” for networking / performance / whatever problems I can imagine.

But maybe there are any “magical” settings I could try? Or will this issue be addressed in an upcoming update?

As I don’t use DSP, Roon could simply tell SONOS to play the original files without any RAAT / FLAC streaming overhead.

Any help is very appreciated

Stephan

Hi @nuwriy,

I have to admit, I’m quite upset (the verb I wanted to use instead was censored) right now.

I just did the following:

  1. Move the NUC in the other room to connect it directly to the FritzBox
  2. Connect the Sonos PORT directly to the cable coming from the router (thus disconnecting everything else from the network)
  3. Stopped everything on the NUC except Roon (Plex, own node.js server)

Guess what? The problem still exists and it even seems worse now. :frowning:

I can now observe the following behaviour very often:

  1. I start an album
  2. the first song starts to play
  3. after ca. 10 seconds it skips to the next song
  4. the app is not recognizing this! the progress bar stops but it pretends to play the first track

Are there any known problems regarding Ubuntu 20.04? Maybe in connection with the Mono framework? Or is it a Sonos Problem?

At the moment, Roon is almost useless to me. Now that I managed to set up almost everything the way I like it, this is a real show stopper.

Please help.

Thanks
Stephan

Hello @Stephan_Lachmuth, thanks for your patience while I consulted with my team. You asked for a list of things that could cause dropouts, here’s an article covering it. You also noted that playing to system output of the iPad works and doesn’t show the issue, right?

Lastly, have you tried to reproduce this issue with a PC or mac computer rather than your Linux core?

I think it might have something to do with adding multiple songs to the queue (i.e. playing whole albums). In some cases I can reproduce the problem almost every time (Bach Cantatas). When I start listening to a CD the skipping occurs. When I start a single song, not.

That is of course not a solution to my problem but maybe it helps finding the cause for it…

@nuwriy I will test playback on other devices tomorrow. I THINK on my Play:3‘s the problem is not present or at least not happening as often.

1 Like

Hello @Stephan_Lachmuth, sounds like a plan! Please let us know how it goes.

Hi @nuwriy,

the problem does not to exist when I play to my Play:3 boxes - at least I could not reproduce it today.

I also found a solution (more a workaround) to the problem with my Sonos Port: AirPlay! Since I switched to AirPlay I experienced no skipping at all. :metal:

Another advantage is, that the Sonos App now displays the title information and cover of the currently played track (instead of “roon_xxxxxx.flac”).

The downside is a lag (2-3 sec) when starting playback - while the position marker on the “waveform” is 2-3 sec ahead. But I can live with it.

Even if my problem seems to be solved now, I suggest you guys should look at “wired” Sonos Streaming to the new Sonos Port. In my opinion there is something wrong there.

But maybe you can add this to the networking documentation: Sonos skips? Try AirPlay when available.

Cheers
Stephan

1 Like