Roon slow to search and play

Roon searches for an artist can take up to 5 minutes.
Even when found and an album selected it can take up to 2 minutes to play.
I have a nucleus 1 server, a qnap NAS drive, about 1000 albums with approximately 17000 tracks and accessing Tidal along with Qobuz.

Hi @Wesley_Tinney,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this slowness always occur or does it only occasionally happen? If you reboot your Nucleus do things improve?

Do the 17,000 tracks also include TIDAL and Qobuz tracks?


The house is hard wired with Cat 6 with all hardware linked to and controlled by a D link:

There are 2 living rooms with a Linn streamer in each with Linn Akubariks in one of these and Linn Akudoriks in the other. Each of these rooms also has a Sony A 65 tv which also play through the speakers and a sky q box in one and a sky mini box in the other.

The property also has 4 bedrooms with Sonos controlling Kef speakers in each bedroom.

The cds are ripped to a QNAP NAS drive with a 6 terabytes hard disc and a mirror disc.

There is also a NUCLEUS server connected. The 1000 (approximately ) cds with 17000 tracks are the only tracks on the discs at present.

I trust this is enough detail.

The searches are always slow to return a result.


Wesley Tinney

Sent from my iPhone

I sent details of the systems 3 days ago and have received no response— the searches are taking even longer now.
How do I reboot and if I do will I need to reconfigure completely. The system was installed by my HiFi dealer.

Searches for an artist are taking over 10 minutes at the minute and no result has yet been returned.
I have still not received any response for my request for support.
When I search in Linn Kazoo results are returned very quickly.

Roon staff enjoying their weekend?

How to reboot your Nucleus is described here. And no, you don’t have to reconfigure because of a reboot.

A post was merged into an existing topic: Roon very slow!

Hi @Wesley_Tinney,

Can you confirm the model of the D Link? Are there any switches or other adapters in use?

As mentioned by Geoff, reboot instructions can be found here. Definitely let us know if there is any change after rebooting!

Can you also temporarily disable TIDAL and Qobuz and let us know if there is any change in behavior?

The response with your system setup came in on the same day as this post. Did you happen to respond via email to the notification that came in? Just to clarify here for the future, you’ll want to make sure to respond directly here in the Community forums.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.