Roon + Sonos not working

Since the beginning I have not been able to get Roon + Sonos working. There has been a minimum of support from Roon but they washed their hands of it. What happens is that if I send audio to a Sonos zone I get immediately a message after a few seconds “Roon lost control of the audio device”. I can see in the Sonos zone that it the roon.wav file is in the playlist and from Sonos I get the message that the track is not correctly encoded. Starting stopping track, hooking up everything wired, nothing works.

Any suggestions out there or people with the same problem?


For support you need to add @support



My main setup around the house is Sonos. Works without a problem with roon.

Is your Sonos on mesh mode? (Sonos Bridge)
If not:
Can you describe your wireless network?

Can you use other streaming apps with your Sonos without any issues?


Hi @Wim_Blauw ---- Thank you for the feedback and my apologies for the frustrations here. In the interest of getting this resolved for you may I very kindly ask you to please provide me with the following information to help in my evaluation of this behavior you are reporting to us.

  1. A brief but accurate description of your current setup as seen here.

  2. Please describe your network configuration/topology, as well as providing insight into any networking hardware you may be implementing. I want to have a clear understanding of what the chain of communication looks like and what tools you are using to make those connections possible.


1 Like

Also, you mention that you get a track not encoded correctly message? I guess, more information about that track? Does it occur with all music or only music like the referenced track?


what version of Roon you are running (Settings > About; If you’re running Windows, please let us know whether you’re running 32bit or 64 bit)
version 1.3 build 209, windows 10 64 bit

What operating system you are running (Windows 7; OSX 10.9; etc) windows 10
Basic information about the device you’re using (MacBook Pro 2011 w 4gb of RAM; HP Envy laptop w i7; etc).

Lenovo x220, see attachment

Describe where your music is stored -- this includes hard drive description and interface type (USB, Firewire, etc. If you are using a NAS or any other kind of network storage, be sure to include the information requested in the Network section below) **

on a RipNAS, running windows server 2003, connected with Ethernet cable to sonos player**

Let us know your collection size (approximate number of tracks) 13500

Network – KPN Experia router, wireless to laptop, wireless to sonos player/ripnas

1 Like

If you are using a Sonos Connect, I wonder what output you are using. When I use rca outputs into a set of powered speakers, Roon+Sonos works just fine. But on an occasion when I used the coax output from the Connect into my DAC and on to another set of powered speakers, it hardly worked at all and I got the messages you reported. I think the coax connection was the problem, but I got my Homeplug Ethernet stuff sorted out and went back to using my Sonicorbiter player without further experimentation. Good luck!

1 Like

Hi @Wim_Blauw ----- Thank you for following up and taking the time to answer my questions. Both are appreciated!

My apologies if I missed this in your report, but can you verify which Sonos device you are making use of?


1 Like

Just a SONOS connect, bought about 2009. I connect it via a coax to an iFi Mirco DSD and then to my amplifier. I tried the advice of the other poster, disconnecting the coax and playing directly with rca outs to my power amp but I am running into same problem

1 Like

Hi @Wim_Blauw ---- Thank you for following up and verifying that information for me!

Moving forward, I would like to propose the following test to see if we can trigger a change in behavior here. Can you try (temporarily) mounting the NAS + laptop via ethernet to your KPN Experia router and confirm if the performance of your setup improves?

Looking forward to your feedback!

1 Like

Hi @Wim_Blauw, @support,

I am a fellow Sonos user and I have the exact same problem as you after I started using Roon.

Problem experienced:
Frequent interruptions after I start playing some tracks with the message displayed: “Roon lost control of the audio device”.

I have a Sonos Play 5 (Gen 1) and a Sonos Connect running on the wireless network (not Sonos Mesh). Roon Core on a MacBook Pro (MAC OS Sierra) and the router is an ASUS DSL-AC68U with the latest firmware. I am running the latest most up to date version of Roon. I am grouping the Play 5 with the Connect and begin playing some tracks. Interruptions occur at unpredictable times (anytime between 2mins to 30 mins after I begin play) and the above message is displayed. Interestingly, if I use the Sonos app to play the same tracks, no issues with interruption occur. I am wondering if somehow Roon is a bit less resilient as compared to the stock Sonos app?

Any advice will be greatly appreciated.

many thanks

1 Like

A bit of an investigation and some experiments since my last post. Thought I would share my findings in case they are useful:

The issue encountered (Sonos disconnecting followed by the message “Roon lost control of the audio device”) appears to be affected by a number of variables (not just Roon).

I have been trying to change the Wireless channel on my router and Sonos performance improved when I moved to either Ch1 or Ch6. I am now using Ch6 and Roon playing through Sonos appears to be working OK so far. Things are still not as perfect as with the Sonos app. There appear to be one or two small stutters soon after I start playing music but things stabilise thereafter.

The Sonos app still appears to be a little bit more resilient but only just. I have been trying the Sonos app next to Roon (starting and stopping) to compare this resilience. Either way Sonos hates anything other Ch1, 6 and 11. This may be specific to my net but worth trying it out.

All the best


Just a final note to say that Sonos works well with Roon after the tweaks in my home WiFi. A strong and stable WiFi is the key and the problems I encountered were resolved.

Enjoying the music :slight_smile:


You mind sharing your tweaks for the benefit of the community?

Thanks! :smiley:

1 Like

Already done in post above my last :slight_smile:

1 Like

No change, still same problem

1 Like

Hey @Wim_Blauw – it’s unclear from your post, but were you still seeing these problems when connected over ethernet, as opposed to wifi? I want to be sure you’re experiencing this problem with a wired connection before we suggest next steps.


1 Like

All, thanks for all the feedback but no advice is resulting in any improvement,keep getting same problem & frustration. I will return to my trusty JRiver/JRemote set up, maybe in future I will return to Roon if my set up changes.

1 Like

I Have Ethernet connected sonod… Getting same disconnected message.
When watching the zones… The songs units seem to disappear and reappear randomly.
Sonos on its own in exactly the same configuration is ROCK SOLID… something Roon is doing is different and causing the unstable behaviors.

Hi @Jeff_White,

The current stable build of Roon, 242, has a known bug here the discovery timeout of Sonos devices was set very low. This means even very small network problems to make Roon think the device has disappeared and remove it from the audio device list/stop the music. If this is the problem you’re having, the music will stop and the speaker will disappear completely from the list in Settings -> Audio, then re-appear in maybe 30 seconds when we rediscover the speaker.

If it is that timeout bug we have a fix coming in the next release, whenever that is ready.

If you’d like I can take a look at your log file and see if it is in fact this bug or something else, here’s the knowledge base article on where to find them: Ideally I’d like a zip file or similar with the whole directory, uploaded to dropbox or similar. I can send you a PM with instructions for a place to upload if you don’t have something convenient.


1 Like