Roon + Sonos not working

I have had it on two endpoint. One is Soundbar + Connect + Sub (those are bundled within Sonos as one thing) and a room with two Stereo Play 1.

Well, it figures. This morning, I was playing the playlist with the reproducible-crash track, and it played without issue. Sigh. I suppose it’s not 100% reproducible after all. I hate bugs like this as a developer so much…

I will try a few more times to see if I can get a reliable reproduction case again.

Like RobOK, I noticed that once Roon lost control of the endpoint, the Sonos app was also not able to properly control it. It could play tracks, but couldn’t show correct Now Playing information. Interestingly, after a little while of not trying to use it, Roon was again able to control the endpoint. I didn’t do anything specific, like rebooting the Sonos, so I’m not sure what caused the issue to resolve.

The track is Apple Lossless, and I am using volume leveling, so I believe that Roon is already applying some DSP to the track. If I’m able to get it to reproduce again, I will trying turning volume leveling off to see whether that has any effect.

FWIW, here’s the info you requested:

Roon 248
macOS X Sierra Server 10.12.4
Roon Core is on a Mac Mini Server Late 2012. 2.6GHz i7, 8GB RAM, SSD.
Music is stored on a Synology 1515+ NAS, shared via SMB
Music is Apple Lossless, imported by iTunes.
I have roughly 8700 tracks
Endpoint is a Sonos ZP-80 running Sonos 7.3

Intermittent bugs are the best, the extra time spent hunting makes finally squashing them much more satisfying.

We’re trying to track down what I think is a related bug internally. So far I haven’t observed any relationship between files and where it crashes. I suspect but cannot prove that it is more of a networking problem than a file problem.

I could use one set of logs showing the crash to check if the symptoms match what we’re seeing.

Let me know if you find any sort of pattern, just wanted to say that we’re still looking at this.

Yes, this is what I had too. I couldn’t figure out how to explain it but you got it right – Sonos App could still play songs but did not show Now Playing song name. I opened a new thread to keep our issues seperate but we can look for commonalities too.

So far, no. I did have it lose control last night in the same fashion, while playing something totally different. I happened to be in proximity to the Sonos player at the time, so I just yanked its power and rebooted it.

@ben, if it happens again, how do I get the log you asked for?

Here are the instructions for finding the log files:

Take everything in the logs folder, zip it up into one file, and upload somewhere I can get it. If you don’t have a convenient place to upload files I can PM you instructions for one managed by Roon.

Roon keeps a reasonably long log history around, logs from ~24-48 hours ago should still be in there, so you probably don’t need to wait for the problem to occur again.


How has your playback been?


I haven’t had the problem again, but I have not been doing the same rapid track changes that seemed to be associated with the issue before.

I have seen the playback fail to start when I tried to change tracks, but I was able to make it start by hitting play a couple of more times.


Just wanted to respond to say that I know exactly the issue you describe. I have encountered it with my sonos speakers and I have found a way to ‘gently’ avoid it. Basically, if I quickly skip 4-5 tracks one after the other then Roon loses control of the audio device (in this case the Sonos speaker). Once this occurs then Roon cannot play anything for a while. I need to leave it be for 5 mins or so before it can ‘regain’ control of the sonos device. I avoid this issue by being ‘gentle’ when skipping tracks. I have not yet reported it but I know the fantastic Roon team can tackle this quite well :-).


Yes, this causes some of my Sonos problems too, but not all. I will try you more “gentle” approach to track skipping!

1 Like

I’ve been running Roon and Sonos very successfully for 3-4 months at least. I went away on vacation for 2 weeks, came home and my Sonos devices are no longer working with Roon. Note that I also have PS Audio DSjr (connected to network via its Bridge) and a MyTek Brooklyn (connected to Mac Mini running the Core) and both these devices still work flawlessly since returning from vacation.

I checked the two Sonos devices (Play:1 and Play:3) using the Sonos Application and can stream music to both via Amazon Prime music without any issues.

I’ve tried to disable and reenable the devices within Roon to no avail - still will not play through them.

When I returned home from vacation, booted up Roon and first thing I did was upgrade to 1.3 (build 259), upgrading the Core and all remote roon devices. Since experiencing this problem I refreshed to latest version of Sonos on both devices, still not working with Roon.

One thing I did notice is that Roon has a very bizarre IP address associated with both Sonos devices. I’ve checked the device IP addresses on my router and and they don’t match what Roon lists.

All my network devices are on 192.168.2.. Roon says the Sonos devices are sitting at 169.254..*. Roon does have all other devices (Core, MyTek, PSA DSjr, etc) with the correct IP addresses.

If I attempt to play anything to either Sonos device, I get no errors, the play button shows depressed but the song timer does not move. No music, no error messages, it just sits there.


1 Like

I just rebooted the Mac Mini where the Roon Core resides and the Sonos IP addressed all refreshed to their proper addresses (192.168.2.*) and everything is working.

Problem closed.

Is this problem still occurring for you @Yiannis_Kouropalatis

Hi @RobOK
I don’t have any further insight as I have decided to gradually move away from Sonos in favour of Roon End points. I disconnected my sonos components a few weeks ago so I have not managed to test if something changed with the issue. Prior to moving away from Sonos I was in touch with Roon Support regarding a slightly different problem with Sonos (Grouped Sonos Zones do not work when moving from the Sonos app to Roon, unless they are ungrouped first) and I provided detailed logs to help with diagnosis / resolution. Eric has been in touch since and I know support was closer to understanding the nature of the problem.

Despite preferring the tonality of the sonos speakers, I found that I much preferred the mini PC with roon bridge feeding my HiFi vs the Sonos Connect. So with a bit of heavy heart I decided to say goodbye to Sonos.


1 Like

thanks for the update… my Sonos is more embedded through my house, so not an easy transition. I have one USBoard end point which is cool, but just in one room. For me, I’ll probably move away from Roon rather than move away from Sonos at least for the foreseeable future.

No issues here sense last update.

1 Like

Tech Whisky,

I’m continuing to work with support on this. I have two theories:

  • problems are worse with a higher number of SONOS devices playing at once – say 5-7 or more, OR
  • problems worse with pre-existing groups (Sub + Play:1, or TV Bar + Play:1, etc.)

I don’t have any “proof” of those but just noticing when it happens more on my system. How complex is your Sonos setup? You use it a lot with never a “loss of control” error?


A post was split to a new topic: Sonos: Play 1 dropping connection

I just experienced this exact issue on one of my Sonos devices (a Port); the 7 others are working fine. It is the same if I try local or streaming (both Qobuz & Tidal).

I tried factory resetting the device, restarting Roon core, same behavior.

The error within Roon is “lost control of the device”. But if I’m in the Sonos app after starting play from Roon I can catch the “not encoded correctly” error.

Fwiw, I’m on early release. And though all my other Sonos devices are on one build, the port is on a slightly earlier build (see screenshot), but I can’t force it to update any further.

This may be of limited value, but: I had years of trouble getting Roon to play nicely with Sonos. I have a direct ethernet link to a Play Five in my living room and then six other connections via Sonosnet. I FINALLY took my old Chromecast audio and plugged it into the Living Room speaker. All I have to do now is go into my Sonos app and change it to line-in, and everything syncs all the time beautifully. No dropouts. The sound is great. If I want to listen to an audiobook, I just go back and change the setting in Sonos. (Yes, it’s Sonos great, and there are higher ends systems. But I made that choice long ago and am very happy with it - particularly now that I can use Roon without fail.)