Roon still hijacking iOS volume?

This was the original thread marked as fixed. Am I the only one still having this issue or am I doing something wrong?

Nah, it’s a long way from fixed, throw in Bluetooth speakers as well and things can get very messy indeed.

Having not seen any recent complaints, I thought I was doing something wrong.

What a mess.

My worst case scenario is listening through a Bluetooth speaker in line in mode connected to a Chromecast. The iOS devices end up trying to control the Bluetooth volume and Roon volume. Turning off BT on the iOS device makes it better. Niche case, hot mess…

How this is still not fixed is beyond me. This is genuinely dangerous.

What Roon ever decide is prioritise to fix in each update is a total mystery to us all. Maybe they have a big spinning wheel with all the bugs on and what it lands on gets fixed. Certainly feels like it.

3 Likes

Having the same problem here. I have no idea why this was marked as “fixed”. This is a dangerous issue that can damage equipment or worse someone’s hearing. This should be a top priority.

This volume issue doesn’t only happen with iOS devices.
I’ve had it happen using Roon remote using a Windows 10 PC controlling a Roon Rock NUC.
The volume control becomes unresponsive and then all of the sudden goes 100% volume. Lucky I’ve not blown the speakers (or my ear drums!) I have set the max volume limits and that works but this seems to be an ongoing issue.

Hi, @RBO, thank you for the report. Am I getting it right that you are seeing an issue with iOS local zone or it can affect any zone when you launch Roon app on iOS with Lock Screen volume controls enabled? Setting volume limits does not help to mitigate this issue?

Thanks!


Ivan

2 Likes

Hi @ivan and thanks for the quick response.

It’s only when when I try to play to the iPhone (its own speakers). Tried to reproduce it this evening and was unable to. I guess it does not always happen, reason I never picked it up before :man_shrugging:

Yesterday evening I wanted to play to my NAD zone and after hitting play, I realised I had the iPhone selected as the output and it started playing at 100% volume. I then turned the volume down, closed the app, opened it up again and volume went right up to 100%.

I then set max volume limit to 75, closed app and when opened up again, volume was back to 100.

That’s when I remembered this issue which I thought had been fixed.

Forgot to add that this only ever happened when playing to the iPhone and iPad speakers. Never happened when playing to any other endpoints. My lock-screen controls are disabled.

1 Like

I concur with what RBO has described above. And this happens regardless of whether the lock screen controls are turned on or off.

Thank you for your replies, @RBO and @acbarn. Could you, please, share Roon logs from your affected iOS devices with me?

You can do this following these steps:

  1. Terminate Roon
  2. Go System Preferences on your device
  3. Scroll down until you find Roon option
  4. Tap on it
  5. Toggle the switch for “Save logs to Files on next start up” option
  6. Launch Roon
  7. Go to Files → On this iPhone/iPad
  8. There will be Roon folder, you need to enter it and send the archive which Roon saved there.

Thanks!


Ivan

Logs sent.

1 Like

Hi @acbarn ,

Where have you sent the logs? We are unable to locate them on our end. Can you please upload them here and let us know after? Thanks!

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

@noris I emailed them directly to Ivan. I’ll upload now to your link.

@noris OK, the logs are uploaded.

@noris Any update on this? Roon is still cranking the system volume to 100 on my iPhone 13 Pro Max. This seems like it should be high priority.

I wonder what they will find is causing your issue. Since the update Roon is back to where it was and no longer takes control of the volume of my iPad, thank goodness…

It’s not happening on my iPad Pro, only my iPhone 13 Pro Max.

@noris Can I get an update please?