Roon stop working

Today after I got home from work, I saw that my server was offline.
I got this when I try to restart:

root@darkdreams:~# systemctl restart roonserver
Error: No space left on device

Nothing is wrong. Everything has plenty of space, Any ideas?

Without any more information I’d guess that the filesystem that holds your RoonServer and RAATServer directories is full. These are typically located in /var/roon.

Thanks for your reply.
The file system has plenty of space. What information you need specifically so I can post it.

Thanks for the help!

df -k
df -i
cat /proc/sys/fs/inotify/max_user_watches

As requested:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sun Jan 15 20:24:59 2017 from bio10

root@darkdreams:~# touch test
root@darkdreams:~# rm test
root@darkdreams:~# df -k
Filesystem 1K-blocks Used Available Use% Mounted on/dev/sda2 136739968 72664944 57105988 56% /
udev 10240 0 10240 0% /dev
tmpfs 3281028 9516 3271512 1% /run
tmpfs 8202560 16 8202544 1% /dev/shm
tmpfs 5120 4 5116 1% /run/lock
tmpfs 8202560 0 8202560 0% /sys/fs/cgroup
/dev/sda1 523248 132 523116 1% /boot/efi
/dev/sdb1 976759804 44152192 932607612 5% /media/hififs 1840245248 1468132800 372112448 80% /cloudmedia
tmpfs 1640516 0 1640516 0% /run/user/1000
tmpfs 1640516 0 1640516 0% /run/user/0
root@darkdreams:~# df -i
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/sda2 8691712 450662 8241050 6% /
udev 2048395 415 2047980 1% /dev
tmpfs 2050640 673 2049967 1% /run
tmpfs 2050640 5 2050635 1% /dev/shm
tmpfs 2050640 6 2050634 1% /run/lock
tmpfs 2050640 13 2050627 1% /sys/fs/cgroup/dev/sda1 0 0 0 - /boot/efi
/dev/sdb1 932673148 1890 932671258 1% /media/hififs 744224180 600 744223580 1% /cloudmedia
tmpfs 2050640 4 2050636 1% /run/user/1000tmpfs 2050640 4 2050636 1% /run/user/0
root@darkdreams:~# cat /proc/sys/fs/inotify/max_user_watches

try this and then try starting roonserver:

sudo echo 1048576 > /proc/sys/fs/inotify/max_user_watches

My guess is that you have something installed on the machine which is opening up a bunch of inotify watches and when RoonServer goes to startup it can’t allocate enough. The command above will increase the number of available watches significantly.

Do you have some kind of cloud-based storage software installed (crashplan, dropbox, etc)?

If the above fixes the problem then you’ll want to add the following into /etc/sysctl.conf as a long-term solution:


I actually do, I have crashplan. I am going to disable it.
I will apply your recommendation.

I will report back as soon as I get home.

Thanks again!

No need. This is a known issue with Crashplan although I don’t know if they are ever going to do anything to directly fix it. There’s a support note on their website:


So far so good.

I dont use crashplan any more, They push client updates constantly and brake it. Ugh.

Excellent! Glad it’s working!

1 Like

A post was split to a new topic: Roon stops playing (Ubuntu Server Core)