Roon stopped importing new albums?

Roon Core Machine

Roon Rock Version 1.8 (build 884) stable on Intel NUC i7 Gen 8 16 gb
Visible on the network, and communicates with clients (I can play music)
Says “There was an error checking for an update”

Networking Gear & Setup Details

Unifi Ethernet connected server and devices

Connected Audio Devices

Several, Windows, Bluesound etc

Number of Tracks in Library

5727 albums / 77480 tracks.

Description of Issue

I constantly add albums to my Roon share that is on a TrueNAS. Usually they show up on Roon after max 4 hrs. Now I added albums yesterday and the day before and they dont show up. Never happened to me before. I have restarted both the Nas and the Rock server, the little donut shows up, but it doesnt find the new albums. Anybody experienced this?


I think this is an issue with the back-end services infrastructure of Roon - I’m seeing the same error message at the moment.

The issue may be causing the import problem; I don’t know. One thing to check would be the rescan setting for your NAS in Settings > Storage > Edit.

Edit: the error message seems to have been cleared now. Are you still experiencing the import problem?

Staffan with Music stored directly on Rock, Roon gets notified of new files added, but this does not happen with music stored on a Nas.

I used to share my music off a Synology and had the same issue and had to scan the library everytime I added music. I ended up putting a 2TB drive in my Nuc and problem was solved. I now just keep the music synced between them and my main ripping and downloading computer.

Not perfect I know

I did Force rescan but it ends up with the same 77480 tracks, and the newly added albums are not visible

Just seen Geoff’s reply, so if this is a new issue then it could be related to that.

Have you looked at the logs or the skipped files from import

No skipped files. Where do I find logs?


But they are intended for Support. They are somewhat difficult to interpret for outsiders…

Yea, I had 21 logs, and I really dont know what to look for.

Probably best to wait for Support to pick this up (will be after the weekend at the earliest now).

If that error message (checking for update) has gone from your system, you could try rebooting the NUC to see if that has made any difference. Was your rescan interval set correctly in Settings > Storage > Edit? I expect it to be set to a 4 hours rescan interval.

Have you read this FAQ yet? It might help or provide clues.

Yes, none of that seems like the problem

I can play the files (theyre all flac btw) on Foobar on my laptop via the network, so they are not corrupt, nor unreachable and are in folders on my main Roon-folder that all Roon music is pointed to in Rock, just like the rest of the music. It has just stopped importing new music for some reason.

Oo! Can it be my 64 Gb USB stick holding the metadata that is full? It says
Size: 15,7 GB (16 881 090 905 byte)
Size on disk: 69,9 GB (75 058 118 656 byte)
63 010 files, 63 052 folders

I really thought I overdid it when putting that one there. Apparently not? Can I clean it up?

Well, no. It wasnt that. But kind of strange that the USB is full. I removed some old stuff from there. But my Roon installation seems to have hit a roof ant 77480 tracks. Have to wait for support.

I tried a Force Rescan today as well, its fast, more then 1000 tracks per second. It goes up to a higher number real quick, 78XXX something, then back to 77480 track imported and the most recent added albums in my Roon folder are not in the Roon inventory.

I"m not sure what you mean by this. The Roon database resides on the PC’s main drive. Can you explain? Is this a drive you are using as a backup?

If so, depending on how the drive is formatted, backing up thousands of small files can take more on disk space than the actual size of the files.

Bad description from my side. I do two backups every 4 days, one to the 64 Gb USB drive, and one to Dropbox. It wasnt the issue though but I was surpriced it was so full.

Ah, then as I mentioned the issue is that the drive holding the backup is set for larger default cluster sizes than the files being backed up; which results in a bunch of small files taking up larger disk space.

Crude example, if your drive is formatted as Fat32 then the default cluster size is 4KB. If the file being copied over to this drive during the backup is less than 4KB, it is still taking up 4KB of space. This can add up to a lot of wasted space with thousands of small files.

That sounds plausible. I might look into reformatting it, but first I really would like the problem with that my albums doesnt get into the inventory solved. Hoping that a support tech will show up here.

NAS notifying the RoonServer when something new has been added has been an issue for some. Usually, a rescan will fix this. But, since that didn’t work,

Have you tried rebooting the PC running TrueNAS?

Have you run out of inotify watch handles?

Check to see if the max number of inotify watches have been reached:

Use tail with the -f (follow) option on any old file, e.g. tail -f /var/log/dmesg: - If all is well, it will show the last 10 lines and pause; abort with Ctrl-C - If you are out of watches, it will fail with this somewhat cryptic error:

tail: cannot watch ‘/var/log/dmsg’: No space left on device

Otherwise, while you wait, how about a test. what if you created a new directory on the TrueNAS, not where you are currently storing the rest of your music, and copy 1 of the new albums that are not being detected there. Then go to Settings Storage and add that new location. Does the album show up?

1 Like