Roon stopped playing to Sonos, AirPlay since Build 334

Hi there,

Quick run through of my setup:

Roon Core running on Netgear 524X
Library points at iTunes music folder on the above NAS, with about 13,000 tracks
Gigabit LAN with 2 D-Link switches distributing LAN throughout home.

Sonos devices:
1 x Play:1 (Office, Wired LAN)
1 x Play:1 (Kitchen, Wireless)
1 x Soundbar + Bass pairing (Living Room, Wired LAN)

Airplay Devices - 2 x Sky Q set top boxes, both Wired LAN
Router is an Netgear ORBI, with 1 satellite unit providing extended coverage.

Since build 334 was installed, Roon will not play to any endpoint. It will now not even play to the speakers in my Windows 10 Laptop which is bizarre.

I’ve tried:

  1. Playing to any endpoint on Windows 10 Laptop
  2. Playing to any endpoint from the Android app
  3. Playing to any endpoint from the iOS app

I’ve reset every piece of equipment - wireless router, both switches, the NAS box and all sonos devices and no luck.
I can confirm the Sonos devices, NAS box, and ORBI router are all on the latest firmware.

If I open the Sonos app and play to an endpoint from my Windows laptop or my Android phone - it works.

Any ideas?

Thanks for sharing your report with us, @Duncan_McDonald!

So we can get some additional insight into what may be happening here, may I ask that you please elaborate on the above? Are you able to see these zones in Roon? If you try to play to them, what happens? Does the slider progress? Are tracks skipping around? Are you receiving any error messages?

Do you have a firewall enabled on the Core machine? If so, does disabling the firewall yield positive results?

Can you confirm that you are able to see the Core machine over the network from other devices?


Hey Dylan,

To answer your queries, roon can see (detect) all the devices - I can switch freely between them in the Windows app. When you press play on a track the play button changes to pause (as though the track has started), but neither the progress time indicator, or the audio waveform move or progress. If you click to switch zones the tiny bars icon that sits next to the active audio endpoint in the list of zones is “moving” up and down (so part of the app thinks it is playing something) but no sound.

This stays like this for about 30 seconds or so (on the sonos endpoints) before stopping or in the case of my default audio device (for example my laptop speakers) it gives up after about a second.

No error messages, and no skipping, since the track doesn’t appear to move or progress at all.

There’s no firewall on the core and never has been, and I can browse to the machine via network shares and its Web interface with no problem.



Just some more info - I thought I’d play a song in the Sonos app (which works) to my Office endpoint, pause the playback then open Roon and try and play the same song to the same endpoint. Sonos throws this error:


But I’m not sure if that’s just because the sonos is “locked” by the sonos app and it’s complaining that something is trying to steal it, or it’s related to the problems I’m having?


Ok - another update!

Just to try and narrow things down I’ve installed “Emby” on to the ReadyNAS, pointed it at my Music library, then launched the Windows app “Ember” and connected to the NAS service. I’ve then chosen to connect to another sound output and it provides me with my Sonos devices as “DLNA” endpoints - and they work and play the music?


Thanks for the updates, @Duncan_McDonald!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Hey Dylan,

No problem:

Played a track to Office Sonos Play:1 at 10:26:00 - track stops after exactly 30 seconds, no sound produced.
changed audio zone to Default Output, currently set as my Laptop’s speakers - played the same track at 10:28:30 and it gives up instantly.



Hi @Duncan_McDonald ---- Thank you for the continued feedback and insight, but more importantly thank you for your patience here.

Continuing forward, now that we have a sense as to when the error(s) occurred I have enabled the mentioned diagnostics from @dylan’s post above. What this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our serves. We will be sure to confirm when the report has been received so you know that we have it.


Update: Confirming that the diagnostics report has just arrived and is now attached to your ticket for review by a member of our tech team.

Hey @Duncan_McDonald,

Thanks for your continuing patience here!

While the diagnostics report is under review by the team, I would like to propose the following to see if we can trigger a change in behavior with your setup. Please see below:

  • Before anything, please create a backup of your Roon DB.
  • After the backup has been created please close ALL active instances of the Roon application (core, remotes, and any bridge devices).
  • Once the application is completely inactive please locate your “RAATServer” folder on the machine currently hosting your core. The RAATServer folder is going to be in the same directory as your Roon DB, so the directions found here will help to locate it.
  • When you’ve located your “RAATServer” folder on the core machine using the directions posted above please rename the folder to “RAATSever_Old”.
  • Finally, please re-launch Roon and confirm if there is any change in behavior.


Note: Do not delete the “RAATServer_Old” folder.

Thanks Dylan, I will give this a go… Although it may take a while as the core runs on my readynas and I’m not sure about navigating my way though a Linux command line!

Will update soon,



Hi Dylan

Did what you asked and no change I’m afraid - think this is what you meant:


Rebooted the NAS too just to be sure and no difference.



Thanks for giving that a try, @Duncan_McDonald!

Since that didn’t yield any different behavior I’d like to propose another test that will allow us to narrow down where the behavior may be stemming from.

If you temporarily use your PC as the Core machine for Roon is the experience the same or does this behavior go away on the new Core?


Hi Dylan

I can, but could you give me rough instructions on how to do that - I’d want to be able to easily switch back to using the core on the NAS if need be?



Sure thing, @Duncan_McDonald!

For this test I don’t think it will be necessary to move your entire database — testing with a new Core will give us the data we need. On the PC, follow the instructions below:

  • On the Windows machine, in Roon, go to Settings > General > Disconnect
  • Next, when it asks you to choose the Core machine, choose This PC
  • Set up a new database
  • You don’t need to import your entire library. If you have a TIDAL account you can import that. If not, you can import a small portion of your library just for testing purposes

Once you do the above try playing to the same zones as before. Has the behavior changed with this new Core machine?

When you’re ready to switch back just go to Settings > General > Disconnect and select your NAS Core again.


1 Like

Hi Dylan

Thanks for that - ok, so running the core from my Laptop now works to all Sonos devices. I can also play to sonos now from my mobile apps, once they connect to the new core.

So presumably there must be something up with the NAS core - any ideas what we can do next as having the core on the Laptop is not a permanent fix (but I totally get that we needed to try).



Thanks for testing that out, @Duncan_McDonald!

That’s definitely a good data point and should help the team narrow down what may be happening.

The team has suggested another test for the NAS Core machine. The team noticed that the tracks that were being played in the diagnostics report were all AAC files. Do you have any FLAC or WAV files that you could try on the NAS? If so give those files a try and let me know if it’s the same experience.


Hi Dylan

I don’t have any FLAC or WAV I’m afraid, though I did try an MP3 and it didn’t play either from the NAS core?

Is there something I can download in FLAC that I could purchase and test with as an Album?


2L has free download of the same music in many different Flac formats, go for the CD column.

Thanks for that Daniel.

Dylan - downloaded a FLAC album and the behaviour is the same from the NAS core - no playback.

Starting to look like it’s the core on the NAS - but I don’t understand what’s changed other than the update to Build 334?


Thanks for giving that a try @Duncan_McDonald!

Next, I’d like to try a completely fresh database on the NAS Core and see if the issue persists. Please see the instructions below:

  • Create a backup of your Roon database
  • Locate your Roon database according to these instructions
  • Rename the entire RoonServer folder to roon_old
  • Relaunch Roon, sign in, and configure a new install

Once you’ve done this try playing files to these zones and let me know if the issue persists!