Roon stopped seeing Hegel H190

Roon Core Machine

I’m using Roon for Mac, version 2.0 (build 1303).

Networking Gear & Setup Details

My Mac is connected to WiFi exposed by ASUS ZenWiFi AX XT8. No VPN.

Connected Audio Devices

I’m using Hegel H190 which is connected via an ethernet cable to the mentioned ASUS router. Hegel H190 has the latest firmware installed: p5123.32.0.

Number of Tracks in Library

About 10k tracks.

Description of Issue

For over 4 months, I was able to stream my music from Roon on Mac to my Hegel H190 flawlessly. Everything worked fine until today. I opened Roon and noticed that my Hegel was not listed in my audio devices list. When I went to the Audio tab, it wasn’t listed there either. I tried everything I could to fix the issue on the Hegel:

  • restarting
  • removing the power cable to restart the Internet connection
  • forcing a firmware upgrade
  • resetting to factory settings

No luck there. What’s really interesting is that it all worked without any problems for so long and it just suddenly stopped working, not sure what might have changed in my setup. Now, Hegel is sometimes seen in Roon as an Airplay device, but even then I wasn’t able to play music through it. I can choose it as the audio device, but the playback never starts. Most of the times it’s not visible as a Roon Ready device or an Airplay one.

Everything seems to be working fine from Hegel’s point of view - I can access the machine using its web interface without any issues. Also, my Mac sees it as an Airplay device in the Sound tab of the System Preferences. And I can play music using it this way. That’s why I think it could be a problem on Roon’s side.

Hope this is helpful, please let me know if I can provide any additional information to make it easier to debug.

Thanks

Is the Hegel on the same subnet as your Roon core?
Be sure the first three numbers in the IP addresses are the same. Like 192.168.0.xxx and 192.168.0.yyy?

Have you tried connecting your Mac via ethernet to the Asus?

Yes, Hegel is on 192.168.50.100 and Roon is on my Mac with the following IP: 192.168.50.169

However, now I see that there could be something wrong with Roon Core… The following address should open some kind of a web interface, right? http://192.168.50.169:9300/display/

It returns an error: " This page isn’t working".

I just tried it, no luck… Good suggestion, though!

1 Like

When you tried this, did you restart your Mac so your Asus could assign an IP, it might have just stayed on WiFi.

I just did that and checked that a new IP was assigned: 192.168.50.10. Still no effect.

Also, I didn’t change anything in my setup recently, so I’m thinking it’s either something that got updated on my Mac or in Roon that caused it.

1 Like

Any firewall enabled on your Mac?

If not

I’d be tempted to recommend a database backup, reinstall etc.

@support

Have you tried another ethernet cable between router and H190? Also, assume you turned the wifi on your Mac off when you connected it via ethernet?

1 Like

I disabled it, nothing changed. Also, I tried to use my GF’s PC laptop and everything worked fine with my previous WiFi setup, so it must be something related to the Mac or its setup.

Yes, the WiFi was turned off and I tried two different ethernet cables.

I just renamed my Roon, RAATServer and RoonMounts folders in the Library, removed Roon from Applications and performed a clean install - nothing changed.

Does your H190 appear as an Airplay device from within MacOS - e.g. my H390 does:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.