Roon Stopping (and sometimes restarting)

Roon Core Machine

Roon runs on a SonicTransporter i9 with their own OS (sonicorbiter).
Intel i9 (9900 8-core)
8 GB RAM
ROON core is on this machine
HQPlayer is also on this machine

Networking Gear & Setup Details

Fios Gig Service goes to fios router to Melco S100 switch
SonicTransporter runs ROON and HQP then it sends music to a ORendu then DAC. This is controlled by an IPad Pro.

Connected Audio Devices

The SonicTransporter is connected to a opticalRendu with a fiber cable.
A USB cable then connects to a Denefrips DAC

Number of Tracks in Library

Have about 1500 albums - 300 local and 1200 (total) with Tidal & Quboz.

Description of Issue

I am getting random stops in playback. Sometimes it just stops and sometimes it restarts after 3-5 seconds. Looking at the ROON logs there seems to be an issue - it keeps showing RAAT lost the connection with the iPad and sometimes iPhone. Since these are just being used as remotes I don’t understand this. The ROON cache often seems high but I have cleared this and it doesn’t solve the problem.
Please help

One other fact - the iPad is an 8 with 14.7.1 software.

This just happened again and here is a picture of the logs

@support - any idea what is going on?

Hey @DJD,

Thanks for following up and for your patience while we returned to work after the weekend.

I wonder if you’ve tried rebooting your Core since this started happening? If you haven’t, could you please:

  • quit Roon on your SonicTransporter
  • turn off the SonicTransporter
  • unplug it for a few minutes
  • plug it back in and turn it on
  • launch Roon

Any change?

Have done that many times. Can you tell anything from the logs?

Hello @DJD ,

Can you please upload a full log set from the SonicTransporter to Dropbox / Google Drive and provide a link? Do you notice RoonServer logs also ending or does the music playback just stop? Does the issue impact multiple zones?

@noris I tried to download the logs from the SonicTransporter i9 but they are only showing today (I guess what is visible to me is only from when it was turned on last and I shut it down daily). The logs from today won’t show the stop problem. It last occurred around Oct 1. Since then I have been trying to troubleshoot and have taken the optical rendition out of the loop and also not used HQP. It would be helpful if you could give me a reading on what you see in the two screen shots I sent with my request for support.

Thanks Dan

I talked to the server folks and may be able to get you more logs - will try to send tomorrow if I am successful.

@noris - Noris - can you email me your email so I can add it to google drive. I have more logs, but they still may not go back to Oct 1 when the last issue occured.

@noris Here is a link to the logs on Google drive:
Link deleted.

They only go back a few days. The actual stops are shown on the two screen shots I took when it happened and previously posted - Let me know if you don’t have these and I’ll post them here.

Let me know after you view/download from Goggle Drive so I can ‘close’ it.

@noris I’ve deleted the link. Can you please review the image of the logs from the day it happened and let me know what you think is going on?

@noris @beka Response?

Hi @DJD,

Thank you for sending the logs over and for your patience here while we’ve had a chance to review them, especially after the holiday weekend here in USA.

We managed to download the logs before you removed the link, and looking over them, we are seeing some sporadic network errors. You appear to be getting DNS failures according to the log.

How do you have your router’s DNS servers configured, can you please try to use Cloudflare DNS, Quad9 or Google DNS if you are not using either of these services yet?

As for the issue itself, the logs you sent do not contain the timestamp from 10/1 to check what happened right before, but have you by any chance reached out to SmallGreenComputer Support yet? You can do so by clicking on “Contact Us” (bottom right) on their website:

It would be a good idea to reach out to them to see if they are noticing any issues on the hardware side, as well as to see if they can retrieve/look over the system-level log on this unit for any further clues. Thanks!

@noris @agillis I have the DNS servers set to Goggle DNS’s. Also, I have been talking to SGC and they said I should have you review the logs. What would likely be the cause of sporadic errors?

Do either of you have anything to suggest/offer to fix the issue?

The sonicTransporter uses Google DNS by default. @noris did the logs show anything.

Hi @agillis ,

Nothing notable that I could see in the logs except for sporadic NameResolutionFailures with our login servers, Qobuz and discovery services, and lots of traces related to HQPlayer.

Have you been able to retrieve the system-level logs from @DJD 's Core? Perhaps those will provide some more clues. I will also PM you a link with the logs from DJD’s Core.

@DJD - Can you please let us know when/if the issue occurs again? If you are able to reproduce the issue without HQPlayer in the mix, that could also allow for some clearer logging. Thanks!

@noris @agillis ,

Thanks for the response. To try and decipher the issue I have pared the system back. I took the oRendu out of the system and am going directly from the sonictransporter to the DAC with a short USB cable. I also started by just doing local files from my NAS (no streaming) with ROON. After 4-5 days without stops I started using Tidal/Qobuz. After 4-5 days without stops, I started using HQPlayer (and Tidal/Qobuz) but only with PCM. So far I haven’t had any stops with this either. Next I will do DSD with HQP. After that I will go back through the same routine but with the oRendu in the chain. I’m open to any other suggestions???

Try using the Rendu but with no HQplayer

Andrew,

I’m about to put the Orendu back in the system. It seems there are several ways to do that. Connect it to 1G ports on the switch with either fiber or Ethernet cables. Also, it appears it could also be connected directly to the i9 via fiber. Of these three options, which one do you recommend for stability (forgetting sound quality for now)?

Thanks