Roon stops playing when starting a new song [Duo 2 CPU]

I have an inconsistent problem. Roon can stop playing when a new track. It’s almost as if the effort of getting a new track up - I mostly shuffle big playlists - is too much for the hardware. Roon can stop several times in an hour or wait for a day or two before the music stops. Today I’ve restarted Roon 5 times.

My MacBook Pro should be meaty enough to run ROON and only ROON, surely?

My system.
MacBook Pro - 2.66ghz, Intel Core Duo 2, 8gb ram. Wired connection to ethernet switch.
Seagate external, portable usb drive - 2tb. USB powered.
Meridian MS200 wired to ethernet switch.
Meridian 568.2
Meridian M100 speakers

Any ideas of what I can try to isolate the problem?


Are you enabling DSP Headroom adjustments within Roon? In my configuration (MacBook Pro i7 Quad Core), I found it helped to disable that setting.

Are you using HQPlayer filters? I found that the poly-sinc-xtr filter was another factor causing Roon to pause between tracks. I had better luck with poly-sinc-short and minring-fir filters.


Just had a look. Headroom adjustments were enabled but were set at 0. I’ve now disabled that option and also the Parametric EQ. I’ll see how that goes.

Not using HQ Player.

Thanks for the suggestions.

Stopped again with the hour.

Hi Graeme,

A Core Duo 2 is under the minimum recommended spec for a Roon Core and you can expect performance to deteriorate as your library, playlists or DSP usage make increased demands on your CPU.

You might consider building a dedicated Roon server with ROCK. I think the i5 is a good performance point but a smaller library can operate with an i3.

You could then use the MacBook as a Control only.

Thanks, Andy. Never occurred to me that the MacBook Pro would be under specced. I’ll look into building a server with ROCK.

Graeme, what are you using to control Roon? And do you have the full version of Roon or Roon server installed?
Can I suggest something as a stop gap? If not already done back everything up, remove Roon and put RoonServer in its place. You will need another device for control. You should find this works better and if it doesn’t your issue may not be entirely down to the Macbook. An upgrade is still required but I have had Roon running on Atom based chipsets with less problems than you have.

Perhaps we should flag @support here.

There are several other people reporting about a similar stopping problem.

There’s a known stopping issue with streaming to Devialet gear which is being worked on. I believe other stopping issue threads have either been resolved or had other causes identified. Please PM me exceptions if that’s not the case.

Thanks, Henry. I’ll try that whilst I figure out which hardware upgrade route I want to go.

Over two days now since going over ‘headless’. No stops at all. Thanks for the help!

1 Like