Roon stops working unexpectedly - Windows shuts it down

Core Machine (Operating system/System info/Roon build number)
My Core is a Lenovo Idea Pad 480 running Windows 8.1, 8 GB of Memory, 64 bit running Roon v.1.16 build 416. My library is stored on WD Elements drive connected to the Lenovo.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
The Lenovo is connected via an ethernet cable to an Arris Model DG2470A Router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
A Meridian Media Core is connected via an ethernet cable to the aforementioned router.

Description Of Issue
Roon won’t run for more than 30 seconds or so.

I get a Windows message that says the program stopped working - followed by "Roon has stopped Working. A problem caused the program to stop working correctly.

Windows will close the program and notify you if a solution is available. Close Program. " Windows help isn’t much help.

Exactly what model and spec machine is the core running on. You don’t mention if it’s SSD for the boot drive, nor cpu spec. Are you running the the 32 or 64 bit version? Have any changes been made, like widows update or roon update?

Thanks for your reply. The Core is a Lenovo Idea Pad 480 running Windows 8.1 with 8 GB of Memory and 64 Bit. The drive on the Lenovo is a Samsung SSD 850 1 TB. I am running Roon v. 1.16 (build 416). The library is stored on a WD Elements drive connected to the Lenovo. I thought I included this information - with the exception of the details on the SSD - on the original post. I only raise that in case you are requesting additional information I did not provide. If that is the case, I apologize as I might not be understanding the question. There have not been any recent roon or windows updates. Roon was working all day - and, then the aforementioned issue started.

So, Roon was working perfectly well (for how long: days, weeks, months?), and then something changed, and Windows (8.1) says it will in future shut it down after 30 seconds or so?

The trick is thus to identify what, precisely, has changed. Are you sure that there hasn’t been a Windows Update installed recently? Check in Settings/Windows Update/View update history to make sure. I’m also assuming that you haven’t installed a new app or application that might have caused the issue.

Does the Windows Event Viewer give any clues as to why Windows is shutting down Roon? In the Event Viewer, look in Windows Logs/Application and filter on Critical, Warning, and Error messages to see if there are any connected with the running of Roon…

Hi @Michael_Riffitts,

Can you please double check to make sure that Roon is still allowed in the Windows Firewall and also past any Antivirus Firewalls you may have running on that PC? You can use these instructions to verify the Windows aspect, and as a temporary test, I would check to see if temporarily disabling any Antivirus Firewalls causes a change in behavior here.

If you have already checked both of these aspects, I would next check the Windows Event viewer for any clues as @Geoff_Coupe suggested, and if you see anything related to Roon show up there, can you please share a screenshot here by using these instructions?

Hi, Geoff. Thanks for responding. Yes, Roon was working perfectly fine. I did determine that a Windows update immediately preceded the issue. I used System Restore to revert to an earlier version of Windows, uninstalled Roon and reinstalled Roon, but I am having the same issues. I’ve included screenshots from the Windows Event screen and the report sent to Windows. Thanks for any additional help you can provide.

Hi Noris, I don’t think it is any anti-virus/firewall issue. Roon is an allowed application in Windows firewall, and I am not running any other virus protection. A Windows update preceded the issue, but when I restored Windows to a prior version using System Restore and reinstalled Roon, I have the same issue. Please see the screen shots from the Windows Event log and report sent to Windows. Thanks for any help you can provide.

I just tried installing Roon on another laptop (Acer) running Windows 10 and using the same WD Elements drive and got the same result, i.e., Roon shuts down after about 30 seconds or so. I also tried installing Roon on a MAC and using a La Cie hard drive for the library (3TB) - same result. Thus, same result on two laptops with same external WD hard drive and MAC with La Cie hard drive containing library copied from WD drive.

What is going on? Could it be the router? I’ve attached the event logs from the laptop running Windows 10.

Hi @Michael_Riffitts,

Thanks for sharing those screenshots. I am wondering if this issue is possibly media or database related, if you start Roon fresh without the hard drives added as watched storage locations on one of your Cores affected by this, does the same behavior still occur?

You can try setting the current database aside for one of your Cores by using the following instructions:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • See if same behavior persists

Hi Norris, I tried replacing the ethernet cable that connects the core to the router - and, used a different port on the router. So far, that seems to have done the trick. Thanks, Michael

Hi @Michael_Riffitts,

Thank you for the update here. I spoke to our technical team regarding those traces and they appear to be networking-related.

If this issue occurs again, I would take a look to see if there are any network traffic-shaping tools on affected machines and also make sure that your router is up to date.

If the Ethernet cable and router port change allow continued stability please do let me know. Thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.